質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.12%
Anaconda

Anacondaは、Python本体とPythonで利用されるライブラリを一括でインストールできるパッケージです。環境構築が容易になるため、Python開発者間ではよく利用されており、商用目的としても利用できます。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

受付中

Python condaでのパッケージインストールエラー

104kazK
104kazK

総合スコア14

Anaconda

Anacondaは、Python本体とPythonで利用されるライブラリを一括でインストールできるパッケージです。環境構築が容易になるため、Python開発者間ではよく利用されており、商用目的としても利用できます。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

2回答

0リアクション

0クリップ

17531閲覧

投稿2019/06/28 02:28

編集2019/06/29 06:10

前提・実現したいこと

下記サイトで紹介されている顔画像のクラスタリングをしたく、Pythonをはじめました。プログラミング自体は少しかじっている程度です(MATLAB,R)。
検索するとPythonにはAnacondaがいいということなのでインストールして、anaconda promptにて当該クラスタリングプログラミングに必要なパッケージを導入しようとやってみました。

発生している問題・エラーメッセージ

conda install -c conda-forge opencv は無事に動き、インストールできたようです。次に conda install -c menpo dlib でエラーが表示されます。内容は UnsatisfiableError: The following specifications were found to be incompatible with each other: - anaconda-navigator -> pillow -> jpeg[version='>=9b,<10a'] - conda-forge/win-64::jpeg==9c=hfa6e2cd_1001 - h5py -> hdf5[version='>=1.10.4,<1.10.5.0a0'] - imageio -> pillow -> jpeg[version='>=9b,<10a'] - jupyter -> qtconsole -> pyqt -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9b,<10a'] - matplotlib -> pyqt=5.9 -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9b,<10a'] - navigator-updater -> pyqt[version='>=5.6'] -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9b,<10a'] - pillow -> jpeg[version='>=9b,<10a'] - pip -> python[version='>=3.6,<3.7.0a0'] - pkgs/main/win-64::hdf5==1.10.4=h7ebc959_0 - pkgs/main/win-64::libtiff==4.0.10=hb898794_2 -> jpeg[version='>=9b,<10a'] - pkgs/main/win-64::qt==5.9.7=vc14h73c81de_0 -> jpeg[version='>=9b,<10a'] - pyqt -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9b,<10a'] - pytables -> hdf5[version='>=1.10.4,<1.10.5.0a0'] - qtconsole -> pyqt -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9b,<10a'] - scikit-image -> imageio[version='>=2.1.0'] -> pillow -> jpeg[version='>=9b,<10a'] - seaborn -> matplotlib[version='>=1.4.3'] -> pyqt=5.9 -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9b,<10a'] - spyder -> pyqt=5 -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9b,<10a'] - wrapt -> python=3.4 です。

試したこと

まずはjpegのバージョンが問題かと思い、
conda install jpeg=9b
をやってみましたが、その後走らせても同じエラーがでます。
そもそもエラーの内容がよく分かってません。
ご教示頂けますと幸いです。

追記*****
アンインストールして最初から全て管理者権限でやってみました。エラーは変わらずなのですが、jpegを9cにしてやったところエラーの種類が減りました(管理者権限にしたことが原因か9cが原因かは不明)。

UnsatisfiableError: The following specifications were found to be incompatible with each other:

  • anaconda-navigator -> pillow -> jpeg[version='>=9b,<10a']
  • conda-forge/win-64::jpeg==9c=hfa6e2cd_1001
  • conda-forge/win-64::libtiff==4.0.10=h36446d0_1001 -> jpeg[version='>=9c,<10a']
  • conda-forge/win-64::qt==5.9.7=hc6833c9_1 -> jpeg[version='>=9c,<10a']
  • navigator-updater -> pyqt[version='>=5.6'] -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9c,<10a']
  • pillow -> jpeg[version='>=9b,<10a']
  • pip -> python[version='>=3.6,<3.7.0a0']
  • pyqt -> qt[version='5.9.*,>=5.9.6,<5.10.0a0'] -> jpeg[version='>=9c,<10a']

conda listでもanaconda navigatorでも、jpegはちゃんと9cになっています。
どうしたらよいか途方に暮れております。。お力をお貸しください。

補足情報(FW/ツールのバージョンなど)

python3系、現在の最新版

以下のような質問にはリアクションをつけましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

リアクションが多い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

まだ回答がついていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.12%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Anaconda

Anacondaは、Python本体とPythonで利用されるライブラリを一括でインストールできるパッケージです。環境構築が容易になるため、Python開発者間ではよく利用されており、商用目的としても利用できます。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。