質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.81%

存在するはずのgem(kaminari-core-1.0.0)のBundler::GemNotFound:

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 665

joru

score 40

前提・実現したいこと

dockerを用いた開発環境で

docker-compose up


をしようとすると、

Bundler::GemNotFound: Could not find kaminari-core-1.0.0 in any of the sources


がでて、サーバーを立てることができない。

発生している問題・エラーメッセージ

$ docker-compose up
_db_1_22a74910cbab is up-to-date
Starting _web_1_e9f5fac7c725 ... done
Attaching to _db_1_22a74910cbab, _web_1_e9f5fac7c725
db_1_22a74910cbab | Initializing database
db_1_22a74910cbab | 2019-05-20T09:33:02.836197Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
db_1_22a74910cbab | 2019-05-20T09:33:03.591013Z 0 [Warning] InnoDB: New log files created, LSN=45790
db_1_22a74910cbab | 2019-05-20T09:33:03.774521Z 0 [Warning] InnoDB: Creating 
(中略)
db_1_22a74910cbab | 2019-05-20T09:48:41.565473Z 0 [Note] Event Scheduler: Loaded 0 events
db_1_22a74910cbab | 2019-05-20T09:48:41.566244Z 0 [Note] mysqld: ready for connections.
db_1_22a74910cbab | Version: '5.7.26'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  MySQL Community Server (GPL)
web_1_e9f5fac7c725 | Bundler::GemNotFound: Could not find kaminari-core-1.0.0 in any of the sources
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/spec_set.rb:91:in `block in materialize'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/spec_set.rb:85:in `map!'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/spec_set.rb:85:in `materialize'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/definition.rb:170:in `specs'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/definition.rb:237:in `specs_for'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/definition.rb:226:in `requested_specs'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/runtime.rb:108:in `block in definition_method'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/runtime.rb:20:in `setup'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler.rb:107:in `setup'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/bundler/setup.rb:20:in `<top (required)>'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
web_1_e9f5fac7c725 |   /usr/local/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
web_1_e9f5fac7c725 | bundler: failed to load command: rails (/usr/local/bundle/bin/rails)
_web_1_e9f5fac7c725 exited with code 1

該当のソースコード

#Gemfile
(前略)
# line messaging api
gem 'line-bot-api'
gem 'dotenv-rails'

# api化 CORS設定
gem 'rack-cors'

# infinite scrollのためのpagenation
gem 'kaminari', '~> 1.0.0'

# rake taskを定期実行する
gem 'whenever', require: false
(後略)
#Gemfile.lock
(前略)
    json (2.2.0)
    kaminari (1.0.0)
      activesupport (>= 4.1.0)
      kaminari-actionview (= 1.0.0)
      kaminari-activerecord (= 1.0.0)
      kaminari-core (= 1.0.0)
    kaminari-actionview (1.0.0)
      actionview
      kaminari-core (= 1.0.0)
    kaminari-activerecord (1.0.0)
      activerecord
      kaminari-core (= 1.0.0)
    kaminari-core (1.0.0)
    launchy (2.4.3)
      addressable (~> 2.3)
    letter_opener (1.7.0)
      launchy (~> 2.2)
(後略)

試したこと

・ https://rubygems.org/gems/kaminari-coreに1.0.0が存在する確認
・ docker-compose run web bundle update kaminari
・ docker-compose run web bundle update kaminari-core
を行いました。

追加・修正

FROM ruby:2.6.2


# 必要なパッケージのインストール(基本的に必要になってくるものだと思うので削らないこと)
RUN apt-get update -qq && \
    apt-get install -y build-essential \
                       libpq-dev \
                       nodej

# 作業ディレクトリの作成、設定
RUN mkdir /app_name
##作業ディレクトリ名をAPP_ROOTに割り当てて、以下$APP_ROOTで参照
ENV APP_ROOT /app_name
WORKDIR $APP_ROOT

# ホスト側(ローカル)のGemfileを追加する(ローカルのGemfileは【3】で作成)
ADD ./Gemfile $APP_ROOT/Gemfile
ADD ./Gemfile.lock $APP_ROOT/Gemfile.lock

# Gemfileのbundle install
RUN bundle install
ADD . $APP_ROOT
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • joru

    2019/05/21 00:21

    申し訳ないです。
    関係ありました。。。
    # 必要なパッケージのインストール(基本的に必要になってくるものだと思うので削らないこと)
    RUN apt-get update -qq && \
    apt-get install -y build-essential \
    libpq-dev \
    nodej
    この部分nodejになってしまっていて本来はnodejsでした、
    後ろにあったスペースを消す際に削除してしまったようです

    キャンセル

  • iwamot

    2019/05/21 00:30 編集

    Dockerfileで`RUN bundle install`しているなら、必要なgemは入りそうですけどね。`docker-compose build --no-cache`でビルドし直してみるのがよいのかもしれません。

    キャンセル

  • urbainleverrier

    2019/05/21 17:25

    gemらは`/vernder`に入れてますか?globalに管理されちゃってるんじゃないでしょうか

    キャンセル

回答 1

check解決した方法

0

必要なパッケージのインストール(基本的に必要になってくるものだと思うので削らないこと)
RUN apt-get update -qq && \
apt-get install -y build-essential \
libpq-dev \
nodej
この部分nodejになってしまっていて本来はnodejsでした、

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.81%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る