質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.42%
Vue.js

Vue.jsは、Webアプリケーションのインターフェースを構築するためのオープンソースJavaScriptフレームワークです。

npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

Vuex

Vuexは、Vue.js アプリケーションのための状態管理ライブラリです。アプリケーション内で使用するコンポーネントのための集中データストアを提供。コンポーネント同士でデータをやり取りし、処理のフローを一貫させたり、データの見通しを良くすることができます。

Vue CLI

Vue CLIは、Vue.jsでアプリケーション開発を行うためのコマンドラインインタフェース(CLI)に基づいた開発ツールです。インタラクティブなプロジェクトの雛形や設定なしで使用できるプロトタイプの作成など、さまざまな機能が用意されています。

Q&A

2回答

21673閲覧

Vue,jsのローカルサーバーがThis dependency was not found表示で起動できない

ysk1914

総合スコア17

Vue.js

Vue.jsは、Webアプリケーションのインターフェースを構築するためのオープンソースJavaScriptフレームワークです。

npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

Vuex

Vuexは、Vue.js アプリケーションのための状態管理ライブラリです。アプリケーション内で使用するコンポーネントのための集中データストアを提供。コンポーネント同士でデータをやり取りし、処理のフローを一貫させたり、データの見通しを良くすることができます。

Vue CLI

Vue CLIは、Vue.jsでアプリケーション開発を行うためのコマンドラインインタフェース(CLI)に基づいた開発ツールです。インタラクティブなプロジェクトの雛形や設定なしで使用できるプロトタイプの作成など、さまざまな機能が用意されています。

0グッド

0クリップ

投稿2019/04/17 22:58

Vue-cliで開発する学習をしているのですが、ローカルサーバーが起動しなくなりました。
以下に試したことを記載します。
解決策をご存知の方、アドバイスいただけると幸いです。

試したこと

bash

1yarn serve 2yarn run v1.15.2 3$ vue-cli-service serve 4 INFO Starting development server... 5 98% after emitting CopyPlugin

上記のyarnコマンドでyarnを起動しようとすると以下のエラーが表示されます。

エラー表示

bash

1 ERROR Failed to compile with 1 errors 23:05:27 2 3This dependency was not found: 4 5* core-js/modules/es6.function.name in ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/babel-loader/ 6lib!./node_modules/vuetify-loader/lib/loader.js!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-l 7oader/lib??vue-loader-options!./src/App.vue?vue&type=script&lang=js& 8 9To install it, you can run: npm install --save core-js/modules/es6.function.name 10^C 11MacBook-Pro:practice_vue_firebase user$ npm install --save core-js/modules/es6.function.name 12npm ERR! code ENOLOCAL 13npm ERR! Could not install from "core-js/modules/es6.function.name" as it does not contain a package.json file. 14 15npm ERR! A complete log of this run can be found in: 16npm ERR! /Users/user/.npm/_logs/2019-04-17T14_05_46_073Z-debug.log 17

npmをインストールしてくださいと表示されているので記載の「npm install --save」コマンドを実行すると、そんなファイルはないよ、みたいなエラーが表示されます。

そのほか

・nodemoduleとpackage.jsonを一度消してみて再実行もやってみましたが事象は解決されずでした。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答2

0

yarn upgradeyarn upgrade --latest などしてもダメでしょうか?
(実行する前に package.json や yarn.lock はパックアップしておいてください)

追記
ミスったので削除依頼中

投稿2019/04/18 12:21

編集2019/04/18 12:23
wtokuno

総合スコア448

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

ysk1914

2019/04/18 22:53

MacBook-Pro:practice_vue_firebase user$ yarn upgrade --latest yarn upgrade v1.15.2 [1/4] ???? Resolving packages... warning vue-cli > coffee-script@1.12.7: CoffeeScript on NPM has moved to "coffeescript" (no hyphen) warning vue-cli > metalsmith > gray-matter > coffee-script@1.12.7: CoffeeScript on NPM has moved to "coffeescript" (no hyphen) warning @vue/cli-plugin-eslint > eslint > file-entry-cache > flat-cache > circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor. [2/4] ???? Fetching packages... [3/4] ???? Linking dependencies... warning "firebase > @firebase/storage@0.2.14" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/database@0.3.19" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/storage > @firebase/storage-types@0.2.10" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/storage > @firebase/storage-types@0.2.10" has unmet peer dependency "@firebase/util@0.x". warning "firebase > @firebase/auth > @firebase/auth-types@0.6.0" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/auth > @firebase/auth-types@0.6.0" has unmet peer dependency "@firebase/util@0.x". warning "firebase > @firebase/messaging@0.3.18" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/functions@0.4.5" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/database > @firebase/database-types@0.3.10" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/firestore@1.2.0" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/firestore > @firebase/firestore-types@1.2.0" has unmet peer dependency "@firebase/app-types@0.x". warning "firebase > @firebase/messaging > @firebase/messaging-types@0.2.10" has unmet peer dependency "@firebase/app-types@0.x". warning " > sass-loader@7.1.0" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0". warning " > vuetify-loader@1.2.2" has unmet peer dependency "webpack@^4.0.0". [4/4] ???? Rebuilding all packages... success Saved lockfile. success Saved 838 new dependencies.
ysk1914

2019/04/18 22:54

yarnをアップデートしてもvue-cliのバージョンは以下の通りでした.. ├─ vue-cli-plugin-vuetify@0.5.0 ├─ vue-cli@2.9.6 ├─ vue-router@3.0.6 ├─ vue-template-compiler@2.6.10 ├─ vue@2.6.10 ├─ vuetify-loader@1.2.2 ├─ vuetify@1.5.12 └─ vuex@3.1.0
wtokuno

2019/04/19 02:52

#この下にコメント繋げるの気が引けますが - yarn list --pattern core-js を実行したらどうなりますか? - yarn add core-js@2 したらどうなりますか? - 新しくプロジェクトを作って yarn serve したらどうなりますか?
guest

0

使用している vue-cliのバージョンは何でしょうか。
以下によると 3.5.2 で修正されているそうです。
https://github.com/vuejs/vue-cli/issues/3678#issuecomment-476949256

投稿2019/04/18 02:44

wtokuno

総合スコア448

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

ysk1914

2019/04/18 10:03

回答ありがとうございます。 使用しているvue-cliは3.6.2でした。
ysk1914

2019/04/18 11:37

yarnのほうが2.9.6のままになっていたのでvueをアップデートしたところ以下のように3.6.3になりましたが、yarn serveで起動しても結局同じエラーのままでした。
ysk1914

2019/04/18 11:40

yarn info @vue/cli yarn info v1.15.2 { name: '@vue/cli', description: 'Command line interface for rapid Vue.js development', 'dist-tags': { latest: '3.6.3' },
wtokuno

2019/04/18 12:24

`yarn upgrade` や `yarn upgrade --latest` などしてもダメでしょうか? (実行する前に package.json や yarn.lock はパックアップしておいてください)
ysk1914

2019/04/21 05:59

wtokuno様 遅くなり申し訳ございません。 上記`yarn upgrade` や `yarn upgrade --latest`を試しましたが解決されませんでした....
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.42%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問