質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

eclipseビルドエラーについて

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,738

keikar

score 4

前提・実現したいこと

eclipseでjavaの勉強を始めたばかりなのですが、プロジェクト作成時にワークスペースのエラーが表記されてどうにも出来ません。
解決策等ありませんか

エラーの種類とかも調べてみたのですが抽象的すぎて分からなかったです、アンインストールして再ダウンロードなども試しました。自分が未熟なだけかも知れないですがお力を貸して頂けると嬉しいです。

発生している問題・エラーメッセージ

ビルド中にエラーが発生しました。
プロジェクト 'hello' でビルダー 'Java ビルダー' の実行中にエラーが発生しました。
java.lang.NullPointerException

補足情報(FW/ツールのバージョンなど)

Java12 macOS
eclipse 4.11 for macOS

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • nskydiving

    2019/04/16 05:30

    Eclipse のバージョンが結構古いようですが、最新版ではどうでしょうか?

    キャンセル

  • nskydiving

    2019/04/16 05:32

    他に内部コンパイル・エラーは発生していなかったでしょうか?

    キャンセル

  • y_waiwai

    2019/04/16 06:55

    そのエラーが出たというコードを提示しましょう

    キャンセル

  • keikar

    2019/04/16 23:44

    そもそものeclipseのバージョンが対応してないとの情報を頂いたので試してみます。ありがとうございます

    キャンセル

回答 2

+2

一か月ほど経ちましたがeclipse 4.11(2019-03)はデフォルトではまだjdk12が使えませんね。

インストール後
Help>Eclipse Marketplace...
でEclipse Marketplaceダイアログを開きSearchタブにあるFindに「java12」と入力し虫眼鏡アイコンをクリックすると
Java 12 Support for Eclipse 2019-03 (4.11) 4.11
ってのが出てきますので、右下にあるInstallボタンを押し手順通りパッチをインストールすると使えるようになるようです。

これを入れるとご質問の現象が消えました。(当方はWindows10ですが現象や対処は同じと思います)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+1

eclipse 4.1 は Java 8 までしかまともに動きません(サポートされてません)
eclipse 4.7.1a (Oxigen) からがサポート対象です。

なので jdk 9~ を利用したい場合は 現時点での最新のエクリプスに変更することをお勧めします。

downloadしたのは「ep411I-unit-mac64-java8-macosx.cocoa.x86_64-8.0」だと思いますが、
その他のダウンロードを見てわかる通り、java8で起動する用のものですね

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/16 23:46

    わかりました。最新版というか対応するものをダウンロードして試してみます。情報ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる