質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.83%

jupyter notebookをインストールしたが起動しない

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,387

oyatsu8

score 86

jupyter notebookをインストールしたのですが、下記のようなエラーが出て起動できません。
環境は Mac OS 10.3.6
pythonのバージョンは 3.6.5 です。

$ jupyter notebook
Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/notebook/services/sessions/sessionmanager.py", line 10, in <module>
    import sqlite3
  File "/Library/Frameworks/SQLite3.framework/Versions/E/Python/3.6/sqlite3/__init__.py", line 23, in <module>
    from sqlite3.dbapi2 import *
  File "/Library/Frameworks/SQLite3.framework/Versions/E/Python/3.6/sqlite3/dbapi2.py", line 27, in <module>
    from sqlite3._sqlite3 import *
ImportError: dlopen(/Library/Frameworks/SQLite3.framework/Versions/E/Python/3.6/sqlite3/_sqlite3.cpython-36m-darwin.so, 2): Library not loaded: /Library/Frameworks/SQLite3.framework/Versions/D/SQLite3
  Referenced from: /Library/Frameworks/SQLite3.framework/Versions/E/Python/3.6/sqlite3/_sqlite3.cpython-36m-darwin.so
  Reason: image not found

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/3.6/bin/jupyter-notebook", line 6, in <module>
    from notebook.notebookapp import main
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/notebook/notebookapp.py", line 86, in <module>
    from .services.sessions.sessionmanager import SessionManager
  File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/notebook/services/sessions/sessionmanager.py", line 13, in <module>
    from pysqlite2 import dbapi2 as sqlite3
ModuleNotFoundError: No module named 'pysqlite2'


SQlite3の場所、バージョンを調べたところ下記のような結果

$  which sqlite3
/usr/bin/sqlite3

$ sqlite3 --version
3.19.3 2017-06-27 16:48:08 2b0954060fe10d6de6d479287dd88890f1bef6cc1beca11bc6cdb79f72e2377b


jupyter notebookを入れる前に、QGis3.6をインストールするために、GDALなども入れていたためか、下記のような
エラーが出たので、強制的に
brew uninstall --ignore-dependencies python sqlite
を実行しました。
また、QGis3.6をインストールするときに、パスの設定なども触りました。

$ brew rm python sqlite
Error: Refusing to uninstall /usr/local/Cellar/sqlite/3.27.2 and /usr/local/Cellar/python/3.7.3
because they are required by gdal, geos, glib, libdap, libspatialite, libxml2, numpy, osgeo-gdal and python@2, which are currently installed.
You can override this and force removal with:
  brew uninstall --ignore-dependencies python sqlite

パスの設定は下記のようになっています。
(拙い知識で設定しています)。

$ vi ~/.bash_profile
if [ -f ~/.bashrc ]; then
    . ~/.bashrc
fi
export PYENV_ROOT=${HOME}/.pyenv
if [ -d "${PYENV_ROOT}" ]; then
    export PATH=${PYENV_ROOT}/bin:$PATH
    eval "$(pyenv init -)"
fi
export PATH=$HOME/.nodebrew/current/bin:$PATH
alias python=python3
$ echo $PATH
/Library/Frameworks/Python.framework/Versions/3.6/bin:
/Users/thgpf_mbp/.nodebrew/current/bin:/usr/local/bin:
/usr/bin:
/bin:
/usr/sbin:
/sbin:
/Users/no136/.nodebrew/current/bin:
/usr/bin/

その後、
SQliteやpython、notebookも何度か再インストールしたり、ネットでの解決法など試みましたが、同じ結果になります。
アドバイスを頂けたら助かります。

追記:
参考にしたサイト
https://kjirou.github.io/old-sorenari-blog/articles/2659.html
https://github.com/Homebrew/legacy-homebrew/issues/17312

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.83%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る