質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.59%

raspbianでipv4,httpsでのwget,curl時にエラーが出る

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,256

score 17

前提・実現したいこと

プログラミング初心者で初質問なので至らないところもありますがお許し下さい。
raspbianで、httpsでのwget,curlを用いたダウンロードに失敗します。

発生している問題・エラーメッセージ

pi@raspberrypi:~/opencv20190404 $ wget -O opencv.zip https://github.com/opencv/opencv/archive/3.4.5.zip
--2019-04-04 22:14:38--  https://github.com/opencv/opencv/archive/3.4.5.zip
github.com (github.com) をDNSに問いあわせています... 192.30.255.113, 192.30.255.112
github.com (github.com)|192.30.255.113|:443 に接続しています... 失敗しました: 接続がタイムアウトしました.
github.com (github.com)|192.30.255.112|:443 に接続しています... 失敗しました: 接続がタイムアウトしました.
再試行しています。

(以後続く)

試したこと

メインpcのWSLのUbuntuで同じスクリプトを実行したところ、成功しました。

追記(2019/04/08):
下記の質問とほぼ同じ状況だったので
iptablesのルールをすべて消去してみましたが変わりませんでした。
https://teratail.com/questions/49296

また、今まではwindowsからssh接続をして操作していたのですが、直接操作したところ、
「ネットワークに届きません」
というエラーが出ました。

追記(2019/04/09):
windowsのvirtualboxでraspbianを入れ同じコマンドを試したところ成功しました。

補足情報(FW/ツールのバージョンなど)

raspberry pi とssh接続
raspbian 9.8]

追記(2019/04/10):

/etc/dhcpcd.conf内の記述を間違えており修正しました。
再度wgetコマンドを実行したところ、

ホストへの経路がありません


というエラーが出ました。

また、githubのipアドレスでtracerouteコマンドを実行したところ、

traceroute to 192.30.255.113 (192.30.255.113), 30 hops max, 60 byte packets
 1  192.168.1.221 (192.168.1.221)  3159.326 ms !H  3159.145 ms !H  3159.106 ms !H


「ホストへ到達できない」というエラーです。
※raspberry pi のipアドレスは固定してあります。

これは修正したルーターのipアドレスなどの記述にまだ誤りがあるといことでしょうか?

ネットワーク回りの知識が乏しいので教えていただけると嬉しいです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • shunx2_1003

    2019/04/11 14:13

    DHCPではなく、固定IPを使用するということです。誤解を招くような記述で申し訳ありません。

    キャンセル

  • over

    2019/04/11 14:23

    すいません。私の認識も間違っていました。ラズパイのネットワーク設定は/etc/dhcpcd.confなんですね。勉強になりました。

    キャンセル

  • shunx2_1003

    2019/04/11 15:13

    いえいえ、親切にご回答いただき、ありがとうございました。

    キャンセル

回答 1

checkベストアンサー

+1

shunx2_1003さん、

そちらのネットワーク環境がまだよくわからないのですが、IPアドレス周りの設定の仕方が悪そうな感じがします。
DHCPを使わずに、固定IPを使用する、ということでいいんでしょうか?
であれば、以下を見てください。

うまくネットにつながっているWindows 10で、cmd.exe を開いて、ipconfig /all をします。
で、つながっているアダプタの情報を見ます。

.
.
.
Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Intel(R) Ethernet Connection HOGEHOGEHOGE
   Physical Address. . . . . . . . . : 11-22-33-44-55-66
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::~~~~~~ 
   IPv4 Address. . . . . . . . . . . : 192.168.1.101
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 1234567890
   DHCPv6 Client DUID. . . . . . . . : 00-01-02-03-04-05-06-07-06-05-04-03-02-01
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled
.
.
.

こんな感じのが見れたら、

   IPv4 Address. . . . . . . . . . . : 192.168.1.101
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 192.168.1.1


このあたりを参考にして、ラズパイの/etc/dhcpcd.confの最後の行に下の追加しましょう。

# /etc/dhcpcd.confに追記。
interface eth0                            # 有線LAN
static ip_address=192.168.1.123/24        # IPv4 AddressとSubnet Maskから
static routers=192.168.1.1                # Default Gateway
static domain_name_servers=192.168.1.1    # DNS Servers

ip_address=ですが、IPv4アドレスを設定しますが、他の機器と番号がかからないように、最後とこの番号を決めます。(xxx.yyy.www.zzzだったら、.zzzのみ変更してみる) 
"/24"は、Subnet Maskのビット数です。255(=8bit).255(=8bit).255(=8bit).0(=0bit)で、8bit x3で、24ビットなので、/24です。

いろいろいじってしまった後だと、うまく設定が反映されないかもしれないので、うまく行かなかったら、Raspbianを焼き直して、試してみてください。(2019-04-08-raspbian-stretchも出たばかりですし!)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/11 14:16

    ありがとうございました!
    無事解決しました。
    routersの部分が間違っていたためにこのエラーが発生しました。
    ご迷惑をおかけしました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る