質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.62%

  • Ruby on Rails

    6960questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 4

    2402questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • RubyGems

    316questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

railsローカルサーバーが立ち上がりません......

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 972

zeben

score 51

 You're using Rubygems 2.0.14 with Spring. Upgrade to at least Rubygems 2.1.0 and run gem pristine --all for better startup performance.
Could not find mysql2-0.4.1 in any of the sources
Run bundle install to install missing gems.

『rails s』をすると上記のようなエラーがでてきてしまうのですが原因はなんでしょうか?
Rubyも最新版に変えてみたのですが解決出来ません。
お時間のある時で良いのでご回答いただければ幸いです。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

rails s を実行するのは、現在の環境になってから初めてですか?
つまり、これまでは正常に起動出来ていたのに、急にエラーが発生するようになったのでしょうか?
それとも、環境構築後、最初の起動で失敗しているのでしょうか?

ちょっと前置きですが…
失敗するからには原因があるのですが、現在の状態がどうなっているのか、その状態に至った経緯はどのようなものかが分からないと、解決のしようがありません。
サーバーを目の前にしているのであれば、いろいろとコマンドを実行して自ら状況を調査できますが、質問サイトを通して解決法のヒントを得たい場合は、これら具体的な情報をご提示いただけないと回答しにくいです。

さて、本題ですが
Upgrade to at least Rubygems 2.1.0
とあるので、Ruby本体ではなくて「Rubygems」をアップグレードする必要があるのでは?

なので、提案されている通り
gem pristine --all
を実行しれみると良いのではないでしょうか。
場合によっては、その前に下記コマンドを実行する必要があるかもしれません。
gem update --system

それと、「Could not find mysql2-0.4.1」と出ていますが、MySQLはインストール済みなのでしょうか?もしそうならバージョンは何ですか?

いずれにしても、不足しているGemをインストールするために
bundle install
するよう勧められているので、「起動しようとしているサーバー」に必要なGemが不足していないか、想定どおりのバージョンがインストールされているかを再点検してみるのが良いと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/10/12 18:40

    pi-chan様

    ご指摘ありがとうございます!
    全てをインストールをしてからbundle Installしたら成功しました。
    ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.62%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby on Rails

    6960questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 4

    2402questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • RubyGems

    316questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。