質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.62%

windowsのgemのsqlite3インストールでエラーが出る

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 10K+

score 11

Ruby on Railsを始めようと思って以下のサイトを参考に導入作業をしていました
https://www.javadrive.jp/rails/install/
railsのインストールは正常にできたのですが、gemでsqlite3をインストールしようとすると以下のようなエラーが出ます
このエラーの原因は何か教えてください
OSはWindows10 Home 64bitです

C:\>gem install sqlite3
Temporarily enhancing PATH for MSYS/MINGW...
Installing required msys2 packages: mingw-w64-x86_64-sqlite3
警告: mingw-w64-x86_64-sqlite3-3.27.0-1 は最新です -- スキップ
Building native extensions. This could take a while...
ERROR:  Error installing sqlite3:
        ERROR: Failed to build gem native extension.

    current directory: C:/Ruby26-x64/lib/ruby/gems/2.6.0/gems/sqlite3-1.4.0/ext/sqlite3
C:/Ruby26-x64/bin/ruby.exe -I C:/Ruby26-x64/lib/ruby/2.6.0 -r ./siteconf20190227-12196-19643xi.rb extconf.rb
checking for sqlite3.h... yes
checking for pthread_create() in -lpthread... yes
checking for -ldl... no
checking for dlopen()... no
missing function dlopen
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby26-x64/bin/$(RUBY_BASE_NAME)
        --with-sqlcipher
        --without-sqlcipher
        --with-sqlite3-config
        --without-sqlite3-config
        --with-pkg-config
        --without-pkg-config
        --with-sqlcipher
        --without-sqlcipher
        --with-sqlite3-dir
        --without-sqlite3-dir
        --with-sqlite3-include
        --without-sqlite3-include=${sqlite3-dir}/include
        --with-sqlite3-lib
        --without-sqlite3-lib=${sqlite3-dir}/lib
        --with-pthreadlib
        --without-pthreadlib
        --with-dllib
        --without-dllib

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  C:/Ruby26-x64/lib/ruby/gems/2.6.0/extensions/x64-mingw32/2.6.0/sqlite3-1.4.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in C:/Ruby26-x64/lib/ruby/gems/2.6.0/gems/sqlite3-1.4.0 for inspection.
Results logged to C:/Ruby26-x64/lib/ruby/gems/2.6.0/extensions/x64-mingw32/2.6.0/sqlite3-1.4.0/gem_make.out
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

下記の回答をしたのですが、これでは駄目です。コメント参照。

==============================================
必要なライブラリが足りていないというエラーです。
簡単には、バージョンを下げるとコンパイル済みのgemがあるので、大丈夫です。
gem install sqlite3 --version 1.3.13

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/27 22:18

    「コンパイル済みのgemがある」とは、gem内のプログラムのうちCで書かれた物がコンパイル済みであると言う意味です。

    ああ、すいません。これでは駄目ですね。
    久しくsqlite3を使うプログラムを実行してませんでしたが、require "sqlite3" でエラーになりますね。
    gemの中にRubyのバージョンに依存した実行モジュールがあるようです。
    1.3.13だと、Ruby2.4までのコンパイル済み実行モジュールがあります。

    ・sqlite3 1.4内のCプログラムがコンパイルできるライブラリを自分で揃える
    ・Ruby2.4を使って、sqlite3 1.3.13を使う
    の二択です。

    キャンセル

  • 2019/02/27 23:06

    前者は難しそうなのでRuby2.4.5を入れ直して
    gem install rails
    でRails 5.2.2
    gem install sqlite3 --version 1.3.13
    でSqLite3 1.3.13
    をインストールし、再び
    rails new practice
    を行っても同じように怒られました(なにかの上書き?的なものを聞かれたときに拒否したからかなあ...)

    キャンセル

  • 2019/03/03 19:57 編集

    プラットフォームを指定してsqlite3 1.3.13を正しくインストールすればできました!実は諦めてWindows Subsytem for Linuxでもインストールを試みていたのでLinuxでのエラー対策も一応メモ書きしておきます


    <Linux(Ubuntu)>
    sudo apt update //インストールできないファイルの対策
    sudo apt install ruby //rubyの実行環境
    sudo apt install ruby-dev //これがないとgemが正しく動かない
    sudo apt install libxml2 //nokogiriのgem native extensionエラー対策
    sudo apt install libxml2-dev //nokogiriのgem native extensionエラー対策
    sudo apt install zlib1g-dev //nokogiriのgem native extensionエラー対策
    sudo gem install nokogiri //railsインストール時のnokogiriエラー対策
    sudo gem install rails //railsの実行環境
    sudo apt install libsqlite3-dev //bundle installのsqliteエラー対策
    cd [作業パス]
    rails new [アプリ名] --skip-bundle
    cd [アプリ名]
    「vim Gemfile」等でGemfileを編集
    →最終行に「gem 'therubyracer'」を追加 //サーバーのランタイムエラー対策
    →「gem 'sqlite3'」を「gem 'sqlite3', '~> 1.3.6'」に変更 //bundle installのsqliteエラー対策
    bundle install
    rails server
    ブラウザで「http://localhost:3000/
    →Yay!You're on Rails!


    <Windows>
    https://rubyinstaller.org/downloads/からRuby+Devkit 2.5.3-1 (x64)をダウンロード、実行
    フォルダは「C:\Ruby25-x64」等のわかりやすいパスにしておく
    「Add Ruby executables to your PATH」「Use UTF as default external encoding.」にチェックを入れる(自己流)
    gemを正しく使うためMSY2もチェックを入れる
    Rubyのインストールが終わればMSY2のインストールを始める
    Ruby Installer2の「1」「2」「3」をそれぞれ実行
    gem install rails
    http://www.sqlite.org/download.htmlからsqlite-dll-win64-x64-3270200.zipとsqlite-tools-win32-x86-3270200.zipをDL
    それぞれの中にあるsqlite3.dllとsqlite3.exeをRubyをインストールしたフォルダのbinディレクトリにコピー
    gem install sqlite3 --version 1.3.13 --platform=ruby //1.4.0は未対応のため旧バージョンを指定、プラットフォームを指定しないとsqlite_native.soの位置がおかしくなる
    cd [作業パス]
    rails new [アプリ名] --skip-bundle
    cd [アプリ名]
    「vim Gemfile」等でGemfileを編集
    →「gem 'sqlite3'」を「gem 'sqlite3', '~> 1.3.13」に変更 //bundle installのsqliteエラー対策
    bundle install
    rails server
    ブラウザで「http://localhost:3000/
    →Yay!You're on Rails!


    ご迷惑をおかけしました
    本当にありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.62%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る