質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.37%

  • Ruby on Rails

    9344questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • AWS(Amazon Web Services)

    2677questions

    Amazon Web Services (AWS)は、仮想空間を機軸とした、クラスター状のコンピュータ・ネットワーク・データベース・ストーレッジ・サポートツールをAWSというインフラから提供する商用サービスです。

  • Heroku

    1311questions

    HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。

herokuにデプロイ出来ません。。。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 247

Orange48

score 4

herokuにまたデプロイできません。。。

一通り試行錯誤してみたのですがダメでした。
NameError: uninitialized constant CarrierWave::Storage::Fog は出なくなりました。
Sass::SyntaxError: File to import not found or unreadable: normalize. sassのエラーが出ました。sassのgemをいじったからだと思います。
fog-awsを使ってもダメでした。

発生している問題・エラーメッセージ

```

       Gems in the groups development and test were not installed.
       Bundled gems are installed into ./vendor/bundle
       Post-install message from i18n:

       HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
       But that may break your application.

       Please check your Rails app for 'config.i18n.fallbacks = true'.
       If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
       'config.i18n.fallbacks = [I18n.default_locale]'.
       If not, fallbacks will be broken in your app by I18n 1.1.x.

       For more info see:
       https://github.com/svenfuchs/i18n/releases/tag/v1.1.0

       Post-install message from trollop:
       !    The 'trollop' gem has been deprecated and has been replaced by 'optimist'.
       !    See: https://rubygems.org/gems/optimist
       !    And: https://github.com/ManageIQ/optimist
       Post-install message from fog:
       ------------------------------
       Thank you for installing fog!

       IMPORTANT NOTICE:
       If there's a metagem available for your cloud provider, e.g. fog-aws,
       you should be using it instead of requiring the full fog collection to avoid
       unnecessary dependencies.

       'fog' should be required explicitly only if the provider you use doesn't yet
       have a metagem available.
       ------------------------------
       Post-install message from sass:

       Ruby Sass is deprecated and will be unmaintained as of 26 March 2019.

       * If you use Sass as a command-line tool, we recommend using Dart Sass, the new
         primary implementation: https://sass-lang.com/install

       * If you use Sass as a plug-in for a Ruby web framework, we recommend using the
         sassc gem: https://github.com/sass/sassc-ruby#readme

       * For more details, please refer to the Sass blog:
         http://sass.logdown.com/posts/7081811

       Bundle completed (77.82s)
       Cleaning up the bundler cache.
-----> Installing node-v8.10.0-linux-x64
-----> Detecting rake tasks
-----> Preparing app for Rails asset pipeline
       Running: rake assets:precompile
       Yarn executable was not detected in the system.
       Download Yarn at https://yarnpkg.com/en/docs/install
       I, [2019-02-17T17:48:24.236643 #1661]  INFO -- : Writing /tmp/build_7c149b9d96946daa1b57948e42c2c256/public/assets/application-cb9e80baa3e87dd80b4ca48376144010a84ccf41deadd24174943da9f19cae7b.js
       I, [2019-02-17T17:48:24.237153 #1661]  INFO -- : Writing /tmp/build_7c149b9d96946daa1b57948e42c2c256/public/assets/application-cb9e80baa3e87dd80b4ca48376144010a84ccf41deadd24174943da9f19cae7b.js.gz
       rake aborted!
       Sass::SyntaxError: File to import not found or unreadable: normalize.
       (sass):362
       /tmp/build_7c149b9d96946daa1b57948e42c2c256/vendor/bundle/ruby/2.5.0/gems/sass-ogical_paths'
       /tmp/build_7c149b9d96946daa1b57948e42c2c256/vendor/bundle/ruby/2.5.0/gems/sprockets-3.7.2/lib/sprockets/legacy.rb:104:in `each'

(See full trace by running task with --trace)
!
!     Precompiling assets failed.
!
!     Push rejected, failed to compile Ruby app.
!     Push fail

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • mather

    2019/02/18 03:17

    コードブロックが閉じられていないので、 ``` の終わりを書いてください。

    キャンセル

  • Orlofsky

    2019/02/18 03:21

    エラーメッセージだけ載せられてもエラーメッセージでググっては?くらいのコメントしかつかないのでは?
    何をどうしたかきちんと載せては?参考にしたURLなどを質問に追記しては?

    キャンセル

  • bochan2

    2019/02/21 09:15

    githubのリンクでもgoogle driveでもいいので全ソースコードを添付していただけると解決の役に立つと思います。

    キャンセル

  • Orange48

    2019/02/24 23:19

    見いにくい質問で大変申し訳ありません。
    以後気をつけます。

    キャンセル

回答 1

checkベストアンサー

0

Sass::SyntaxError: File to import not found or unreadable: normalize

normalize.cssの読み込みができていないようです。

@import "normalize";

こちらの行を削除するかファイルを用意してください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/24 23:22

    cssのファイルに問題がありました。
    ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Ruby on Rails

    9344questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • AWS(Amazon Web Services)

    2677questions

    Amazon Web Services (AWS)は、仮想空間を機軸とした、クラスター状のコンピュータ・ネットワーク・データベース・ストーレッジ・サポートツールをAWSというインフラから提供する商用サービスです。

  • Heroku

    1311questions

    HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。