質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • MySQL

    6673questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

  • Linux

    4284questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Ubuntu

    1685questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • Windows

    1634questions

    Windowsは、マイクロソフト社が開発したオペレーティングシステムです。当初は、MS-DOSに変わるOSとして開発されました。 GUIを採用し、主にインテル系のCPUを搭載したコンピューターで動作します。Windows系OSのシェアは、90%を超えるといわれています。 パソコン用以外に、POSシステムやスマートフォンなどの携帯端末用、サーバ用のOSもあります。

  • Windows Subsystem for Linux

    15questions

WSL上にmysql-serverをインストールできない

受付中

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 185

Alberta_Fagni

score 18

分からないこと

WSL上でsudo apt install mysql-serverを実行したところ、以下のようにエラーになり、mysql-serverをインストールできず、その原因が分かりません。
mysql-clientはインストールできました。

ログ

パッケージリストを読み込んでいます... 完
依存関係ツリーを作成しています... 50%
状態情報を読み取っています... 完
以下の追加パッケージがインストールされます:
  libaio1 libcgi-fast-perl libcgi-pm-perl libencode-locale-perl libevent-core-2.1-6 libfcgi-perl libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl libhttp-message-perl libio-html-perl
  liblwp-mediatypes-perl libtimedate-perl liburi-perl mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server-5.7 mysql-server-core-5.7
提案パッケージ:
  libdata-dump-perl libipc-sharedcache-perl libwww-perl mailx tinyca
以下のパッケージが新たにインストールされます:
  libaio1 libcgi-fast-perl libcgi-pm-perl libencode-locale-perl libevent-core-2.1-6 libfcgi-perl libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl libhttp-message-perl libio-html-perl
  liblwp-mediatypes-perl libtimedate-perl liburi-perl mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server mysql-server-5.7 mysql-server-core-5.7
アップグレード: 0 個、新規インストール: 21 個、削除: 0 個、保留: 11 個。
21.0 MB 中 0 B のアーカイブを取得する必要があります。
この操作後に追加で 162 MB のディスク容量が消費されます。
続行しますか? [Y/n] y
パッケージを事前設定しています ...
以前に未選択のパッケージ mysql-common を選択しています。
(データベースを読み込んでいます ... 現
.../0-mysql-common_5.8+1.0.4_all.deb を展開する準備をしています ...
mysql-common (5.8+1.0.4) を展開しています...
以前に未選択のパッケージ libaio1:amd64 を選択しています。
.../1-libaio1_0.3.110-5_amd64.deb を展開する準備をしています ...
libaio1:amd64 (0.3.110-5) を展開しています...
以前に未選択のパッケージ mysql-client-core-5.7 を選択しています。
.../2-mysql-client-core-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb を展開する準備をしています ...
mysql-client-core-5.7 (5.7.25-0ubuntu0.18.04.2) を展開しています...
以前に未選択のパッケージ mysql-client-5.7 を選択しています。
.../3-mysql-client-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb を展開する準備をしています ...
mysql-client-5.7 (5.7.25-0ubuntu0.18.04.2) を展開しています...
以前に未選択のパッケージ mysql-server-core-5.7 を選択しています。
.../4-mysql-server-core-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb を展開する準備をしています ...
mysql-server-core-5.7 (5.7.25-0ubuntu0.18.04.2) を展開しています...
以前に未選択のパッケージ libevent-core-2.1-6:amd64 を選択しています。
.../5-libevent-core-2.1-6_2.1.8-stable-4build1_amd64.deb を展開する準備をしています ...
libevent-core-2.1-6:amd64 (2.1.8-stable-4build1) を展開しています...
mysql-common (5.8+1.0.4) を設定しています ...
update-alternatives: /etc/mysql/my.cnf (my.cnf) を提供するために自動モードで /etc/mysql/my.cnf.fallback を使います
以前に未選択のパッケージ mysql-server-5.7 を選択しています。
(データベースを読み込んでいます ... 現
.../00-mysql-server-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb を展開する準備をしています ...
mysql-server-5.7 (5.7.25-0ubuntu0.18.04.2) を展開しています...
以前に未選択のパッケージ libhtml-tagset-perl を選択しています。
.../01-libhtml-tagset-perl_3.20-3_all.deb を展開する準備をしています ...
libhtml-tagset-perl (3.20-3) を展開しています...
以前に未選択のパッケージ liburi-perl を選択しています。
.../02-liburi-perl_1.73-1_all.deb を展開する準備をしています ...
liburi-perl (1.73-1) を展開しています...
以前に未選択のパッケージ libhtml-parser-perl を選択しています。
.../03-libhtml-parser-perl_3.72-3build1_amd64.deb を展開する準備をしています ...
libhtml-parser-perl (3.72-3build1) を展開しています...
以前に未選択のパッケージ libcgi-pm-perl を選択しています。
.../04-libcgi-pm-perl_4.38-1_all.deb を展開する準備をしています ...
libcgi-pm-perl (4.38-1) を展開しています...
以前に未選択のパッケージ libfcgi-perl を選択しています。
.../05-libfcgi-perl_0.78-2build1_amd64.deb を展開する準備をしています ...
libfcgi-perl (0.78-2build1) を展開しています...
以前に未選択のパッケージ libcgi-fast-perl を選択しています。
.../06-libcgi-fast-perl_1%3a2.13-1_all.deb を展開する準備をしています ...
libcgi-fast-perl (1:2.13-1) を展開しています...
以前に未選択のパッケージ libencode-locale-perl を選択しています。
.../07-libencode-locale-perl_1.05-1_all.deb を展開する準備をしています ...
libencode-locale-perl (1.05-1) を展開しています...
以前に未選択のパッケージ libhtml-template-perl を選択しています。
.../08-libhtml-template-perl_2.97-1_all.deb を展開する準備をしています ...
libhtml-template-perl (2.97-1) を展開しています...
以前に未選択のパッケージ libtimedate-perl を選択しています。
.../09-libtimedate-perl_2.3000-2_all.deb を展開する準備をしています ...
libtimedate-perl (2.3000-2) を展開しています...
以前に未選択のパッケージ libhttp-date-perl を選択しています。
.../10-libhttp-date-perl_6.02-1_all.deb を展開する準備をしています ...
libhttp-date-perl (6.02-1) を展開しています...
以前に未選択のパッケージ libio-html-perl を選択しています。
.../11-libio-html-perl_1.001-1_all.deb を展開する準備をしています ...
libio-html-perl (1.001-1) を展開しています...
以前に未選択のパッケージ liblwp-mediatypes-perl を選択しています。
.../12-liblwp-mediatypes-perl_6.02-1_all.deb を展開する準備をしています ...
liblwp-mediatypes-perl (6.02-1) を展開しています...
以前に未選択のパッケージ libhttp-message-perl を選択しています。
.../13-libhttp-message-perl_6.14-1_all.deb を展開する準備をしています ...
libhttp-message-perl (6.14-1) を展開しています...
以前に未選択のパッケージ mysql-server を選択しています。
.../14-mysql-server_5.7.25-0ubuntu0.18.04.2_all.deb を展開する準備をしています ...
mysql-server (5.7.25-0ubuntu0.18.04.2) を展開しています...
libhtml-tagset-perl (3.20-3) を設定しています ...
libevent-core-2.1-6:amd64 (2.1.8-stable-4build1) を設定しています ...
ureadahead (0.100.0-20) のトリガを処理しています ...
libencode-locale-perl (1.05-1) を設定しています ...
libtimedate-perl (2.3000-2) を設定しています ...
libio-html-perl (1.001-1) を設定しています ...
liblwp-mediatypes-perl (6.02-1) を設定しています ...
libc-bin (2.27-3ubuntu1) のトリガを処理しています ...
libaio1:amd64 (0.3.110-5) を設定しています ...
liburi-perl (1.73-1) を設定しています ...
systemd (237-3ubuntu10.12) のトリガを処理しています ...
libhtml-parser-perl (3.72-3build1) を設定しています ...
libcgi-pm-perl (4.38-1) を設定しています ...
man-db (2.8.3-2ubuntu0.1) のトリガを処理しています ...
mysql-client-core-5.7 (5.7.25-0ubuntu0.18.04.2) を設定しています ...
libfcgi-perl (0.78-2build1) を設定しています ...
libhttp-date-perl (6.02-1) を設定しています ...
libhtml-template-perl (2.97-1) を設定しています ...
mysql-server-core-5.7 (5.7.25-0ubuntu0.18.04.2) を設定しています ...
libcgi-fast-perl (1:2.13-1) を設定しています ...
libhttp-message-perl (6.14-1) を設定しています ...
mysql-client-5.7 (5.7.25-0ubuntu0.18.04.2) を設定しています ...
mysql-server-5.7 (5.7.25-0ubuntu0.18.04.2) を設定しています ...
invoke-rc.d: could not determine current runlevel
221G[oOKi]g MySQL database server mysqld       227G
update-alternatives: /etc/mysql/my.cnf (my.cnf) を提供するために自動モードで /etc/mysql/mysql.cnf を使います
Renaming removed key_buffer and myisam-recover options (if present)
/proc/net/unix が開けません: そのようなファイルやディレクトリはありません
ファイルをstatできません /proc/1/fd/5: 許可されていない操作です
ファイルをstatできません /proc/49/fd/3: 許可されていない操作です
ファイルをstatできません /proc/49/fd/4: 許可されていない操作です
ファイルをstatできません /proc/5225/fd/7: 許可されていない操作です
dpkg: パッケージ mysql-server-5.7 の処理中にエラーが発生しました (--configure):
 installed mysql-server-5.7 package post-installation script subprocess returned error exit status 1
dpkg: 依存関係の問題により mysql-server の設定ができません:
 mysql-server は以下に依存 (depends) します: mysql-server-5.7 ...しかし:
  パッケージ mysql-server-5.7 はまだ設定されていません。

dpkg: パッケージ mysql-server の処理中にエラーが発生しました (--configure):
 依存関係の問題 - 設定を見送ります
libc-bin (2.27-3ubuntu1) のトリガを処理しています ...
エラーメッセージは前の失敗から続くエラーであることを示しているので、レポートは書き込まれません。
systemd (237-3ubuntu10.12) のトリガを処理しています ...
ureadahead (0.100.0-20) のトリガを処理しています ...
処理中にエラーが発生しました:
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

試したこと

sudo apt-get remove --purge 'mysql*'
sudo rm -rf /etc/mysql /var/lib/mysql
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt install mysql-server

ubuntu 18.04.1 LTS (Bionic Beaver)
windows Version 10.0.17134.523

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

Mysqlはそれ単品ではなくて、色々なモジュールの集合体です。そして、それらを扱うにはバージョンを合わせないと依存関係の問題を解決できないと注意されます。

ログを読んでいくとmysql-serverを読もうとして最終的に設定されていないって注意出ているので、依存問題を解決できずに入れられないんだと思います。

リポジトリを設定して5.7と指定して入れてみてください。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • MySQL

    6673questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

  • Linux

    4284questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Ubuntu

    1685questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • Windows

    1634questions

    Windowsは、マイクロソフト社が開発したオペレーティングシステムです。当初は、MS-DOSに変わるOSとして開発されました。 GUIを採用し、主にインテル系のCPUを搭載したコンピューターで動作します。Windows系OSのシェアは、90%を超えるといわれています。 パソコン用以外に、POSシステムやスマートフォンなどの携帯端末用、サーバ用のOSもあります。

  • Windows Subsystem for Linux

    15questions