質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.49%

VirtualBoxで作成した仮想OSからLAN上のNASに接続出来ない

解決済

回答 3

投稿

  • 評価
  • クリップ 2
  • VIEW 4,684

score 16

CentOS 7にVirtualBoxをインストールし、仮想OSとしてWindows 10を動作させています。

構成図

仮想サーバからNASに接続したいのですが、エクスプローラで接続することが出来ません。
詳細を以下に記します。
【詳細】

  • 仮想OSはブリッジ接続でLANに接続しています。
  • プライベートネットワークで接続を行っています。
  • エクスプローラのネットワークに対象となるNASやその他のPCが表示されます。
  • エクスプローラでNASを選択するとエラーメッセージが表示されます。
    ERROR
  • IPアドレスを指定してもアクセス出来ません
  • 他に作成した仮想OS(Windows 10)からも接続出来ませんでした。
  • ファイアーウォールは切ってみました。
  • ウィルス対策ソフトは入っていません。
  • LAN上のWindowsマシンからは正常に見えています。
  • ワークグループは正しく設定されており、同一LAN内の同一ワークグループマシンを確認することができます。
  • NASが提供している管理画面(HTTP/HTTPS接続)は問題なく接続可能です。
  • 対象となっているNASはQNAPとBAFFALOです。
  • 実サーバ側のファイアーウォールも切ってみましたが、現象は変わりません。

いろいろと試してはいるのですが、例えばCIFSの設定なども触ってみましたが、エクスプローラで開くことが出来ません。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • chabo3110

    2019/02/10 20:36

    ありがとうございます。
    LAN上にある物理マシン(WindowwsおよびLinux)マシンからNASへの接続は問題なくできています。
    Linuxからは、SMBによる接続になりますが、こちらも問題ありません。
    厳密な「接続」という意味では対象のNASの管理画面(HTTP/HTTPS)が見えているので、仮想OSからも「接続」は出来ているのですが、NASのフォルダーやファイルがまったく見えないという状況です。

    キャンセル

  • kunai

    2019/02/10 20:41

    HTTP/HTTPSが見えてるってことは、ファイル転送のプロトコルのポートが空いてないのでは?
    それぞれに設定されているIPアドレスも教えていただけませんか?

    キャンセル

  • chabo3110

    2019/02/11 00:34

    実サーバ(ホストOS)および仮想サーバのファイアーウォールは全て無効にして試してみましたのでポートが閉じていることは考え難いかと思います。
    また、各IPアドレスならびにサブネットマスクをチェックし、ネットワークアドレスに間違いがない事も確認済みです。
    ちなみに各機材のIPはイカの通りです。
    NAS:172.16.0.10/24
    実サーバ:172.16.0.100/24
    仮想サーバ:172.16.0.101/24
    です。

    キャンセル

回答 3

+2

解決方法が解りました。
仮想OSとして新規にWindows 10をインストールしたのですが、Windows自体のバグである可能性が高いことが判明しました。

確認された現象を整理します。
対象となるNASをQNAPとBUFFALOで検証していたのですが、もう一つ古いNASがあることを思い出しまして、そいつを駄目元で確認すると繋がることが解りました。
ただし、「機能と機能」→「Windowsの機能の有効化または無効化」→「SMB 1.0/CIFS クライアント」を有効にした状態が前提です。

古いNASで「SMB 1.0/CIFSクライアント」だと繋るということが何となく想像が付きました。多分古いNASの対応バージョンが古いと思った次第です。

そこで、QNAP NASの設定でSMBの対応バージョンを「SMB 1」のみに絞り込んで接続してみたところ見事に繋がりました。
対象のQNAP NASでは、SMBのバージョンを限定することができ、「SMB 3」まで現時点で対応できる状態になっていましたが、敢えて絞り込みました。

色々ググってみると、SMB絡みでWindowsの不具合が報告されており、それが影響していそうです。
レジストリを変更する記述など(英語)が上がっていましたが、該当するレジストリが存在しなかったりするので、まずは最新版にアップデートしてから最終確認を行ってみたいと思います。

これに至った経緯としては、Wiresharkを使って通信内容を確認しました。
通信内容で以下のエラーが確認できました。

Session Setup Respons Error,STATUS_MORE_PROCESSING_REQUIRED

これをキーにネット上の情報を探ってみたところ、この結果に行き着きました。

ちなみに、BUFFALOのNASには、SMBのバージョンを限定する設定は確認できず、未だに接続出来無い状態が続いていますが、こちらもWindowsのアップデートで解決すると思っています。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

check解決した方法

0

本件の対策は以下の対応で解決しました。

regeditを起動し、以下のレジストリを変更します。

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

値を「1」に変更します。

再起動した方が良いと思いますが、再起動しなくても接続を行うことができました。

以上で対策が完了しました。
以前の解答は、参考情報として残します。

以上

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

エラーメッセージが異なるため見当違いかもしれませんが、
使用されているNASはCIFS1.0 SMB1.0だったりしませんか?
Windows10ではデフォルトでCIFS1.0 SMB1.0が無効化されているので、コントロールパネルのプログラムと機能から
機能の追加と削除でCIFS1.0 SMB1.0クライアントを有効にしてみてください。

CIFSじゃなくてSMBです。。。すみません

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/11 12:27

    ご回答ありがとうございます。
    SMB1.0クライアント!と思いきや、CIFSとSMBは同時に機能の有効化が行われるようになっており、既に対応済みでした。
    一応、思い当たる節はこんな感じなのかな?と思ってはいるのですが、なんだろう?
    違うマシンに同一環境を構築して試してみようと思います。

    キャンセル

  • 2019/02/11 16:03

    ゲストOSのネットワークプロファイルがパブリックになってたりしませんよね?

    キャンセル

  • 2019/02/11 16:45

    ご回答頂きまして、本当にありがとうございます。
    最初はパブリックになっていましたが、プライベートに変更している状態です。
    考えられるセキュリティ設定は全て取り除きました。

    後ほどの記載しますが、ネットワークでエラーがsmb絡みのエラーが発生していることをWireshark を使って確認に至りました。
    詳細は別途記載予定です。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る