質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.61%

AWSにてPHPの最新バージョンをインストールできない

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 4,412

score 5

前提・実現したいこと

AWS上のPHPバージョンが5.3.29だったため、epel、remiをインストールし、
古いphpをアンインストールしphp7.1をインストールしようとしたところ、
下記エラーが出てしまいインストールできません。
どのようにすれば解決できますでしょうか。
どうかよろしくお願いいたします

発生している問題・エラーメッセージ

---epelにてダウンロード---

$ sudo yum --enablerepo=remi,epel install php71 php
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main                                                | 2.1 kB     00:00
amzn-updates                                             | 2.5 kB     00:00
1060 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.29-1.8.amzn1 will be installed
--> Processing Dependency: php-cli(x86-64) = 5.3.29-1.8.amzn1 for package: php-5.3.29-1.8.amzn1.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.29-1.8.amzn1 for package: php-5.3.29-1.8.amzn1.x86_64
---> Package php71.x86_64 0:7.1.25-1.35.amzn1 will be installed
--> Processing Dependency: php71-common(x86-64) = 7.1.25-1.35.amzn1 for package: php71-7.1.25-1.35.amzn1.x86_64
--> Processing Dependency: php71-cli(x86-64) = 7.1.25-1.35.amzn1 for package: php71-7.1.25-1.35.amzn1.x86_64
--> Processing Dependency: httpd-mmn = 20120211x86-64 for package: php71-7.1.25-1.35.amzn1.x86_64
--> Processing Dependency: php71-common for package: php71-7.1.25-1.35.amzn1.x86_64
--> Processing Dependency: httpd24 for package: php71-7.1.25-1.35.amzn1.x86_64
--> Running transaction check
---> Package httpd24.x86_64 0:2.4.37-1.83.amzn1 will be installed
--> Processing Dependency: httpd24-tools = 2.4.37-1.83.amzn1 for package: httpd24-2.4.37-1.83.amzn1.x86_64
---> Package php-cli.x86_64 0:5.3.29-1.8.amzn1 will be installed
---> Package php-common.x86_64 0:5.3.29-1.8.amzn1 will be installed
---> Package php71-cli.x86_64 0:7.1.25-1.35.amzn1 will be installed
---> Package php71-common.x86_64 0:7.1.25-1.35.amzn1 will be installed
--> Processing Dependency: php71-xml(x86-64) = 7.1.25-1.35.amzn1 for package: php71-common-7.1.25-1.35.amzn1.x86_64
--> Processing Dependency: php71-process(x86-64) = 7.1.25-1.35.amzn1 for package: php71-common-7.1.25-1.35.amzn1.x86_64
--> Processing Dependency: php71-json(x86-64) for package: php71-common-7.1.25-1.35.amzn1.x86_64
--> Running transaction check
---> Package httpd24-tools.x86_64 0:2.4.37-1.83.amzn1 will be installed
---> Package php71-json.x86_64 0:7.1.25-1.35.amzn1 will be installed
---> Package php71-process.x86_64 0:7.1.25-1.35.amzn1 will be installed
---> Package php71-xml.x86_64 0:7.1.25-1.35.amzn1 will be installed
--> Processing Conflict: httpd24-2.4.37-1.83.amzn1.x86_64 conflicts httpd < 2.4.37
--> Processing Conflict: php71-common-7.1.25-1.35.amzn1.x86_64 conflicts php-common < 5.5.22-1.98
--> Processing Conflict: php71-cli-7.1.25-1.35.amzn1.x86_64 conflicts php-cli < 5.5.22-1.98
--> Processing Conflict: httpd24-tools-2.4.37-1.83.amzn1.x86_64 conflicts httpd-tools < 2.4.37
--> Processing Conflict: php71-7.1.25-1.35.amzn1.x86_64 conflicts php < 5.5.22-1.98
--> Finished Dependency Resolution
**Error: php71 conflicts with php-5.3.29-1.8.amzn1.x86_64
Error: php71-cli conflicts with php-cli-5.3.29-1.8.amzn1.x86_64
Error: php71-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
Error: httpd24-tools conflicts with httpd-tools-2.2.34-1.16.amzn1.x86_64
Error: httpd24 conflicts with httpd-2.2.34-1.16.amzn1.x86_64**
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


---remiにてダウンロード---

$ sudo yum install --enablerepo=remi,remi-php71
Loaded plugins: priorities, update-motd, upgrade-helper
Error: Need to pass a list of pkgs to install
 Mini usage:

install PACKAGE...

Install a package or packages on your system

aliases: install-n, install-na, install-nevra

該当のソースコード

試したこと

epel,remiにてダウンロード

補足情報(FW/ツールのバージョンなど)

OS:Amazon Linux AMI 2018.03.0 (HVM), SSD Volume Type 
PHP(現状):5.3.29
epel:7-11
remi:7
※epel,remiについては下記サイト参考にし導入しております。
https://aws.amazon.com/jp/premiumsupport/knowledge-center/ec2-enable-epel/

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • asahina1979

    2019/02/03 19:29

    epel や remi は OS似合ったものを入れましょう

    キャンセル

  • yaz

    2019/02/03 19:51

    ご指摘ありがとうございます。
    下記のサイトを参考にし、epel,remiのバージョンを7に変更いたしました。
    https://aws.amazon.com/jp/premiumsupport/knowledge-center/ec2-enable-epel/

    その上でKosuke_Shibuya様から回答いただいたコマンドを含めインストールを試みましたが、同様のエラーが出てしまいできませんでした。
    大変お手数をお掛けしますが、何か不備等ございましたらご教授頂けないでしょうか。
    よろしくお願いいたします。

    キャンセル

  • hichon

    2019/02/03 20:44

    php7.1はamzn-mainに入ってるので、epel,remiは追加しなくて良いのでは?

    キャンセル

  • yaz

    2019/02/03 21:44

    hichon様
    ご指摘ありがとうございます。
    Amazon Linuxにamzn-mainという専用のリポジトリがあることを初めて知りました…。
    amzn-mainにて無事php7.1にアップデートすることができました。ありがとうございました。

    キャンセル

回答 3

check解決した方法

0

度々の質問に回答、指摘いただきありがとうございます。
Amazon Linuxにはhicson様から指摘頂いたamzn-mainという専用のリポジトリがあり、
デフォルトの設定だとepel,remiのリポジトリよりも優先的に参照するみたいです。

epel,remiリポジトリ参照コマンドでアンインストールしたはずの古いphp,apacheとバッティングしたり、
パッケージが存在していなかったりしていたのはこれが起因だと思います。
(当方初心者のため、原因詳細はよくわかっておりません。申し訳ありません。)

php,apacheをアンインストールし、下記コマンドにてPHP7.1をインストールすることができました。

-----php,apacheアンインストール-----

$sudo yum remove php-*
$sudo yum remove httpd*

-----php7.1,apache2.4インストール--------
$sudo yum install php71
(PHP7.1とapache2.4は自動で一緒にインストールされました)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

sudo yum --enablerepo=remi,epel upgrade php71 php

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/03 19:32

    回答いただきありがとうございます。
    ご教授頂いたコマンドにてインストールを試みましたが、下記エラーが出てしまいダウンロードができませんでした。
    大変お手数をおかけしますが、ご教授頂けないでしょうか。

    $sudo yum --enablerepo=remi,epel upgrade php71 php
    Loaded plugins: priorities, update-motd, upgrade-helper
    1336 packages excluded due to repository priority protections
    Package(s) php71 available, but not installed.
    Package(s) php available, but not installed.
    No packages marked for update

    キャンセル

  • 2019/02/03 20:47

    エラーメッセージ読んでないのでしょうか?

    キャンセル

  • 2019/02/03 22:13

    返信いただきありがとうございます。

    解決致しました。
    エラーログを確認できておらず無思慮に質問してしまい、不快な思いをさせてしまい
    申し訳ございませんでした。

    キャンセル

0

conflicts が発生したパッケージをアンインストールしてからインストールしましょう

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/03 20:08

    ご回答ありがとうございます。
    conflictsが発生していると表示されている古いphpについて下記コマンドにてアンインストールしております。
    その後、再度インストールを実行してもconflictsが発生してしまいます。

    パッケージのアンインストール方法等に不備等ございましたら、
    大変お手数をお掛けしますがご教授いただけないでしょうか。
    何卒よろしくお願いいたします。

    ----PHPアンインストールコマンド----
    $ sudo yum remove php-*
    Loaded plugins: priorities, update-motd, upgrade-helper
    No Match for argument: php-*
    No Packages marked for removal

    $udo yum remove php-5.3.29-1.8.amzn1.x86_64
    Loaded plugins: priorities, update-motd, upgrade-helper
    No Match for argument: php-5.3.29-1.8.amzn1.x86_64
    No Packages marked for removal

    キャンセル

  • 2019/02/03 21:06

    httpd24とhttpd24-toolsもアンインストールしてますか?

    キャンセル

  • 2019/02/03 22:20

    返信いただきありがとうございます。

    httpd24とhttpd24-toolもアンインストールしておりましたが、conflictsのエラーは出たままでした。
    別途記載した方法で解決しましたが、conflictsが残り続ける原因詳細は特定できませんでした。

    度々の質問にご対応いただき、ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る