質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.96%

ssh port番号を変更したところ接続が出来なくなりました。

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 2,564

score 221

ubuntu16.04
さくらvps

直前までは接続出来ていたのですが

デフォルトの22番からポートを変更、リスタートしたところssh接続出来なくなりました。
sudo service ssh restart

ターミナル

ssh -vvv -p 50022 ubuntu@xxx.xxx.xxx.xxx
LibreSSL 2.7.3
debug1: Reading configuration data /Users/jun/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 48: Applying options for *
debug2: resolve_canonicalize: hostname xxx.xxx.xxx.xxx is address
debug2: ssh_connect_direct
debug1: Connecting to xxx.xxx.xxx.xxx [xxx.xx.xxx.xxx] port 50022.
debug1: connect to address xxx.xx.xxx.xxx port 50022: Connection refused
ssh: connect to host xxx.xx.xxx.xxx port 50022: Connection refused

サーバーで確認した事

sudo isof -i:50022
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
sshd  19654 root 3u IPv4  177093  0t0  TCP  *:50022(LISTEN)
sshd  19654 root 4u IPv6  177102  0t0  TCP  *:50022(LISTEN)


sshd_configで50022番を指定しています

よろしくお願いいたします

追記
ログの一部を載せます

Jan 23 08:14:01 tk2-233-26158 CRON[8846]: pam_unix(cron:session): session opened for user root by (uid=0)
Jan 23 08:14:01 tk2-233-26158 CRON[8846]: pam_unix(cron:session): session closed for user root
Jan 23 08:29:18 tk2-233-26158 sudo:   ubuntu : TTY=pts/0 ; PWD=/etc/ssh ; USER=root ; COMMAND=/usr/bin/vim ssh_config
Jan 23 08:29:18 tk2-233-26158 sudo: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Jan 23 08:29:38 tk2-233-26158 sudo: pam_unix(sudo:session): session closed for user root
Jan 23 08:29:46 tk2-233-26158 sudo:   ubuntu : TTY=pts/0 ; PWD=/etc/ssh ; USER=root ; COMMAND=/usr/bin/vim sshd_config
Jan 23 08:29:46 tk2-233-26158 sudo: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Jan 23 08:30:00 tk2-233-26158 sudo: pam_unix(sudo:session): session closed for user root
Jan 23 08:35:24 tk2-233-26158 sudo:   ubuntu : TTY=pts/0 ; PWD=/etc/ssh ; USER=root ; COMMAND=/usr/sbin/service ssh restart
Jan 23 08:35:24 tk2-233-26158 sudo: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Jan 23 08:35:24 tk2-233-26158 sshd[7846]: Received signal 15; terminating.
Jan 23 08:35:24 tk2-233-26158 sshd[8867]: Server listening on 0.0.0.0 port 50022.
Jan 23 08:35:24 tk2-233-26158 sshd[8867]: Server listening on :: port 50022.
Jan 23 08:35:24 tk2-233-26158 sudo: pam_unix(sudo:session): session closed for user root
Jan 23 08:38:08 tk2-233-26158 sshd[8870]: Connection closed by 127.0.0.1 port 38620 [preauth]
Jan 23 08:39:45 tk2-233-26158 sudo:   ubuntu : TTY=pts/0 ; PWD=/etc/ssh ; USER=root ; COMMAND=/usr/bin/ssh -p 50022 localhost
Jan 23 08:39:45 tk2-233-26158 sudo: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Jan 23 08:39:50 tk2-233-26158 sudo: pam_unix(sudo:session): session closed for user root
Jan 23 08:39:50 tk2-233-26158 sshd[8874]: Connection closed by 127.0.0.1 port 38622 [preauth]
Jan 23 08:41:43 tk2-233-26158 sudo:   ubuntu : TTY=pts/0 ; PWD=/etc/ssh ; USER=root ; COMMAND=/usr/bin/vim sshd_config
Jan 23 08:41:43 tk2-233-26158 sudo: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Jan 23 08:42:22 tk2-233-26158 sudo: pam_unix(sudo:session): session closed for user root
Jan 23 08:42:28 tk2-233-26158 sudo:   ubuntu : TTY=pts/0 ; PWD=/etc/ssh ; USER=root ; COMMAND=/usr/sbin/service ssh restart
Jan 23 08:42:28 tk2-233-26158 sudo: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Jan 23 08:42:29 tk2-233-26158 sshd[8867]: Received signal 15; terminating.
Jan 23 08:42:29 tk2-233-26158 sshd[8890]: Server listening on 0.0.0.0 port 50022.
Jan 23 08:42:29 tk2-233-26158 sshd[8890]: Server listening on :: port 50022.
Jan 23 08:42:29 tk2-233-26158 sshd[8890]: Server listening on 0.0.0.0 port 22.
Jan 23 08:42:29 tk2-233-26158 sshd[8890]: Server listening on :: port 22.
Jan 23 08:42:29 tk2-233-26158 sudo: pam_unix(sudo:session): session closed for user root
Jan 23 08:42:35 tk2-233-26158 sshd[8892]: Accepted publickey for ubuntu from 49.129.136.208 port 54583 ssh2: ECDSA SHA256:9nmovVIQo/p2K5Sm4afnpqWUJy3XOAUfyoR2evW6us4
Jan 23 08:42:56 tk2-233-26158 sshd[7971]: Received disconnect from 49.129.136.208 port 53700:11: disconnected by user
Jan 23 08:42:56 tk2-233-26158 sshd[7971]: Disconnected from 49.129.136.208 port 53700
Jan 23 08:42:56 tk2-233-26158 sshd[8894]: Received disconnect from 49.129.136.208 port 54583:11: disconnected by user
Jan 23 08:42:56 tk2-233-26158 sshd[8894]: Disconnected from 49.129.136.208 port 54583
Jan 23 08:42:56 tk2-233-26158 sshd[8272]: Received disconnect from 49.129.136.208 port 54109:11: disconnected by user
Jan 23 08:42:56 tk2-233-26158 sshd[8272]: Disconnected from 49.129.136.208 port 54109
Jan 23 08:44:14 tk2-233-26158 sshd[9001]: Accepted publickey for ubuntu from 49.129.136.208 port 54593 ssh2: ECDSA SHA256:9nmovVIQo/p2K5Sm4afnpqWUJy3XOAUfyoR2evW6us4
Jan 23 08:44:45 tk2-233-26158 sshd[9111]: Connection closed by 127.0.0.1 port 57672 [preauth]
Jan 23 08:46:31 tk2-233-26158 sshd[9114]: Connection closed by 127.0.0.1 port 38626 [preauth]
Jan 23 08:47:04 tk2-233-26158 sshd[9117]: Connection closed by 127.0.0.1 port 57676 [preauth]
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • grilled_python

    2019/01/22 15:54 編集

    ありがとうございます。消しておきました。
    初心者でして、練習用に借りております。

    キャンセル

  • CHERRY

    2019/01/23 08:58

    ubuntu なら、サーバーの /var/log/auth.log あたりに ssh の接続ログが出力されていると思いますが、ポート変更後の ssh ログはどのように記録されていますか?

    キャンセル

  • grilled_python

    2019/01/23 09:11

    回答ありがとうございます。
    ログの一部を追記いたしました。

    キャンセル

回答 3

checkベストアンサー

+1

ファイヤフォールで拒否されているなんてことはないでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/23 08:27 編集

    ポートを50022にした状態で、ssh -p 50022 localhostで接続できれば、sshの設定は問題ないと判断して良いと思います。

    キャンセル

  • 2019/01/23 08:51 編集

    回答ありがとうございます。
    localhostで接続という事ですとターミナル側からではなくubuntu側からsshでしょうか?
    試しにどちらからもやってみました。
    ターミナル側
    ssh: connect to host localhost port 50022: Connection refused
    ubuntu側
    Permission denied (publickey).
    となっております

    キャンセル

  • 2019/01/25 17:28

    時間がかかりましたがうまくいきました!!!!
    https://qiita.com/tpywao/items/76899267b9935038d9cd
    こちらを参考にしました。

    >>iptableを停止するのではなく、設定を変更してみてはどうでしょうか?

    $sudo vim /etc/iptables/iptables.rules

    --A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
    +-A INPUT -m state --state NEW -m tcp -p tcp --dport 50022 -j ACCEPT

    $sudo iptables-restore < /etc/iptables/iptables.rules

    どうも設定を書き込むだけで最後のコマンドで設定を更新していなかったのが原因のようです。

    回答いただいた方すべてに感謝いたします。大分勉強になりました。

    キャンセル

+1

ssh: connect to host xxx.xx.xxx.xxx port 50022: Connection refused

で見る限り、サーバで接続を蹴られていて

sshd  19654 root 3u IPv4  177093  0t0  TCP  *:50022(LISTEN)

を見ると、ポートは開いているようなので、接続先を間違っているとか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/22 16:33

    回答ありがとうございます。
    確認しましたがipアドレスに間違いはありません
    試しに
    $ sudo vim /etc/ssh/sshd_config
    - Port 50022
    + Port 22
    と22番に戻してみて
    リスタート
    入力履歴のコマンドを50022から22に書き換えて実行したところ
    ssh接続できる様になりました。
    もう一度50022に戻し、リスタート
    5022では接続できない様な状態です

    キャンセル

  • 2019/01/22 16:59

    > もう一度50022に戻し、リスタート
    このあと、もう一度 22 で接続してみてください。
    つながれば、接続先の間違いです。

    キャンセル

  • 2019/01/22 17:12

    22でssh接続できました。
    接続先を間違えているというのはどこを確認すればよろしいでしょうか?
    よろしくお願いいたします

    キャンセル

  • 2019/01/22 20:19

    別のサーバに接続しようとしています。
    該当のサーバのアドレスを確認の上、正しいアドレスで接続してください。

    キャンセル

0

selinux を無効にしてみてはどうでしょうか
GCPのCompute Engineで同じようになった際にselinuxが邪魔していました

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/22 16:46

    getenforce
    Disabled
    でした。しかし、SElinuxというものを知る事ができました
    ありがとうございます

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.96%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る