質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.13%

C#で作ったボットをAzureに発行したが動かない

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 1,482

poorpoor

score 22

以前の質問からまだ数日のうちですが、今一度お助けください。

先日はお力添えにより無事ボットを発行できたのですが、その後『WEBチャットでテスト』でテストしたところ、何度メッセージを送っても「送信できませんでした」となってしまいます。
Azureの『チャンネル』を確認すると、「There was an error sending this message to your bot: HTTP status code NotFound」というエラーメッセージが出ていました。
どうすれば実機でもボットが動くようになるでしょうか?

Web.configファイルは

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <appSettings>
    <!-- update these with your BotId, Microsoft App Id and your Microsoft App Password-->
    <add key="BotId" value="アプリケーション発行時のプロファイル名" />
    <add key="MicrosoftAppId" value="Azureで生成したアプリケーションのID" />
    <add key="MicrosoftAppPassword" value="Azureで生成したアプリケーションのパスワード" />
  </appSettings>
  <system.webServer>
    <handlers>
      <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModule" resourceType="Unspecified" />
    </handlers>
    <aspNetCore processPath="dotnet" arguments=".\(slnファイル名).dll" stdoutLogEnabled="false" stdoutLogFile="\\?\%home%\LogFiles\stdout" />
  </system.webServer>
</configuration>

このようになっています。

エミュレーターでは応答でき、これとは別の、BotFrameworkのテンプレートを使って作ったエコーボットでも動きませんでした。
『Bot Channels Registration』ではなく『WebAPP』で作ったリソースに発行してみましたが、やはり動きません。
ngrokはインストールしてありますが、使ってはいません。

ボットの発行は、主に下のサイトを参考にしています。
1.Visual Studio を使用して C# ボットをデプロイする
2.Azure Bot Serviceを使ってFAQBotを公開までの備忘録
3.Bot Framework V4で編集しやすいベースとなるボットを作成してAzureにデプロイ
(ただし3についてですが、ボットの発行時点でIDとパスワードを保存しているので、「Botにセキュリティ認証部分を追加」欄にある「「設定」のノードで、Microsoft App IDの「管理」を選択」という操作はしていません。
また、StartupファイルのConfigureServicesメソッドにAPP認証処理を書いていても書いていなくても、同じくボットは動きませんでした)

度々ですが、よろしくお願いします。

1/25
こちらのサイト(youtube)で、同じエラーに対処する動画を見つけました。参考にして『高度なツール』からKUDUを開いたのですが、動画ではwwwrootのフォルダにたくさんのファイルやフォルダがあったのに対し、私のボットには「hostingstart.html」しかありませんでした。

もしかしたら発行時にフォルダやファイルが抜けおちているのかもしれません。
どうすればいいでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

こんにちは。

お疲れ様です。

考えられる要因は複数ありますが、調べてみるとほとんどが
・アプリケーションの停止によりメッセージを受信できない
・ボットがメッセージを受信しても応答に失敗する
ということがわかりました。

Webチャット機能ですでに機能していないというようですので、ボットが動作しているかの確認はできていますでしょうか?
1.[概要] ウィンドウを開く
2.[Messaging endpoint](メッセージング エンドポイント) をコピーし、ブラウザーに貼り付け

・エンドポイントから、HTTPエラー405が返される場合
ボットが到達可能であり、ボットがメッセージに応答できていますので、ボットがタイムアウトしている
か、HTTP5xxエラーで失敗しているかを調べる必要があります。
・エンドポイントから "このサイトに到達できない" または "このページに到達できない"というエラーが返される場合
ボットが停止しているため、再デプロイする必要があります。

追記です。

<configuration>
<system.webServer>
    <rewrite>
      <rules>
        <rule name="Main Rule" stopProcessing="true">
                <match url=".*" />
                <conditions logicalGrouping="MatchAll">
                    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                </conditions>
                <action type="Rewrite" url="/" />
            </rule>
        </rules>
    </rewrite>
</system.webServer>
</configuration>

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/23 11:43 編集

    お返事ありがとうございます。
    ご提示いただいたコードを試してみましたが、やっぱり動きませんでした。

    キャンセル

  • 2019/01/24 11:49

    またお返事が遅くなりました。

    試していただいたんですね、ありがとうございました。
    でもやはり動かなかったと…。

    うーん、何が原因なのか。
    >ただし3についてですが、ボットの発行時点でIDとパスワードを保存しているので、「Botにセキュリティ認証部分を追加」欄にある「「設定」のノードで、Microsoft App IDの「管理」を選択」という操作はしていません。

    この箇所で管理を選択してみるとか…?
    あとは今一度、作成したときの方法を繰り返していただいて改めてチャットボットを作成してみるくらいしか思い浮かびませんでした…。
    申し訳ないです。

    キャンセル

  • 2019/01/25 14:41

    エラーページをF12で開いたら『Failed to load resource: the server responded with a status of 404 (Not Found)』と出たので、なんだかメッセージングエンドポイントが作成されていなさそうなんですよね……。

    ともあれ、ありがとうございました。前の質問と併せてお世話になりました。
    また何か思いついたことがありましたら、よろしくお願いします。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる