質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.57%

既存のEclipse mars4.5にPyDevを追加する方法について

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 631

HelpfulJp

score 20

PyDevの環境構築の方法わかりますか?EclipseのMars4.5でPyDevを使いたいのです。helpの新規ソフトとしてURLを介しインストールしたところ使えませんでした。

※URLを介してダウンロードする方法のほかに、PyDev5.2.0のzipファイルをダウンロードし解凍して、eclipseのdropinsの中に入れる方法も試しました。しかし、org.python.pydev.debug.newcosole.prefs.interactionConsolePrefs cannot be found by org.python.pydev.debug_5.2.0.qualifier
と返されて動きませんでした。

もしかしてPCの環境変数がおかしいのですかね。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

わかります。ずっとPyDevを使っていて、いつもhelpの新規ソフトとしてURLを介しインストールしています。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/16 17:38

    zip fileを介して入れる方法も試してみたんですけどなぜかダメでした(焦)なぜかわかりますか?

    http://www.pydev.org/manual_101_install.html

    いちおうPydevのオフィシャルページを参考にしたのですけどね^^;不思議です。

    キャンセル

  • 2018/11/16 18:29

    「zip fileを介して入れる方法」はやったことないです。不思議ですね、私は今までPyDevのインストールに失敗したことがありません。

    キャンセル

  • 2018/11/16 21:19

    なるほど。ちなみにeclipseのバージョンはいくつですか?試そうか考えてみます。

    キャンセル

  • 2018/11/17 14:55

    今手元にあるのは4.6.3ですが、それよりも古くても新しくても、どのバージョンでも失敗したことはありません。

    キャンセル

check解決した方法

0

解決法はわかなかったので2018-09のEclipseのpython(Pydev入りのpython抜き)スタンダードをダウンロードし、既存のAnacondaと連結させて使いました。このとき、Anaconda3だとwindows10のmklとのトラブルがでてnumpyなどが使えない状態となります。解決法はteratailに載ってましたが機器やdirectory内のファイル消去と再ダウンロードの手間とリスクがあるため、Anaconda3をアンインストールしてAnaconda2に切り替えました。解決法の模索中にpipを取り入れるのも考えましたが、どうやらAnacondaとpipを一緒に入れると何か問題があるそうだったので止めました。

とりあえず、2018-09Eclipse(all)か2018-09Eclipse(standard)+Anaconda2が初心者にとって無難です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.57%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る