質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.58%

chromeで検索ページを出したあとに出るエラーについて

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 764

nekomami

score 10

python selenium chromeで表示させたページのサーチエリアに、
検索ワードを入力して検索ボタンをクリックし、
検索結果のページが表示されたあとに、ターミナル画面でエラーが表示されます。
chromeのブラウザでは検索ワードが正しく検索され、検索結果のWebページが表示されています。
ここまでのコードは下記です。

driver = webdriver.Chrome("C:\chromedriver\chromedriver.exe")
driver.get(url)
search_area = driver.find_element_by_css_selector('○○○').send_key("ワード")
driver.find_element_by_css_selector('○○○').click()

上記実行後に、ターミナルにエラーが出ます。
おそらくですが、検索結果の表示件数分相当の行数でエラーが出ます。
検索結果が30件あれば、30行ほど同じエラーが連なります。
エラーは下記です。
chromeでは検索結果のWebページが表示されています。

[xxxx/xxxxxx.▲▲▲:ERROR:inspector_emulator_agent.cc(477)] Can only enable virtual time for pages, not workers


xと▲は、数字です。×の部分は、どの行数も同じ数字です。▲は一つずつ増えます。
(例)
1234/654321/991
1234/654321/992
1234/654321/993
1234/654321/994

同じ方法でいくつかの検索サイトを読み込んで検索してみましたが、上記のようなエラーはありません。
ひとつのサイトだけでこのようなエラーがでます。
このエラーは何のエラーでしょうか。
また、ご存知でしたらエラーがでないようにする方法を教えていただけないでしょうか。

どうぞよろしくお願いします。
(不足情報ご指摘ください。追記いたします。お手数おかけいたします。)

追記:
エラーを検索して下記URLにたどり着きましたが、何のエラーなのかもどう対処すればいいのかもわかりませんでした。よくわからないまま、options.add_argument('--no-sandbox')等加えてみましたが、ダメでした。。。

https://stackoverflow.com/questions/52936260/errorinspector-emulator-agent-cc477-can-only-enable-virtual-time-for-pages-n


windows7
python-3.6.4
selenium

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

まず、環境の問題なのかコードの問題なのか切り分けて行きましょうか。
紹介されているコードで省略されている部分もあると思いますので、Googleでwordを検索する以下のコードを動かしてみて動くかどうか確認していただけますか。
私の手元ではブラウザの起動から終了(Quit)まで動作していることを確認済みです。
(chromedriverのパスを通しているため、driver = webdriver.Chrome()と書いています)

# coding:utf-8
from selenium import webdriver

driver = webdriver.Chrome()

url = 'https://www.google.com/'
driver.get(url)
search_area = driver.find_element_by_id('lst-ib').send_keys('word')
driver.find_element_by_name('btnK').click()

driver.quit()

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/16 09:34

    ご丁寧にご連絡ありがとうございました。

    ご記載いただきましたコード実行しました。
    driver = webdriver.Chrome(chrome_options=options) のあとに、
    -------------------
    [1116/091926.406:ERROR:gpu_process_transport_factory.cc(980)]Lost UI shared context.
    -------------------
    このようなエラーが出ます。
    すみません。お手数おかけします。よろしくお願いします。

    キャンセル

  • 2018/11/19 11:16

    実行ありがとうございます。
    こうなると環境に問題がある可能性が高いですね。
    Chrome/ChromeDriverのバージョンが古かったりすると不具合がある可能性がありますがいかがでしょうか?

    キャンセル

  • 2018/11/19 15:36

    ご連絡ありがとうございます。
    ChromeDriver 2.43 でしたので、確認いたしましたが最新版のようでした。
    おっしゃられるとおり、私の環境に原因があると思います。
    このWebページでのみエラーがでるという条件が付きますし、エラーを見ても理解できませんし、時間がかかりそうです、、、。
    お付き合いしてくださってありがとうございました。
    少しずつ解決できるよういろいろと調べて試してみます。
    また何か思いつくことがございましたら教えてください。
    どうぞよろしくお願いします。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.58%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る