質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
import

自身のプラットフォーム・プログラム・データセットに対して、外部ソースを取り込むプロセスをimportと呼びます。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pandas

Pandasは、PythonでRにおけるデータフレームに似た型を持たせることができるライブラリです。 行列計算の負担が大幅に軽減されるため、Rで行っていた集計作業をPythonでも比較的簡単に行えます。 データ構造を変更したりデータ分析したりするときにも便利です。

解決済

pandasがインポートできない件について (AttributeError)

kompeito
kompeito

総合スコア13

import

自身のプラットフォーム・プログラム・データセットに対して、外部ソースを取り込むプロセスをimportと呼びます。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pandas

Pandasは、PythonでRにおけるデータフレームに似た型を持たせることができるライブラリです。 行列計算の負担が大幅に軽減されるため、Rで行っていた集計作業をPythonでも比較的簡単に行えます。 データ構造を変更したりデータ分析したりするときにも便利です。

1回答

0評価

0クリップ

25129閲覧

投稿2018/10/25 04:01

前提・実現したいこと

Jupyter notebookを使って、pandasをインポートしようとしています。

発生している問題・エラーメッセージ

他のライブラリー(numpyやglobなど)インポートできるのですが、pandasだけエラーが生じてしまいます(AttributeError)。
pandasのpip install自体はうまくいっているようです。

-------------pip install後の表示------------

Python

Requirement already satisfied: pandas in ~/anaconda3/lib/python3.7/site-packages (0.23.4) Requirement already satisfied: python-dateutil>=2.5.0 in ~/anaconda3/lib/python3.7/site-packages (from pandas) (2.7.3) Requirement already satisfied: pytz>=2011k in ~/anaconda3/lib/python3.7/site-packages (from pandas) (2018.5) Requirement already satisfied: numpy>=1.9.0 in ~/anaconda3/lib/python3.7/site-packages (from pandas) (1.15.1) Requirement already satisfied: six>=1.5 in ~/anaconda3/lib/python3.7/site-packages (from python-dateutil>=2.5.0->pandas) (1.11.0)

-------------import後のエラーメッセージ------------------

Python

AttributeError Traceback (most recent call last) <ipython-input-70-7dd3504c366f> in <module>() ----> 1 import pandas as pd ~/anaconda3/lib/python3.7/site-packages/pandas/__init__.py in <module>() 43 from pandas.core.sparse.api import * 44 from pandas.tseries.api import * ---> 45 from pandas.core.computation.api import * 46 from pandas.core.reshape.api import * 47 ~/anaconda3/lib/python3.7/site-packages/pandas/core/computation/api.py in <module>() 1 # flake8: noqa 2 ----> 3 from pandas.core.computation.eval import eval 4 5 ~/anaconda3/lib/python3.7/site-packages/pandas/core/computation/eval.py in <module>() 7 import tokenize 8 from pandas.io.formats.printing import pprint_thing ----> 9 from pandas.core.computation.scope import _ensure_scope 10 from pandas.compat import string_types 11 from pandas.core.computation.engines import _engines ~/anaconda3/lib/python3.7/site-packages/pandas/core/computation/scope.py in <module>() 49 50 _DEFAULT_GLOBALS = { ---> 51 'Timestamp': pandas._libs.tslib.Timestamp, 52 'datetime': datetime.datetime, 53 'True': True, AttributeError: module 'pandas' has no attribute '_libs'

該当のソースコード (Jupyter notebook上で実行)

Python

!pip install pandas import pandas as pd

試したこと

numpyなど、その他のモジュールではうまくいきました。

Python

!pip install numpy import numpy as np

pip3 installも試してみましたが、同様のエラーが生じています。

Python

!pip2 install pandas import numpy as np

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

tiitoi
tiitoi

2018/10/25 04:03

import pandas;print(pandas.__file__) とするとどうなりますか?
kompeito
kompeito

2018/10/25 04:06

試してみましたが、同一のエラーが生じました(AttributeError: module 'pandas' has no attribute '_libs')
tiitoi
tiitoi

2018/10/25 04:10

スクリプトを実行している場所に pandas という名前のフォルダや pandas.py という名前のファイルがあったりしないですかね?その場合は名前を変えるか、削除してください。
kompeito
kompeito

2018/10/25 04:16

ご返信有難うございます。実行フォルダ(jupyterを開いている場所)中には、解析対象のデータ(txtファイル)しか保存しておりません…
tiitoi
tiitoi

2018/10/25 04:31

うーん import pandas でコケているんですね。pip install --upgrade pandas で一応更新してみてください。それでも無理だったらちょっとわからないです。すみません。
kompeito
kompeito

2018/10/25 04:47

色々とご対応いただきありがとうございます。『Requirement already up-to-date』と表示されてしまい、更新できませんでした。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

import

自身のプラットフォーム・プログラム・データセットに対して、外部ソースを取り込むプロセスをimportと呼びます。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pandas

Pandasは、PythonでRにおけるデータフレームに似た型を持たせることができるライブラリです。 行列計算の負担が大幅に軽減されるため、Rで行っていた集計作業をPythonでも比較的簡単に行えます。 データ構造を変更したりデータ分析したりするときにも便利です。