質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

解決済

Can't find the ImageMagick library or one of the dependent libraries。Rmagickが入れられないというエラー

ko-u
ko-u

総合スコア61

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

2回答

0評価

0クリップ

3775閲覧

投稿2018/10/24 03:39

編集2018/10/25 05:34

Ruby初心者です。
現在、ターミナル上で以下のようなエラーが起こっております。

ご教授頂けますと幸いです。

【問題点】
以前にインストールしていたのにも関わらず、Rmagickをインストールすることが出来ないというエラー。

【状況】
・Ruby 2.5.1

Permission denied @ rb_sysopen

当初はrailsがインストールされていないというエラーが表示されおりました。

そこでディレクトリの権限がないのかな?と思い、下記サイトを参考に

sudo chown -R (ユーザ名):staff /Users/(ユーザ名)/.rbenv

を実行したところrmagickがインストールされていないというエラーに変わりました。

実際、ターミナル上では

Make sure that `gem install rmagick -v '2.16.0' --source 'https://rubygems.org/'` succeeds before bundling.

というエラーが表示されています。

mkmf.logを開くと

find_executable: checking for clang... -------------------- yes -------------------- find_executable: checking for Magick-config... -------------------- yes -------------------- configure_compile_options: checking for outdated ImageMagick version (<= 6.4.9)... -------------------- no Detected ImageMagick version: 6.9.10 -------------------- configure_compile_options: checking for presence of MagickWand API (ImageMagick version >= 6.9.0)... -------------------- no Detected 6.9+ version, using MagickWand API-------------------- assert_minimum_ruby_version!: checking for Ruby version >= 1.8.5... -------------------- yes -------------------- Can't install RMagick 2.16.0. Can't find the ImageMagick library or one of the dependent libraries. Check the mkmf.log file for more detailed information.

と表示されています。

【原因?】
原因はMacのターミナル上で日本語入力が文字化けしてしまっていたので以下の処理をしたことだと思います。(文字化けは解決)
https://teratail.com/questions/101914

その後に、ローカルを開くとエラーが表示されるようになっていました。

【対応】
・bundle install, bundle update,gem install rmagick -v '2.16.0' をするも変わりません
・再度、sudo chown -R (ユーザ名):staff /Users/(ユーザ名)/.rbenv
・ImageMagick 6 系に再度update

【参考にした記事】
https://qiita.com/nachiguro1003/items/4b564b92eca3ba35744a
http://infinity108.com/114/
https://teratail.com/questions/101914
https://qiita.com/motty93/items/29e22c6bf811f8dd00ab

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。