質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.32%

  • Ruby

    8213questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7693questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

bundle installでfatal: No live threads left. Deadlock?とエラーがでて失敗します

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 851

mitsuru793

score 149

rbenvでrubyで2.1.1がインストールできなかったので、下記の通りソースコードからコンパイルしました。その後bundle installを実行すると、fatal: No live threads left. Deadlock?と表示されます。これは何が起きているのでしょうか?解決策を教えていただきたいです。

ソースコードは下記にあります。
https://github.com/everydayrails/rails-4-1-rspec-3-0

ご回答、よろしくお願い致します。

環境
Max OS X Yosemite 10.10.3
zsh 5.0.8 (x86_64-apple-darwin14.3.0)
rbenv 0.4.0

# 有効なopensslコマンドのバージョンを調べます。
# これはmac osに最初から入っていたもの?
 % openssl version
OpenSSL 0.9.8zd 8 Jan 2015

# brewでインストールした場所とそのバージョンを調べます。
# 現在、2つのopensslが入っていることがわかりました。
 % brew --prefix openssl
/usr/local/opt/openssl
 % /usr/local/opt/openssl/bin/openssl version
OpenSSL 1.0.2d 9 Jul 2015

# brew本体とfomula(パッケージ)全てをインストールします。
 % brew update

# kオプションでrubyのソースコードをダウンロード後、削除しないようにします。
 % rbenv install -k 2.1.1

# バッククォートの部分が先に実行され、その結果が文字列として置き換わります。
# opensslにはbrewの方のパスを設定して、新しいバージョンにします。
 % ./configure --prefix=/Users/mitsuru/.rbenv/versions/2.1.1  --with-openssl-dir=`brew --prefix openssl`
 % make
 % make test
 % make install

 % bundle install
# 一部省略
Using sass-rails 4.0.3
Using turbolinks 2.2.2
--- ERROR REPORT TEMPLATE -------------------------------------------------------
- What did you do?

  I ran the command `./bin/bundle `

- What did you expect to happen?

  I expected Bundler to...

- What happened instead?

  Instead, what actually happened was...


Error details

    fatal: No live threads left. Deadlock?
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/worker.rb:35:in `pop'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/worker.rb:35:in `deq'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/installer/parallel_installer.rb:93:in `process_specs'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/installer/parallel_installer.rb:74:in `call'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/installer/parallel_installer.rb:56:in `call'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/installer.rb:274:in `install_in_parallel'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/installer.rb:91:in `run'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/installer.rb:18:in `install'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/cli/install.rb:107:in `run'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/cli.rb:162:in `install'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in `invoke_command'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/vendor/thor/lib/thor.rb:359:in `dispatch'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/vendor/thor/lib/thor/base.rb:440:in `start'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/cli.rb:10:in `start'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/bin/bundle:20:in `block in <top (required)>'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/lib/bundler/friendly_errors.rb:7:in `with_friendly_errors'
      /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday/gems/bundler-1.10.6/bin/bundle:18:in `<top (required)>'
      ./bin/bundle:3:in `load'
      ./bin/bundle:3:in `<main>'

Environment

    Bundler   1.10.6
    Rubygems  2.2.2
    Ruby      2.1.1p76 (2014-02-24 revision 45161) [x86_64-darwin14.0]
    GEM_HOME  /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday
    GEM_PATH  /Users/mitsuru/.rbenv/versions/2.1.1/gemsets/everyday:/Users/mitsuru/.rbenv/versions/2.1.1/gemsets/global:/Users/mitsuru/.rbenv/versions/2.1.1/lib/ruby/gems/2.1.0
    Git       2.3.2 (Apple Git-55)

Bundler settings

    jobs
      Set for the current user (/Users/mitsuru/.bundle/config): "3"
    gemfile
      Set via BUNDLE_GEMFILE: "/Users/mitsuru/Desktop/work/rails-4-1-rspec-3-0/Gemfile"
--- TEMPLATE END ----------------------------------------------------------------

Unfortunately, an unexpected error occurred, and Bundler cannot continue.

First, try this link to see if there are any existing issue reports for this error:
https://github.com/bundler/bundler/search?q=No+live+threads+left.+Deadlock%3F&type=Issues

If there aren't any reports for this error yet, please create copy and paste the report template above into a new issue. Don't forget to anonymize any private data! The new issue form is located at:
https://github.com/bundler/bundler/issues/new
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

bundle install --jobs=1でインストールすることができました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

自分は全くの素人なので、的外れだったらゴメンなさい!って最初にお断りしておきますね。

あくまでも 想像 で書いていますが、
rbenvでインストールされたものと、ソースからインストールされたものでは、当然、インストール先が異なり切り替えがうまく行かない(コマンド実行時に、コマンド本体と関連モジュールのバージョンの整合性が保たれない)ことが予想されます。

それで、こちら を参考に、たとえば PATH の設定順序 などを再点検してみてはいかがでしょうか?
解決のヒントが何か見つかるかもしれませんので。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/08/29 12:58

    gistにはこのような質問も投稿されているのですね。
    ご回答ありがとうございました。

    キャンセル

同じタグがついた質問を見る

  • Ruby

    8213questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7693questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。