質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

  • Ruby

    8728questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8127questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Ruby version is 2.3.7, but your Gemfile specified 2.5.0とエラーが出てしまう

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,539

unico444

score 1

初歩的な質問で恐縮ですが、どなたか助けていただけませんでしょうか
railsの構築でつまずいてしまい、抜けられず困っています

$rails server で実行すると
Your Ruby version is 2.3.7, but your Gemfile specified 2.5.0
とエラーが出てしまいます

$ rails -v で確認すると同じく
Your Ruby version is 2.3.7, but your Gemfile specified 2.5.0

$ ruby -v 確認してみると
ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-darwin17]

$ which ruby
/Users/okasir/.rbenv/shims/ruby

$rbenv version
2.5.0 (set by /Users/okasir/rails-workspace/tweet_app/.ruby-version)
yamamotos-iMac:tweet_app okasir$

★試したこと
$rails g controller で実行すると
Your Ruby version is 2.5.0, but your Gemfile specified 2.3.7 (Bundler::RubyVersionMismatch)
とエラーが出たのでGimfileを2.5.0に書き換えました
すると今度は上記のYour Ruby version is 2.3.7, but your Gemfile specified 2.5.0 が出てしまい..

どうすればruby2.5.0と認識されるのでしょうか
どうぞよろしくお願いいたします

 

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

which bundler

を実行すると、/Users/okasir/.rbenv/shims/bundlerと返ってきますか?
もしそうでなければ、

gem install bundler

と実行してみてから、rails -vと実行するとどうでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/08 23:07

    ありがとうございます! bundlerが正しくインストールされていない(rubyをインストールした後にインストールしていない)からエラーになった可能性があるのですね
    いろいろ試した後結局rails自体をインストールし直して解決したので、ご指摘いただいた方法は検証できなかったのですが、勉強になりました
    お忙しい中ありがとうございました!

    キャンセル

同じタグがついた質問を見る

  • Ruby

    8728questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8127questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。