質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.42%
CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

PECL

PECL(PHP Extension Community Library)は、PHPで利用できる拡張ライブラリです。 PECLはCで記述されているため、PHPで記述されたPEARのライブラリよりも高速に動作します。

yum

yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。

Q&A

解決済

1回答

18000閲覧

CentOS7でphp-pear(pecl)がインストールできない

okame

総合スコア54

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

PECL

PECL(PHP Extension Community Library)は、PHPで利用できる拡張ライブラリです。 PECLはCで記述されているため、PHPで記述されたPEARのライブラリよりも高速に動作します。

yum

yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。

1グッド

1クリップ

投稿2018/07/31 12:20

前提・実現したいこと

CentOS7にてyumでphp-pear(pecl)をインストールしようとしたらエラーが出てうまくいきません。

発生している問題・エラーメッセージ

$ sudo yum install php-pear 読み込んだプラグイン:fastestmirror Loading mirror speeds from cached hostfile * base: ftp.jaist.ac.jp * epel: mirrors.cat.pdx.edu * extras: ftp.jaist.ac.jp * remi-safe: ftp.riken.jp * updates: ftp.jaist.ac.jp 依存性の解決をしています --> トランザクションの確認を実行しています。 ---> パッケージ php-pear.noarch 1:1.9.4-21.el7 を インストール --> 依存性の処理をしています: php-xml のパッケージ: 1:php-pear-1.9.4-21.el7.noarch --> 依存性の処理をしています: php-posix のパッケージ: 1:php-pear-1.9.4-21.el7.noarch --> トランザクションの確認を実行しています。 ---> パッケージ php-process.x86_64 0:5.4.16-45.el7 を インストール --> 依存性の処理をしています: php-common(x86-64) = 5.4.16-45.el7 のパッケージ: php-process-5.4.16-45.el7.x86_64 ---> パッケージ php-xml.x86_64 0:5.4.16-45.el7 を インストール --> 依存性の処理をしています: php-common(x86-64) = 5.4.16-45.el7 のパッケージ: php-xml-5.4.16-45.el7.x86_64 --> 依存性解決を終了しました。 エラー: パッケージ: php-process-5.4.16-45.el7.x86_64 (base) 要求: php-common(x86-64) = 5.4.16-45.el7 インストール: php-common-7.0.31-1.el7.remi.x86_64 (@remi-php70) php-common(x86-64) = 7.0.31-1.el7.remi 利用可能: php-common-5.4.16-45.el7.x86_64 (base) php-common(x86-64) = 5.4.16-45.el7 エラー: パッケージ: php-xml-5.4.16-45.el7.x86_64 (base) 要求: php-common(x86-64) = 5.4.16-45.el7 インストール: php-common-7.0.31-1.el7.remi.x86_64 (@remi-php70) php-common(x86-64) = 7.0.31-1.el7.remi 利用可能: php-common-5.4.16-45.el7.x86_64 (base) php-common(x86-64) = 5.4.16-45.el7 問題を回避するために --skip-broken を用いることができます。 ** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows: binutils-2.27-28.base.el7_5.1.x86_64 は binutils-2.27-27.base.el7.x86_64 の複製です gnupg2-2.0.22-5.el7_5.x86_64 は gnupg2-2.0.22-4.el7.x86_64 の複製です google-cloud-sdk-207.0.0-1.el7.noarch は google-cloud-sdk-204.0.0-1.el7.noarch の複製です google-cloud-sdk-208.0.0-1.el7.noarch は google-cloud-sdk-207.0.0-1.el7.noarch の複製です google-cloud-sdk-208.0.2-1.el7.noarch は google-cloud-sdk-208.0.0-1.el7.noarch の複製です google-cloud-sdk-209.0.0-1.el7.noarch は google-cloud-sdk-208.0.2-1.el7.noarch の複製です selinux-policy-targeted-3.13.1-192.el7_5.3.noarch は次の要求が不足ています: selinux-policy = ('0', '3.13.1', '192.el7_5.3') selinux-policy-targeted-3.13.1-192.el7_5.4.noarch は selinux-policy-targeted-3.13.1-192.el7_5.3.noarch の複製です

以上です

お手数ですが皆さんのお知恵を拝借できれば幸いです。
宜しくお願いいたします。

DrqYuto👍を押しています

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

ベストアンサー

PHP7をインストールするとき、以下のようにしたと思いますが、

yum install --enablerepo=remi,remi-php70 php

同じように、remiリポジトリを指定してインストールすればよいです。

yum install --enablerepo=remi,remi-php70 php-pear

投稿2018/07/31 12:58

lightwill

総合スコア962

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

okame

2018/07/31 13:01

ご教示いただいた方法で解決しました!PHP7インストール時のことを忘れていました^^; ありがとうございました。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.42%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問