質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.33%

  • Ruby on Rails

    7716questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

railsでactive_storageが読み込めていない件について

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 278

KoheiNoma

score 4

railsでwebアプリの開発をしています。コマンドで「rails server」と打ったら添付画像のようなNoMethodErrorが出ました。エラー文検索すると「config/application.rb」ファイルの「config.load_defaults 5.1」という箇所をコメントアウトすると良いと書かれていたのでそのような感じでやりましたが、エラーが治りませんでした。原因がわからず困っています。どなたか教えていただけると嬉しいです。

エラー文
undefined method `active_storage' for #<Rails::Application::Configuration:0x00007fc6623b1f98> (NoMethodError)

イメージ説明
イメージ説明
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

これだとどうやってactive_storageを消してるのかがよくわからなかったのですが、もしActiveStorageが不要であれば、config/environments/*.rb等にある「active_storage」の行を全部コメントアウト等して消すと良いかもしれません。

具体的には「active_storage」の行は以下で確認できます。

$ git grep 'active.*storage' |grep -v Gemfile
app/assets/javascripts/application.js://= require activestorage
config/environments/development.rb:  config.active_storage.service = :local
config/environments/production.rb:  config.active_storage.service = :local
config/environments/test.rb:  config.active_storage.service = :test

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/03 08:46

    いつもお返事ありがとうございます!(;_;)コマンドに「$ git grep 'active.*storage' |grep -v Gemfile」を入力すればいいということでしょうか?

    キャンセル

  • 2018/08/03 09:13

    ちなみにactive_storageはrails5.1.0からの機能らしいので齟齬が生じているみたいなのですが、この場合どのような処理を施せば良いかわかる範囲で教えていただけると嬉しいです(;_;)railsをアップデートすればいい?のかもしれませんが、そのやり方もいまいちわからないです。

    キャンセル

0

エラーログのパス名をみるに、railties-5.0.3とあることから、Rails 5.0.3を起動しているんだと思われますね。

config.load_defaults 5.2 は、5.2向けの書き方なので、齟齬が出ているんじゃないかと。
active_storageは5.1から導入されたものだと思いますし。

rails serverではなく、bundle exec rails serverでは変化がありますか?


追記

Rails5.0.3を使用されているのですね。
どうやら、Rails5.2の書き方をしているコードが、なぜか混在しているようなので、
差し支え無ければrails newをやり直してみるのはどうでしょうか?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/02 09:47

    お返事ありがとうございます!
    >エラーログのパス名をみるに、railties-5.0.3とあることから、Rails 5.0.3を起動しているんだと思われますね。
    →なるほど。その場合そうすれば良いでしょうか?(;_;)教えていただけると嬉しいです。

    >bundle exec rails serverでは変化がありますか?
    →試してみましたが、同じエラーが表示されました(;_;)

    キャンセル

  • 2018/08/02 10:56 編集

    rails -v

    をするとどうなりますか?

    キャンセル

  • 2018/08/02 11:42

    画像にも追加しましたが、rails5.0.3と表示されました!

    キャンセル

  • 2018/08/02 13:21

    こういう場合ってどうすればいいでしょうか?rails初心者で右も左もわからない状態なので、教えていただるととても助かります。。m(._.)m

    キャンセル

  • 2018/08/03 10:35

    更新しました!

    キャンセル

  • 2018/08/03 11:03

    ありがとうございます!バージョン指定はrails _5.2.0_ new〜でできますよね?

    キャンセル

  • 2018/08/03 13:52

    やり直してみて最初rails_5.2.0_new~でアプリを作った時にrails -vで確かめるとrails5.2.0だったのですが、先ほどと同じコードを全てコピーアンドペーストして作り直した後に、rails -vで確かめるとrails5.0.3に戻っていました(T . T)
    これは何が原因なのでしょうか。。ちなみに素材としてはprogateのrailsのコードをそのまま使っています。

    キャンセル

  • 2018/08/03 15:47

    rails newのときに、バージョンを指定していたのですね。
    実行しているバージョンとの齟齬を無くすためには、バージョンを指定しないほうが良いです。

    キャンセル

  • 2018/08/03 17:06

    お返事ありがとうございます!バージョンを指定せずにもう一度作り直したほうが良いでしょうか?二回rails newをしていて一回はバージョン指定なし、もう一回はバージョン指定ありでやってどちらも最終的にrails5.0.3になってしまったのですが。。

    キャンセル

  • 2018/08/04 00:34

    5.2.0を動かしたいのに、rails 5.0.3が動いてしまう、というならば、この質問の範囲から外れそうですし、
    改めて何を試したか手順を確認してみてはどうでしょうか。

    私は、これ以上回答を更新しないとおもいます。

    キャンセル

同じタグがついた質問を見る

  • Ruby on Rails

    7716questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。