質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Linux

    3766questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • npm

    280questions

    npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

  • Express

    242questions

    ExpressはNode.jsのWebアプリケーションフレームワークです。 マルチページを構築するための機能セットおよびハイブリッドのWebアプリケーションを提供します。

  • yum

    153questions

    yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。

sudo yum install が何もできない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 334

kozica

score 26

実現したいこと

npmやexpressなどをインストールしたいのですが、すべて同じでエラーになります。
これはサーバーの設定かなにかが原因なのでしょうか
どうかお力を貸して頂きたいです

試したこと

$sudo yum install npm
読み込んだプラグイン:priorities, update-motd, upgrade-helper
パッケージ npm は利用できません。
エラー: 何もしません

$sudo yum install express
読み込んだプラグイン:priorities, update-motd, upgrade-helper
パッケージ express は利用できません。
エラー: 何もしません

ディストリビューションは下記のようになっております
$ cat /etc/*-release
NAME="Amazon Linux AMI"
VERSION="2018.03"
ID=""
ID_LIKE=""
VERSION_ID=""
PRETTY_NAME="Amazon Linux AMI 2018.03"
ANSI_COLOR="0;33"
CPE_NAME="cpe:/o:amazon:linux:2018.03:ga"
HOME_URL="http://aws.amazon.com/amazon-linux-ami/"
Amazon Linux AMI release 2018.03

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

yum のリポジトリは有効化されていますか?
"yum-config-manager --enable-repo <リポジトリ名>"
で参照したいリポジトリを有効化してから再度コマンドを実行するとどうなりますか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/25 12:09

    $ yum repolist all
    読み込んだプラグイン:priorities, update-motd, upgrade-helper
    リポジトリー ID リポジトリー名 状態
    !amzn-main/latest amzn-main-Base 有効: 5,934
    amzn-main-debuginfo/latest amzn-main-debuginfo 無効
    amzn-main-source/latest amzn-main-source 無効
    amzn-nosrc/latest amzn-nosrc-Base 無効
    amzn-preview/latest amzn-preview-Base 無効
    amzn-preview-debuginfo/latest amzn-preview-debuginfo 無効
    amzn-preview-source/latest amzn-preview-source 無効
    !amzn-updates/latest amzn-updates-Base 有効: 467
    amzn-updates-debuginfo/latest amzn-updates-debuginfo 無効
    amzn-updates-source/latest amzn-updates-source 無効
    epel/x86_64 Extra Packages for Enterprise Linux 6 無効
    epel-debuginfo/x86_64 Extra Packages for Enterprise Linux 6 無効
    epel-source/x86_64 Extra Packages for Enterprise Linux 6 無効
    epel-testing/x86_64 Extra Packages for Enterprise Linux 6 無効
    epel-testing-debuginfo/x86_64 Extra Packages for Enterprise Linux 6 無効
    epel-testing-source/x86_64 Extra Packages for Enterprise Linux 6 無効
    repolist: 6,401

    上記の場合、epel/x86_64を有効化すればよろしいのでしょうか?

    キャンセル

  • 2018/07/25 12:15

    そうですね。この場合だと
    $ sudo yum-config-manager --enable epel
    で epel は有効化できるはずなので、yum check-update とかでリポジトリの情報を取ってこれてるかどうか確認してみるといいかと思います。

    キャンセル

  • 2018/07/25 12:18

    $ yum check-update
    読み込んだプラグイン:priorities, update-motd, upgrade-helper
    amzn-main | 2.1 kB 00:00
    amzn-updates | 2.5 kB 00:00
    epel/x86_64/metalink | 5.0 kB 00:00
    1045 packages excluded due to repository priority protections
    Security: kernel-4.14.55-62.37.amzn1.x86_64 is an installed security update
    Security: kernel-3.14.48-33.39.amzn1.x86_64 is the currently running version
    情報取ってこれたので、sudo yum install npmしたら無事動きました
    ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Linux

    3766questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • npm

    280questions

    npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

  • Express

    242questions

    ExpressはNode.jsのWebアプリケーションフレームワークです。 マルチページを構築するための機能セットおよびハイブリッドのWebアプリケーションを提供します。

  • yum

    153questions

    yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。