質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.61%

  • Ruby

    7324questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6984questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Railsチュートリアルにて Rubyのversion変更出来ない。

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 740

cheeeeeeese

score 149

初めまして皆様、質問がございます。今回は宜しくお願い致します。 
初心者ですのでわかりづらい点がありましたら申し訳ありません。
宜しくお願いします。

質問
RailsチュートリアルでRubyのvarsion変更ができないので、
できるようにしたいというに関する質問です。

「rubyのversionを変更した順序」になります。

①現在rbenvでインスールしたいversionを確認/rbenv install -l
   2.0.0-p645を確認

②rubyの2.0.0-p645をインストールする/ rbenv install 2.0.0-p645 

③rbenv versions /rubyがインスールされたか確認する
   *2.0.0-p645 (set by /Users/tomokitakahashi/.rbenv/version)
④rbenv global 2.0.0-p645  /rubyのインストールしたいversionsを切り替える

⑤ruby —version 
ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-darwin14]

と⑤を確認してみるとわかるのですが、versionの変更が行えません。
rbenv rehashも行いましたが変更されませんでした。

御教授頂ければ幸いです。

失礼致します。

追記

rbenv versionsの全出力
 $ rbenv versions
    system
* 2.0.0-p481 (set by /Users/tomokitakahashi/.rbenv/version)
  2.0.0-p576
  2.0.0-p645
  2.1.3
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

現時点でのrbenv versionsの出力結果を全部書いてください。



投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/07/20 14:28

    ご回答ありがとうございます。
    そちらの結果も記述いたします。

    ありがとうございます。

    キャンセル

  • 2015/07/20 17:08

    なるほど。systemのRubyが実行されているんですね。
    rbenvインストール時に、.bashrcか.bash_profileかどこかに、`eval "$(rbenv init -)"` を追記してさらに実行していますか?インストール手順にあるはずですが。

    キャンセル

  • 2015/07/21 08:39 編集

    遅れてしまい申し訳有りません。
    >インストール手順にあるはずですが。
    これはおそらくRailsチュートリアルに記述されているということですね。。

    探してきますので引き続き宜しくお願いします。

    失礼します。

    キャンセル

  • 2015/07/21 21:16

    > これはおそらくRailsチュートリアルに記述されているということですね。。
    さあ。Railsとrbenvは直接関係ないので。
    rbenvのインストール手順にあると思います。
    Railsチュートリアルにrbenvインストール手順が書いてあるのならそこ。

    キャンセル

0

.ruby-version というファイルが存在しているかを確認してください。
存在していれば、それを削除します。
(このファイルは folder 毎に ruby の vesion を設定するためのものです。)

あるいは Gemfile中で ruby の version を指定している部分がないかを確認してください。


投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/07/20 15:40 編集

    ご回答ありがとうございます。
    ruby-versionは存在しませんでしたが、勉強になりました。

    ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    Rubyアップデート後

    ruby2.1.0をインストール後rails serverが開けなくなり以下の文が出てきました。 内容を見ても如何すればいいのか困ってます。 OSはWindows8を使っています。

  • 受付中

    rails sをすると古いバージョンのrubyを使ってしまう。

    今回ruby2.0.0という古いバージョンのものからruby2.2.3に新しくしたのですが、rails sをしたときに後者で立ち上がりません。なぜでしょうか?異なるバージョンのru

  • 解決済

    rubyバージョン変更について

    rubyをrbenvを使って管理しているのですが、rails sを行うとどうしてもMacにもとからはいっている2.0.0の方を通してしまいます。 これの対処法等ありましたらお教えい

  • 解決済

    rbenv: cannot rehash: /usr/local/rbenv/shims isn't...

    raspberry pi(ubuntuとほぼ一緒)を用いてrails のデプロイをしようとしていたところ、 rbenvで管理していたrubyのバージョンが変わっていなかったことに築

  • 解決済

    ローカル環境のRails5.0.0が立ち上がらない

    前提 本番サーバは問題なく動作中で、ローカルの開発環境でのみrailsが起動しません。 発生している問題・エラーメッセージ bundle exec rails sだと下記

  • 受付中

    rails appのbundleがインストールできない

    bundle install Fetching gem metadata from https://rubygems.org/......... Fetching version

  • 解決済

    bundle installができない エラー

    昨日、nokogiriのインストールでエラーが出るという質問を投稿させていただきました。 nokogiriのせいなのかと思っていたのですが、そもそもrails sもできないという状

  • 解決済

    bundle installでエラーが出てします。nokogiriによるエラー

    macOS High Sierra バージョン 10.13.2 先日質問しましたが、3日目でまだ解決出来ません>< 全く作業が進まず、心折れそうなので再度質問させてください..

同じタグがついた質問を見る

  • Ruby

    7324questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6984questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。