質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.87%

  • Ruby

    6535questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6366questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • SQLite

    547questions

    SQLiteはリレーショナルデータベース管理システムの1つで、サーバーではなくライブラリとして使用されている。

  • rbenv

    13questions

rubyのバージョンの切り替え

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 77

on_off_on

score 7

イメージ説明

Railsの環境をローカルに構築しようとして、Homebrew経由でrbenv、SQliteをインストールしてRailsもインストールしたあとに、Railsプロジェクトを作ってrails serverで起動しようとしたらGemファイルにはあるけどインストールされてないgemがある(?)と言われ、命令通りにbundleインストールを行ったら自分のRubyのバージョンが2.3.3なのにGemfileには2.5.1になってる、と言われました。

ruby -vで2.5.1と出てきたのでなぜ。。。となってしまって詰まってしまいました。

一応rbenv local 2.3.3に変えて、Gemfileも書き換えて同じことをしてみたのですがうまくいきませんでした。。。

確定でなくても良いので、原因だと思われることを教えていただければと思います。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

ひとつ考えられる可能性として、bundlerrailsがRuby 2.3のほうにしか入っていないために、コマンドを呼ぶとそちらが呼ばれてしまう、ということがあります。

Ruby 2.5のほうにも必要なGemを入れてみましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/27 18:07

    回答ありがとうございます。Ruby2.5のほうにも必要なGemを入れるというのは、ruby -v でRuby2.5.の状態の時に、bundle -vでバージョンがちゃんと表示されたらmaisumakunさんのおっしゃっていることとは違う原因が考えられるということでしょうか?

    キャンセル

  • 2018/05/27 18:13

    bundle -vで、そのbundlerが動くRubyのバージョンまで確認できたかが、ちょっとわからないです(手元に動作環境がないので)。

    キャンセル

0

bundleコマンドがrbenv管理下ではないruby(のgemコマンド)によってインストールされた可能性があります。
この場合、該当コマンドはインストール時に使ったrubyを実行パスとして埋め込みます。

対処法としてはプロジェクトディレクトリで

# ① システムのgemとローカルのgemが別コマンドである事を確認
which gem
sudo which gem

# ② ↑の結果別もの かつ、ローカル側が~/.rbenv/shims/gem的なやつならば
sudo gem uninstall bundler rails
gem install bundler rails

# ③ Gemfile.lockをバックアップとりつつ削除しbundle install
mv Gemfile.lock ._emfile
bundle install --path vendor/bundle

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.87%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    6535questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6366questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • SQLite

    547questions

    SQLiteはリレーショナルデータベース管理システムの1つで、サーバーではなくライブラリとして使用されている。

  • rbenv

    13questions