質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.75%

  • Ruby

    7016questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6737questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • CentOS

    2560questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • Vagrant

    1113questions

    Vagrantは、VirtualBox上の仮想マシンを コマンドラインから作成してくれるソフトウェアです。 ビルド環境など容易に構築が可能です。

  • rbenv

    23questions

railsを古いバージョンで実行する方法

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 208

mashact11

score 2

 前提・実現したいこと

railsのバージョンを新しいバージョンから古いバージョンに切り替えたいのですが、
どの様な操作をすればいいのかわかりません。

 発生している問題・エラーメッセージ

gem list rails
を実行した場合、

coffee-rails (4.2.2)
rails (5.1.6, 5.1.3)
rails-dom-testing (2.0.3)
rails-html-sanitizer (1.0.4)
sass-rails (5.0.7)
sprockets-rails (3.2.1)


と5.1.6と5.1.3が表示されています。

rails server
を実行した場合、

=> Booting Puma
=> Rails 5.1.6 application starting in development
=> Run `rails server -h` for more startup options


と表示され、5.1.6が実行されているのではないかと思います。

rails serverを5.1.3で実行するにはどの様にすれば良いのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • mashact11

    2018/05/19 22:29

    後はrubyはrvenbで簡単に切り替えが出来るので、railsでも同じことが出来ないかなと単純な好奇心です。

    キャンセル

  • mts10806

    2018/05/19 22:29

    まあ、ひとまず、その経緯も質問に追記していただいて、回答を待ってみても良いとは思います。(Ruby自体は私は専門外なので、もしかしたら解決案の提示があるかもしれませんし)

    キャンセル

  • mashact11

    2018/05/19 22:31

    そうですね、アドバイス有難うございます。

    キャンセル

回答 2

+1

私のおすすめはRVMで、バージョンに合わせたGEMSETを作る方法です。

一応一連の流れを記載しておきますね。
とりあえず、RVMインストール
RVMで、RAILS5.1.3専用のGEMSETを作る

rvm gemset create rails513
rvm 2.4.1@rails513
作ったGEMSETに切り替えたら
gem install rails -v "5.1.3"
rails -vで、5.1.3のバージョンが入ってることを確認できたら、
rails _5.1.3_ new myapp -Bとしてください。
-Bを入れなかったら、5.1系列の最後のバージョン5.1.6がインストールされるので、ここ重要です。
たぶん、NEWした時のGemfileが5.1.6に書き換えられているのでしょうか。。。

railsアプリの作成が終わったら、railsアプリ内のGemfileの、gem 'rails', '~> 5.1.3'となっているのを確認して、bundle installで完成です。
一応、確認として、rake aboutrails 5.1.3と表示されていたらOKです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/20 01:39

    rvmをインストールするためにgem install rvmを実行、メッセージが
    Successfully installed rvm-1.11.3.9
    Parsing documentation for rvm-1.11.3.9
    Done installing documentation for rvm after 1 seconds
    1 gem installed
    と表示された後、試しにrvm list knownを実行したのですが、
    -bash: rvm: コマンドが見つかりません
    と表示されます。
    インストールに失敗したのでしょうか?

    またrailsの切り替えはrbenvやgemでは出来ないのでしょうか?

    キャンセル

  • 2018/05/20 02:04

    rvmをインストールした後に、source ~/.profileと、同じターミナル上で打ち込んでください。これを忘れると`$ rvm`というコマンドはパスが通ってないので動きませんよ。もし、忘れてしまったのであれば、最初からやり直すことをお勧めします。rbenvはあんまり分からないのですが、Rubyのバージョン管理だけじゃないですかね?gemだけでやるなら、maisumakunさんの回答のように、一度削除して、指定のバージョンをインストールすればいいと思います。ですが、他に、作っているアプリなどがあったら、意図しないバグを引き起こす可能性も出てくるので、RVMのようなGEMまで管理できる物を使って環境を作るというのは、そういった不具合への対処にもなるのではないでしょうか。間違えても壊して作り直せばいいだけなので。

    キャンセル

  • 2018/05/20 02:22

    source ~/.profileを実行しましたが、
    -bash: /home/vagrant/.profile: そのようなファイルやディレクトリはありません
    と表示されます。

    上手くいきませんし、もう少し勉強してからまた切り替えについて考えたいと思います。

    キャンセル

0

新規にRails環境を作る場合Gemfilegem 'rails', '5.1.3'のように不等号なしで書けば、Ruby環境に入っているRailsバージョンにかかわらず、そのバージョンに固定できます。

すでにRails環境がある場合についても、gem 'rails'のバージョンを書き換えてbundle installし直せば動くかもしれませんが、途中でバージョンを入れ替えたことによってややこしいトラブルになる危険性はもちろんあります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/20 00:27

    Gemfileとはrails newを実行した際に作られるディレクトリ内にあるGemfileで良いのでしょうか?

    キャンセル

  • 2018/05/20 07:33

    そうですね。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.75%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7016questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6737questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • CentOS

    2560questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • Vagrant

    1113questions

    Vagrantは、VirtualBox上の仮想マシンを コマンドラインから作成してくれるソフトウェアです。 ビルド環境など容易に構築が可能です。

  • rbenv

    23questions