質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.76%

  • Ruby

    7075questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • スクレイピング

    289questions

mechanizeというライブラリだけがどうしてもrequireできません

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 140

yuyu_yuyui22

score 2

 前提・実現したいこと

プログラミングは本当に最近始めたばかりの初心者です。
Rubyを使ってwebサイトから情報を取得するためにとスクレイピングをしようとしており、一覧を複数のページに渡って遷移しながらそれぞれのページの特定要素を抜き出していくということがやりたいのですが、mechanizeというライブラリがなぜかrequireしようとしてもエラーが発生してしまいます。

 発生している問題・エラーメッセージ

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- mechanize (LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /Users/username/Desktop/data/test.rb:1:in `<main>'

 該当のソースコード

require 'mechanize'

agent = Mechanize.new
page = agent.get("")
elements =  page.search('')

puts elements


稚拙な質問で申し訳ありません。どなたかアドバイスお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

mechanizeをインストールしていないのでは?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/07 21:20

    ERROR: While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /Library/Ruby/Gems/2.0.0 directory

    ターミナルでgem install mechanizeと打ち込んで実行したら上記のようなエラーメッセージが出てきました。そこで今度はsudo gem install mechanizeと打ち込んだら

    Building native extensions. This could take a while...
    ERROR: Error installing mechanize:
    ERROR: Failed to build gem native extension.

    /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb
    mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/include/ruby.h

    Gem files will remain installed in /Library/Ruby/Gems/2.0.0/gems/unf_ext-0.0.7.5 for inspection.
    Results logged to /Library/Ruby/Gems/2.0.0/gems/unf_ext-0.0.7.5/ext/unf_ext/gem_make.out

    とこのように出てきました。
    インストールの方法から間違っているのでしょうか?

    キャンセル

  • 2018/05/07 21:29

    mechanizeで必要とする別のgemsの一部はCで書かれています。インストール時にCプログラムのコンパイルが行われます。
    コンパイルの際に必要なライブラリが不足しているというエラーです。

    多分Macですよね?「mac mechanize インストール」で検索してみて下さい。

    キャンセル

  • 2018/05/08 19:46

    調べたら解決するための一連の流れが載ってるところがありました!
    どうやらlibxml2やlibxsltやlibiconvなどがインストールされてなかったのがmechanizeのインストールに失敗したした原因だったようです。
    これらをインストールしてからmechanizeをインストールするコマンドを打ったところ、無事にインストールされたようです。
    今度はちゃんとrequireされて結果が出てきました!取り敢えずrequireされない問題は解決です!
    アドバイスありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.76%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7075questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • スクレイピング

    289questions