質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.99%

(仮想通貨)ビットフライヤーAPIを利用した自動売買プログラムのエラーについて

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,566

gogogo5

score 6

bitflyerlightningAPIを使って自動売買のプログラムを開発しています。
bitflyerlightningの管理画面からAPIキーを発行して、API経由で新規注文を出すと下記のエラーコードが返ってきます。

・エラー内容
「status: -121, error_message: Please accept the terms of use., data: None」
→規約を同意してくださいと言った内容ですが、bitflyerの管理画面に該当する箇所が見当たらない。

・違うbitflyerのアカウントでは同じプログラムで注文可能なのでプログラム上は問題無い。
・APIに付与する権限周りは問題ないこと確認。
・画面からは直接注文可能
・使用言語はpython

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

エスパーきぼんぬ、では困ります。
正常系とエラー系の両方の現象を再現できる最小限のコードを提示しない限り、
エラーメッセージでググってください、程度のコメントしか付かないかと。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/05 19:33

    説明に不備があり申し訳ありません。
    エラーメッセージでググって見たいのですが該当のエラーが見つかりませんでした。
    同類のシステムを開発し、同じエラーコードが返ってきた方の対処をご教授いただきたいと思い、投稿させていただきました。

    キャンセル

  • 2018/03/05 20:33

    本来こういうことはビットフライヤー社に問い合わせるべきものですね。

    キャンセル

  • 2018/03/05 21:04

    現象を再現できるだけの情報を提示する気がないようなので、正常系とエラー系のDFを取得してみては?
    https://www.vector.co.jp/soft/win95/util/se113286.html
    それでも解決しないなら、y_waiwaiさんが書かれているよぅにbitFlyer社に問合せましょう。

    キャンセル

0

同じ問題にぶつかり、bitflyerに問い合わせましたが、
API Documentのリンクだけ貼られて冷たくあしらわれました。
結果として、Product_codeを、FX_BTC_JPYからBTC_JPYに変更した結果、エラーが解消し解決しました。

と思いましたが、FX_BTC_JPYをベースにした自動売買プログラムでは結局まともに動きませんので根本解決ではありませんでした。申し訳ありません。
原因は、Web画面からFX取引を試みたことが一度もなかったことで、同意画面を押していないことでした。bitFlyerからbitFlyer lightningへ行き、上部のBIC-FX-JPYをクリックするとFX取引の同意画面が現れ同意したのちはFX_BTC_JPYでも上記エラーは解消されました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.99%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる