質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.54%
C#

C#はマルチパラダイムプログラミング言語の1つで、命令形・宣言型・関数型・ジェネリック型・コンポーネント指向・オブジェクティブ指向のプログラミング開発すべてに対応しています。

.NET Framework 3.5

.NET Framework-3.5は、NET Framework 2.0にアセンブリを追加(3.0も含む)したものをベースにしています。

Q&A

2回答

571閲覧

Windowsアプリケーションの.NET frameworkのマルチターゲットに関して

013dog

総合スコア7

C#

C#はマルチパラダイムプログラミング言語の1つで、命令形・宣言型・関数型・ジェネリック型・コンポーネント指向・オブジェクティブ指向のプログラミング開発すべてに対応しています。

.NET Framework 3.5

.NET Framework-3.5は、NET Framework 2.0にアセンブリを追加(3.0も含む)したものをベースにしています。

0グッド

0クリップ

投稿2018/02/05 11:57

現在、Windowsアプリケーションを作成しています。

ある製品のライブラリを使用したいのですが、次の問題点に困っています。

・現在作成済みのアプリケーション(以下、既存アプリ)は、.NET Framework 3.5で作成されている
・使用したいライブラリは.NET Framework 4以降から使用できる

既存アプリのソリューションに対して新規のプロジェクトを、.NET framework4で作成して追加しました。
そのDLLを既存アプリのメインプロジェクトの参照に加えたいのですが、バージョンが異なるため参照ができないもようです。

質問としましては、.NET framework3.5のプロジェクトを基点に、.NET framework4以降のバージョンのDLLファイルを適切に参照する方法がないかということです。

IDEはVisual Studio 2015 Proです。
どなたかよろしくお願いします。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

Zuishin

2018/02/05 12:01

既存プロジェクトのターゲットを変えてコンパイルし直すのが一番楽だと思いますが、それができない理由がありますか?
guest

回答2

0

g_uoさんに補足ですが、既に作成中のプロジェクトでも途中でターゲットフレームワーク変更は可能ですよ。
もちろん内容によりますが。

投稿2018/02/26 06:54

Smoker

総合スコア16

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

Zuishinさんの質問にあり恐縮ですが、既存アプリのターゲットプラットフォームを".Net Framework 4"に変更してください。

メニュー"プロジェクト" -> [プロジェクト名]のプロパティ(E)... -> アプリケーション
イメージ説明

.Net Framework 4以上をターゲットとする外部ライブラリが使用可能な環境であれば、既存アプリもこれで問題ないのではないかと想像しています。

投稿2018/02/15 01:00

編集2018/02/15 01:01
g_uo

総合スコア212

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.54%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

同じタグがついた質問を見る

C#

C#はマルチパラダイムプログラミング言語の1つで、命令形・宣言型・関数型・ジェネリック型・コンポーネント指向・オブジェクティブ指向のプログラミング開発すべてに対応しています。

.NET Framework 3.5

.NET Framework-3.5は、NET Framework 2.0にアセンブリを追加(3.0も含む)したものをベースにしています。