質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.48%

  • Cisco

    117questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Cisco IOS

    40questions

トランクリンクの設定をしたのにping通らない

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 3,650

narururu

score 45

実現したいこと

トランクリンクの設定をしたR1のfa 1/0とR2のfa 1/0間でpingが通るようにしたい。

環境

GNS3
イメージ説明

R1とR2はどちらもslot 1にNM-16ESWを設定しCatalystとして使用。

IPアドレス
PC-1:192.168.10.10/24
PC-2:192.168.10.20/24
PC-3:192.168.20.10/24
PC-4:192.168.20.20/24
PC-5:192.168.10.50/24
PC-6:192.168.20.60/24

以下は双方向でpingの疎通ができています。
PC1←→PC-2
PC3←→PC-4

R1のshow run

Catalyst#show run
Building configuration...

Current configuration : 1894 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Catalyst
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 switchport trunk allowed vlan 1,2,10,20,1002-1005
 switchport mode trunk
!
interface FastEthernet1/1
 switchport access vlan 10
!
interface FastEthernet1/2
 switchport access vlan 10
!
interface FastEthernet1/3
 switchport access vlan 20
!
interface FastEthernet1/4
 switchport access vlan 20
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2のshow run

Catalyst-2#show run
Building configuration...

Current configuration : 1842 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Catalyst-2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 switchport trunk allowed vlan 1,2,10,20,1002-1005
 switchport mode trunk
!
interface FastEthernet1/1
 switchport access vlan 10
!
interface FastEthernet1/2
 switchport access vlan 20
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 192.168.10.2 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.2 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end


イメージ説明

これが原因かどうかはわかりませんが、気になるのが、fa1/0のトランクポートにdot1qのカプセル化の設定をしたのにも関わらず、show runの結果には表示されていない点です。コマンドを入力した時点では、エラーなどはないです。

原因が分かる方、是非私に教えていただけないでしょうか。

以上、よろしくお願いいたします。

追記

カプセル化の設定は以下の通り反映されていました。
show runではなく、show int fa1/0 trunkで確認できました。
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

check解決した方法

0

トランクリンクの通信確認取れました!
原因はip routingの入力を忘れていたためです。
またもや、初歩的な抜け漏れをしてしまい、大変失礼いたしました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/27 22:41

    ip routingはルータとしての機能をONにするためのものです。ここでは、トランクリンクはスイッチとしての機能ですので関与すると思えません。ひょっとしてVLAN10とVLAN20の間でpingしていませんか?

    キャンセル

  • 2018/01/27 23:26

    ご回答ありがとうございます。
    pingは全て同じVlan内で行っています。全て通信できるようになりました☺
    一方、異なるVlan(Vlan10とVlan20間)の通信はできないことを確認しております。
    問題の切り分けとして、R1とR2にそれぞれno ip routingを入力して、トランクリンク上の通信を試みましたが、できませんでした。
    よって、ip routingが今回の問題解決のキーになります。
    トランクリンクを介す通信はレイヤー3になるためルーティングの設定が必要になる、という風に私の中では捉えました。
    間違った認識かもしれませんが、とりあえず目的は達成できたので、理屈はおいおい考えるとします。
    ありがとうございます☺

    キャンセル

  • 2018/01/27 23:39

    すみません。訂正です。
    再度、no ip routingで同一Vlanでのトランクリンク通信を確認したのですが、通信ができました。
    よって、ip routingは関係ないですね。
    うーん、原因はわかりません。
    大変失礼いたしました。

    キャンセル

  • 2018/01/27 23:51

    トランクリンクはL2の機能です。ip routingは関係ありません。ip routingをすればVLAN10とVLAN20の間での通信が可能となってしまいます。これで目的が達成されているならばPC5と6の設定が逆であるとかの可能性があります。

    キャンセル

  • 2018/01/28 00:22

    ご回答ありがとうございます。
    試しに、ip routingを設定し、vlan10とvlan20での通信をしてみましたが、通信はできない状況です。
    また、PC-5とPC-6の設定を確認しましたが、間違いはありません。
    アドバイスありがとうございます☺

    キャンセル

0

VLan Interfaceの設定がR1にないことが気になります。(そもそも不要だったかもしれません、確認取れず)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/27 18:36

    ご回答ありがとうございます。
    うっかり、R1にVlan Interfaceの設定を忘れていました。
    しかし、設定後もpingは通らなかったです。
    他に原因がありそうです。
    ご指摘ありがとうございました☺

    キャンセル

  • 2018/01/27 19:05

    設定は間違っていないようにみえます。シミュレータとか簡易な環境であるならば、(トランクポートを一度閉じて)空きポートをアクセスポートにして片方のVLANだけ通してみるとかで部分試験できると思います。(ついでにアドレス重複していますよ)

    キャンセル

  • 2018/01/27 19:43

    ご回答ありがとうございます。
    IPアドレスのご指摘の点について、伺いたいのですが、
    同じVlan内では同じネットワーク部でIPアドレスの設定をするのもと認識しておりました。
    では、今回の構成では、PC-5とPC-6のネットワーク部を変更すればいいのでしょうか。
    申し訳ございませんが、ご教授願います。
    IPアドレス難しいです(>_<)

    キャンセル

  • 2018/01/27 20:56 編集

    いやR1とR2のVlanインタフェースのアドレスが被っていると申したかったのです。もっとも本件に関係あるかわかりませんけど。

    キャンセル

  • 2018/01/27 21:47

    ご回答ありがとうございます。
    失礼いたしました。
    R1とR2のVlanインターフェースのIPアドレスを修正しました。
    しかし、ご指摘の通りトランクリンクの通信は未だ解決できず。
    アドバイスありがとうございます。

    キャンセル

  • 2018/01/27 22:22

    トランクリンクの通信確認できました!
    原因はip routingの設定漏れでした。
    アドバイスありがとうございました☺

    キャンセル

0

なるほど、PC1とPC5は同セグメント(192.168.10.0/24)なのでお互いtrunkリンクを通じて疎通ができるべきですね。
設定を見ても問題が無いように見受けられます。
以下はどうでしょうか。

①R1でPC1にPingをする
ping 192.168.10.10

②RT1でarpテーブルを確認してPC1のアドレスを学習している
show arp
→192.168.10.10 が登録されている

③R2で①、②をやってみる
ping 192.168.10.10
show arp
→192.168.10.10 が登録されている

これで①~②が成功して③が失敗するとなると、trunkが正しく通っていないのでしょうね
それを確定させるためには
R1ではPC1のmacアドレスを学習できているが、R2では学習できていない状態になっているはずなので
それも確認してみてください。
④RT1でshow mac-address-tableを実行
⇒PC1のmacアドレスが学習されている(出力I/Fはfa1/1を想定)
④RT2でshow mac-address-tableを実行
⇒PC1のmacアドレスが学習されていないはず
※仮に学習できている場合、出力I/Fはfa1/0を想定

やってみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/27 22:56

    失礼しました。
    ip routingの設定でしたか。
    納得です。

    キャンセル

  • 2018/01/27 23:45

    ご回答ありがとうございます。
    お世話になっております。
    トラブルシューティングの流れが非常に参考になります。今後の参考にさせていただきます。
    問題解決したと思っていたのですが、no ip routingをR1とR2に対して入力し、再度、同一Vlanのトランクリンク通信をしてみたら、通ってしまいました。
    よって、今回通信ができるようになった原因はip routing以外にありそうです。
    今のところ原因はわかりませんが、とりあえず今回は目的が達成できたので分析は後回しにします。
    アドバイス、ありがとうございました☺

    キャンセル

同じタグがついた質問を見る

  • Cisco

    117questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

  • Cisco IOS

    40questions