質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.76%

  • Node.js

    1740questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

  • Raspberry Pi

    714questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • Bluetooth

    217questions

    Bluetoothとは短距離の間でデータを交換するための無線通信規格である。固定・モバイル両方のデバイスから、短波の電波送信を行うことで、高いセキュリティをもつパーソナルエリアネットワーク(PAN)を構築する。

rasberry pi zero w で BLUETOOTH を利用したい

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 441

ttmaji

score 1

rasberry pi zero w を利用して
BLE(ビーコンの情報)を取得したいと考えています。

bleaconというツールが簡単に利用できとしり
以下コマンドでインストールをしてみたのですが
インストールに失敗してしまいます。

npm install bleacon

内部で利用している関連のライブラリのインストールに失敗しているようなのですが
以下のエラーメッセージからどのように対処したら良いかわかりますでしょうか?
( 別途必要な情報等もありましたらお教えください。)
宜しくお願い致します。

pi@geostratosraspi3b001:~/node $ npm install usb
npm WARN npm npm does not support Node.js v5.12.0
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
npm WARN npm You can find the latest version at https://nodejs.org/

usb@1.3.1 install /home/pi/node/node_modules/usb
node-pre-gyp install --fallback-to-build

node-pre-gyp ERR! Tried to download(404): https://github.com/tessel/node-usb/releases/download/1.3.1/usb_bindings-v1.3.1-node-v47-linux-arm.tar.gz 
node-pre-gyp ERR! Pre-built binaries not found for usb@1.3.1 and node@5.12.0 (node-v47 ABI, glibc) (falling back to source compile with node-gyp) 

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

エラーメッセージの意味が判らなかったら、翻訳をしてくれるサイトを使いましょう。

例えば、Google翻訳(https://translate.google.co.jp/?hl=ja)で質問のエラーメッセージ

pi@geostratosraspi3b001:~/node $ npm install usb
npm WARN npm npm does not support Node.js v5.12.0
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
npm WARN npm You can find the latest version at https://nodejs.org/

を翻訳すると

pi @ geostratosraspi3b001:〜/ node $ npm install usb
npm WARN npm npmはNode.js v5.12.0をサポートしていません
npm WARN npmノードの新しいバージョンにアップグレードする必要があります。
npm WARN npmは、npmがこのバージョンで動作するという約束をすることはできません。
npm WARN npmサポートされているNode.jsのリリースは、4,6,7,8,9の最新リリースです。
npm WARN npm https://nodejs.org/で最新バージョンを確認できます。

となります。

翻訳されたものを読めば、どう対処したら良いか判りますよね?

・https;//nodejs.org/のサイトからNode.jaの最新バージョンを取ってきて、Node.js v5.12.0と入れ替える(v5.12.0をアンインストールして、最新バージョンをインストールする)
・そうすれば、お使いのnpmが対応しているので、問題解決。
となるはずです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.76%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Node.js

    1740questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

  • Raspberry Pi

    714questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • Bluetooth

    217questions

    Bluetoothとは短距離の間でデータを交換するための無線通信規格である。固定・モバイル両方のデバイスから、短波の電波送信を行うことで、高いセキュリティをもつパーソナルエリアネットワーク(PAN)を構築する。