質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.02%

  • Ruby

    6369questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2309questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

インストールしたgem なのに、requireしないと使えない。

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 168

siruku6

score 13

実施したこと

Gemfile 追記
gem 'rubyzip'

$bundle install --path vendor/bundle
$rails c
[1] pry(main)> Zip
 >> NameError: uninitialized constant Zip


なぜかrubyzipが使えない。

今回参考にしたページ

https://teratail.com/questions/88151

こちらによると、bundle install したとしても、Gemfile に :require => false が付加されていると、そのgemは読み込まれず、requireする必要があるとのこと。

確認してみたが、Gemfile には :require => false などはついていなかった。

わからないこと

:require => false 以外に、何かしらgem の読み込みが阻害される原因はあるのでしょうか?

参考

Gemfile.lock
rubyzip (1.2.1)

ちなみに、Gemfileに対して

gem 'rubyzip', require: 'zip'


と書けば解決しますが、他のgemのように、require~など書かずに動かしたいです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+3

Bundlerはデフォルトで、Gem自身の名前を持つファイルをrequireするようになっています(Bundler公式)。

多くのGemはその仕様に従って作られているので、特に何かを指示する必要はないのですが、rubyzipの場合はもとの構造上require 'rubyzip'と書いても動かないので、うまくいかないのです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/19 08:52

    bundlerの仕様なのですね。
    私の勉強不足でした。
    質問の後も、いくつかそういったgemに遭遇したのですが、おかげさまでうろたえずに済んでおります。

    ありがとうございます。

    キャンセル

+1

rubyzip はそういう gem です。
そういう gem もあるんです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/19 08:48

    そういうものなのですね。
    私の記述のしかたが悪いのかも知れないと思っていましたが、そうではないようなので安心しました。

    キャンセル

+1

そこには

個別にrequireを実行しなくても、Bundler.requireを実行することで一括でrequireできる

と書いてあるのではないでしょうか?

今質問のコマンドではBundler.requireを実行してないからrequireされてないだけかと。

参考の下を読んでませんでした & railsコマンドはBundler.requireした状態で起動するのですね(たぶん)。失礼しました


maisumakunさんの回答ですでに出ていますが、

https://github.com/bundler/bundler/blob/master/lib/bundler/dependency.rb#L91
https://github.com/bundler/bundler/blob/master/lib/bundler/runtime.rb#L78

require=でtrueと指定したら名前で、文字列を指定したらその文字列でrequireしようとしますね。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/19 08:49

    URLもありがとうございます。
    2通りのやり方があるのですね。
    勉強になります!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 91.02%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    6369questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2309questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。