質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Ruby

    7665questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

gemのrequireでエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,033

miiichat

score 46

$ c:\tools\uru ls
 => 2532        : ruby 2.5.0p0 (2017-12-25 revision 61468) [i386-mingw32]
    2564        : ruby 2.5.0p0 (2017-12-25 revision 61468) [x64-mingw32]
$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 2.7.3
  - RUBY VERSION: 2.5.0 (2017-12-25 patchlevel 0) [i386-mingw32]
  - INSTALLATION DIRECTORY: C:/Ruby25/lib/ruby/gems/2.5.0
  - USER INSTALLATION DIRECTORY: C:/Users/sunah/.gem/ruby/2.5.0
  - RUBY EXECUTABLE: C:/Ruby25/bin/ruby.exe
  - EXECUTABLE DIRECTORY: C:/Ruby25/bin
  - SPEC CACHE DIRECTORY: C:/Users/sunah/.gem/specs
  - SYSTEM CONFIGURATION DIRECTORY: C:/ProgramData
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-mingw32
  - GEM PATHS:
     - C:/Ruby25/lib/ruby/gems/2.5.0
     - C:/Users/sunah/.gem/ruby/2.5.0
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - https://rubygems.org/
  - SHELL PATH:
     - /_U1_
     - C:\Ruby25\bin
     - /_U2_
     - C:\ProgramData\Oracle\Java\javapath
     - D:\program file\jdk\bin
     - C:\Program Files (x86)\GtkSharp\2.12\bin
     - F:\Git\cmd
     - C:\WINDOWS\system32
     - C:\WINDOWS
     - C:\WINDOWS\System32\Wbem
     - C:\WINDOWS\System32\WindowsPowerShell\v1.0\
     - C:\HashiCorp\Vagrant\bin
     - C:\Program Files\PuTTY\
     - C:\tools
     - C:\Ruby25\bin
     - C:\Ruby25-x64\bin
     - C:\Users\sunah\AppData\Local\Microsoft\WindowsApps
     - C:\Users\sunah\AppData\Local\atom\bin
     - C:\Program Files\Heroku\bin
     - C:\Users\sunah\AppData\Local\Microsoft\WindowsApps
C:\ruby> ruby ruby.rb
Traceback (most recent call last):
        6: from ruby.rb:2:in `<main>'
        5: from C:/Ruby25/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:39:in `require'
        4: from C:/Ruby25/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:135:in `rescue in require'
        3: from C:/Ruby25/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:135:in `require'
        2: from C:/Ruby25/lib/ruby/gems/2.5.0/gems/dxruby-1.4.5/lib/dxruby.rb:2:in `<top (required)>'
        1: from C:/Ruby25/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
C:/Ruby25/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- 2.5/dxruby.so (LoadError)
<ruby.rb>

require 'dxruby'

Window.loop do
end

gemのrequireでエラーが出ます
調べてみましたがよくわかりませんでした

回答してくれるとうれしいです

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

2.5/dxruby.soが無いということなので、おそらくまだRuby2.5用のバイナリが提供されていないと言うことだと思います。
C:/Ruby25/lib/ruby/gems/2.5.0/gems/dxruby-1.4.5/の下の方に、2.4/dxruby.soとか2.3/dxruby.soなどが無いか調べて、そこにあるバージョンのRubyを使ってください。
調べると、DxRubyは2016年が最後のバージョンのようなので、Ruby2.3までじゃないでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/10 13:48

    回答ありがとうございます!
    2.3までみたいでした。
    出来ました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.51%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7665questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。