質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.54%
iOS

iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

Swift

Swiftは、アップルのiOSおよびOS Xのためのプログラミング言語で、Objective-CやObjective-C++と共存することが意図されています

Q&A

解決済

1回答

675閲覧

【Swift-Charts】CocoaPodsを使ってChartsRealmを導入する際のエラーを解消したい

miyuki

総合スコア23

iOS

iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

Swift

Swiftは、アップルのiOSおよびOS Xのためのプログラミング言語で、Objective-CやObjective-C++と共存することが意図されています

0グッド

0クリップ

投稿2023/03/28 13:53

編集2023/03/28 13:55

実現したいこと

イメージ説明

Chartsを使用する際に、私のプロジェクトではRealmを使用しているため、ChartsRealmも必要なようなのでCocoaPodsを使って導入しようとしたところ下記のようなエラーがでました。翻訳してもエラーを検索しても、解決方法がわからず困っております。
ご教授いただけますと幸いです。

発生している問題・エラーメッセージ

[!] CocoaPods could not find compatible versions for pod "Charts": In snapshot (Podfile.lock): Charts (= 3.6.0) In Podfile: Charts ChartsRealm was resolved to 3.0.2, which depends on Charts (~> 3.0.2)

該当のソースコード

PodFile

1# Uncomment the next line to define a global platform for your project 2platform :ios, '13.5' 3 4target 'VisualLike' do 5 # Comment the next line if you don't want to use dynamic frameworks 6 use_frameworks! 7 8 # Pods for VisualLike 9 pod 'RealmSwift', '5.1.0' 10 pod 'Charts' 11 pod 'ChartsRealm' 12 pod 'ScrollableGraphView' 13 pod 'FSCalendar' 14 pod 'CalculateCalendarLogic' 15 16end

Podfile.lock
イメージ説明

補足情報(FW/ツールのバージョンなど)

Xcodeのバージョンは12.4です。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

2

ベストアンサー

ChartsRealmは、v3.4.0で更新が止まっていて、Charts v3.4.xを使用するよう依存関係が設定されています。

ChartsRealmをインストールする際、既にCharts3.6.0がインストールされていたため、Charts3.6.0に対応するChartsRealmが存在しないということでエラーになったのだと思います。

RealmSwiftについても同様の問題があると思います。「5.1.0」のバージョン指定でRealmSwiftをインストールしていますが、ChartsRealm3.4.0は、RealmSwift3.18.xを使用するよう依存関係が設定されているため、Chartsのバージョン問題が解決したら今度はRealmSwiftのバージョン問題のエラーが発生すると思います。

Podfile内のRealmSwiftのバージョン指定 , '5.1.0' を削除して、 pod install ではなく pod update を実施すれば、依存関係の合った次のバージョンが再インストールされ、podのエラーは解消されると思います。

  • Charts 3.4.0
  • ChartsRealm 3.4.0
  • RealmSwift 3.18.0

ただ、もし自分のアプリがCharts3.6.0やRealmSwift5.1.0で追加された新しい機能を使用していたら、今度はアプリのビルドでエラーが発生すると思うので、そのあたりの調整は必要だと思います。もし新しい機能(新しいバージョン)の利用が必須で外せないものであれば、更新が止まって同居できなくなったChartsRealmの利用をあきらめる必要があるかもしれません。

投稿2023/03/29 02:26

TakeOne

総合スコア6299

KEMONO_PANTSU_k👍を押しています
botamoti👏を押しています

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

miyuki

2023/03/29 04:32

なるほど。とてもご丁寧にありがとうございます!非常に助かりました。 Chartsの公式リポジトリではWhen using Realm.io: You'll need to add ChartsRealm as a dependency too. と書いてあるのですが、ChartsRealmを使用しない場合は上記の指示を無視してしまっても問題ないということでしょうか?ChartsRealmに関してStarが129しかないこともあり、導入すべきなのかわからず悩んでいます。
TakeOne

2023/03/29 07:24

Charts(グラフ表示ライブラリ)とRealm(データベースライブラリ)は、本来別々のライブラリで、Realmに保存しているデータをグラフに表示したいなら、自分でRealmからデータを読み込んで、それをChartsに渡してグラフ表示すればいいだけです。「When using Realm.io: You'll need to add ChartsRealm as a dependency too.」という説明は、「ChartsRealmを使うと便利だよ」という程度の意味で捉えれば良いと思います。そして、今は更新も止まっており、ChartsRealmの使い方を説明したわかりやすい記事も見当たらないので、無理に使わなくても良いと思います。
miyuki

2023/03/29 08:09

わかりました!ご教授くださりありがとうございます。ベストアンサーにさせていただきます。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.54%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

同じタグがついた質問を見る

iOS

iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

Swift

Swiftは、アップルのiOSおよびOS Xのためのプログラミング言語で、Objective-CやObjective-C++と共存することが意図されています