質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.86%

  • Python

    5900questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

warning: no previously-included files matching '*.pyc' found anywhere in distributionについて

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 218

pocket8137

score 31

pipでインストールする際に、
warning: no previously-included files matching '*.pyc' found anywhere in distributionという警告メッセージが出力されたのですが、
これはどういう意味なのでしょうか。

root@host:~# pip install DateTime==4.0.1
Downloading/unpacking DateTime==4.0.1
Downloading DateTime-4.0.1.zip (65kB): 65kB downloaded
Running setup.py (path:/tmp/pip-build-T7vlWX/DateTime/setup.py) egg_info for package DateTime

warning: no previously-included files matching '*.pyc' found anywhere in distribution
warning: no previously-included files matching '*.pyo' found anywhere in distribution
Downloading/unpacking zope.interface (from DateTime==4.0.1)
Downloading zope.interface-4.4.3.tar.gz (147kB): 147kB downloaded
Running setup.py (path:/tmp/pip-build-T7vlWX/zope.interface/setup.py) egg_info for package zope.interface

warning: no previously-included files matching '*.dll' found anywhere in distribution
warning: no previously-included files matching '*.pyc' found anywhere in distribution
warning: no previously-included files matching '*.pyo' found anywhere in distribution
warning: no previously-included files matching '*.so' found anywhere in distribution
warning: no previously-included files matching 'coverage.xml' found anywhere in distribution
warning: no previously-included files matching 'appveyor.yml' found anywhere in distribution
no previously-included directories found matching 'docs/_build'
Downloading/unpacking pytz (from DateTime==4.0.1)
Downloading pytz-2017.2-py2.py3-none-any.whl (484kB): 484kB downloaded
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/lib/python2.7/dist-packages (from zope.interface->DateTime==4.0.1)
Installing collected packages: DateTime, zope.interface, pytz
Running setup.py install for DateTime

warning: no previously-included files matching '*.pyc' found anywhere in distribution
warning: no previously-included files matching '*.pyo' found anywhere in distribution
Running setup.py install for zope.interface

warning: no previously-included files matching '*.dll' found anywhere in distribution
warning: no previously-included files matching '*.pyc' found anywhere in distribution
warning: no previously-included files matching '*.pyo' found anywhere in distribution
warning: no previously-included files matching '*.so' found anywhere in distribution
warning: no previously-included files matching 'coverage.xml' found anywhere in distribution
warning: no previously-included files matching 'appveyor.yml' found anywhere in distribution
no previously-included directories found matching 'docs/_build'
building 'zope.interface._zope_interface_coptimizations' extension
arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -I/usr/include/python2.7 -c src/zope/interface/_zope_interface_coptimizations.c -o build/temp.linux-armv7l-2.7/src/zope/interface/_zope_interface_coptimizations.o
arm-linux-gnueabihf-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-armv7l-2.7/src/zope/interface/_zope_interface_coptimizations.o -o build/lib.linux-armv7l-2.7/zope/interface/_zope_interface_coptimizations.so
Skipping installation of /usr/local/lib/python2.7/dist-packages/zope/__init__.py (namespace package)
Installing /usr/local/lib/python2.7/dist-packages/zope.interface-4.4.3-nspkg.pth
Successfully installed DateTime zope.interface pytz
Cleaning up...

root@host:~# pip install django-guardian==1.3
Downloading/unpacking django-guardian==1.3
Downloading django-guardian-1.3.tar.gz (292kB): 292kB downloaded
Running setup.py (path:/tmp/pip-build-eTdsEO/django-guardian/setup.py) egg_info for package django-guardian

warning: no files found matching '*.json' under directory 'guardian/fixtures'
warning: no files found matching '*.html' under directory 'guardian/tests/templates'
warning: no previously-included files matching '*' found under directory 'example_project'
warning: no previously-included files matching '*' found under directory 'docs/build'
warning: no previously-included files matching '*' found under directory 'benchmarks'
Requirement already satisfied (use --upgrade to upgrade): Django in /usr/local/lib/python2.7/dist-packages (from django-guardian==1.3)
Requirement already satisfied (use --upgrade to upgrade): six in /usr/lib/python2.7/dist-packages (from django-guardian==1.3)
Installing collected packages: django-guardian
Running setup.py install for django-guardian

warning: no files found matching '*.json' under directory 'guardian/fixtures'
warning: no files found matching '*.html' under directory 'guardian/tests/templates'
warning: no previously-included files matching '*' found under directory 'example_project'
warning: no previously-included files matching '*' found under directory 'docs/build'
warning: no previously-included files matching '*' found under directory 'benchmarks'
Successfully installed django-guardian
Cleaning up...
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

原文)
warning: no previously-included files matching '*.pyc' found anywhere in distribution

意味)
警告: あらかじめ同梱した*.pycに一致するファイルが、頒布品のどこにも見当たりません。

起きていること)
同じような件が、numpyのインストールなどであった、というような検索結果がちらほら見られますね。たぶん、インストールに必要なモジュールが古かったりまるで入っていなかったりで使えなかったことに対する警告だと思います。今回の場合、zope.interfaceというのがなかったために警告が出て、途中で自動でインストールされたようですね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/01/08 18:46

    ありがとうございます。

    インストールに必要なモジュールがなかったので、自動でモジュールをインストールしたとのことで、承知致しました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.86%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python

    5900questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。