質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.25%

  • Python 3.x

    2745questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

wfdbのインストール

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 50

Mac OS10.12.6
の環境で Python 3.6.3をインストールmatplotlibなどのパッケージを入れ動かしております。
素人ですのでその後anacondaも入れてみたりとかなり行き当たりばったりの対応をしていることは否めませんが、、

講習会参加にあたって下記のようなパッケージを入れるように指示があったのですが
最後のwfdbだけがうまくインストールできません。
• matplotlib>=1.5.3
• numpy>=1.12.1
• pandas>=0.19.1
• scikit-learn>=0.18.1
• scipy>=0.19.0
• sklearn>=0.0
• wfdb>=1.3.7

wfdb より上は入りましたのでサンプルのmatplotlibを使ったお絵かきなどは走っております。

指示では
$ pip3 install wfdb
でいけるとのことですが、下記エラーがでます。
"requests"というmoduleがないとの表示ですが、泥沼に入る前に質問させていただきます。
素人くさい質問で申し訳ありません。

Collecting wfdb
Using cached wfdb-1.3.7.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/private/var/folders/x3/rgd374bs0_g8mmw9wbxptgzm0000gp/T/pip-build-rpediy6y/wfdb/setup.py", line 18, in <module>
from wfdb.version import version
File "/private/var/folders/x3/rgd374bs0_g8mmw9wbxptgzm0000gp/T/pip-build-rpediy6y/wfdb/wfdb/init.py", line 1, in <module>
from .readwrite.records import Record, MultiRecord, rdheader, rdsamp, srdsamp, wrsamp, dldatabase, dldatabasefiles
File "/private/var/folders/x3/rgd374bs0_g8mmw9wbxptgzm0000gp/T/pip-build-rpediy6y/wfdb/wfdb/readwrite/records.py", line 14, in <module>
import requests
ModuleNotFoundError: No module named 'requests'


Command "python setup.py egg_info" failed with error code 1 in /private/var/folders/x3/rgd374bs0_g8mmw9wbxptgzm0000gp/T/pip-build-rpediy6y/wfdb/
———————————————

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

requirements.txtを見ると、必要なモジュールが載っています。

https://github.com/MIT-LCP/wfdb-python/blob/master/requirements.txt

本来はpip installの際に一緒にインストールされるはずですが、それが機能していないようですね。
ここに載っているものをあらかじめインストールしてから試してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/12/20 20:47

    ありがとうございます。解決しました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.25%

関連した質問

同じタグがついた質問を見る

  • Python 3.x

    2745questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。