質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.37%

  • Python 3.x

    2395questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

pipがインストールできない

解決済

回答 1

投稿 2017/12/05 00:50 ・編集 2017/12/05 00:56

  • 評価
  • クリップ 0
  • VIEW 54

bunks

score 4

https://qiita.com/suzuki_y/items/3261ffa9b67410803443
こちらの記事に従って、

python get-pip.py


を用いたところ以下のようなエラーが生じました。

Exception:
Traceback (most recent call last):
  File "/var/folders/mw/mgnjhp791wlb21w8p893yys80000gn/T/tmpiHZyvz/pip.zip/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/var/folders/mw/mgnjhp791wlb21w8p893yys80000gn/T/tmpiHZyvz/pip.zip/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,
  File "/var/folders/mw/mgnjhp791wlb21w8p893yys80000gn/T/tmpiHZyvz/pip.zip/pip/req/req_set.py", line 784, in install
    **kwargs
  File "/var/folders/mw/mgnjhp791wlb21w8p893yys80000gn/T/tmpiHZyvz/pip.zip/pip/req/req_install.py", line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
  File "/var/folders/mw/mgnjhp791wlb21w8p893yys80000gn/T/tmpiHZyvz/pip.zip/pip/req/req_install.py", line 1064, in move_wheel_files
    isolated=self.isolated,
  File "/var/folders/mw/mgnjhp791wlb21w8p893yys80000gn/T/tmpiHZyvz/pip.zip/pip/wheel.py", line 345, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/var/folders/mw/mgnjhp791wlb21w8p893yys80000gn/T/tmpiHZyvz/pip.zip/pip/wheel.py", line 287, in clobber
    ensure_dir(dest)  # common for the 'include' path
  File "/var/folders/mw/mgnjhp791wlb21w8p893yys80000gn/T/tmpiHZyvz/pip.zip/pip/utils/__init__.py", line 83, in ensure_dir
    os.makedirs(path)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/os.py", line 150, in makedirs
    makedirs(head, mode)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/os.py", line 150, in makedirs
    makedirs(head, mode)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/os.py", line 157, in makedirs
    mkdir(name, mode)
OSError: [Errno 13] Permission denied: '/Library/Python'


どのようにすればエラーを解決し、pipを正常にインストールすることができるでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

sudo python get-pip.py

投稿 2017/12/05 01:39

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/12/05 12:46

    無事インストールできました。ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.37%

関連した質問

  • 受付中

    python UnicodeEncodeError無視する

    こちらの質問https://teratail.com/questions/23204をしたものです. 追加で少し, 最悪,エラーを起こしている文字は取得できなくていいので

  • 解決済

    pipがアップグレードできません

    Python初心者です。 pipをアップグレードしようとすると下記のようなエラーが出てしまいます。 色々なサイトで調べたのですが解決できず困っています。 教えいただけるとあり

  • 解決済

    pythonのTA-Libについて困っています

    cent os7でpythonのTA-Lib (0.4.9)をつかいたく Python 2.7.10 --  64-bit  インストールし、他の必要なものをインストールしまし

  • 受付中

    Ironpythonでpythonのサードパーティライブラリを使う

    現在Visual Studio 2015 communityでvisual C#を用いて、Windows Form Applicationを作成しています。 そこで、データファイ

  • 解決済

    ImportErrorが解消できない件

    以下に記すエラーの解消方法が分からないのでアドバイスを頂きたいです。 pythonのバージョンに合ったnumpyをインストールしていない時に出るエラーだと思います。 pipでmat

  • 解決済

    Python モジュール読み込みエラー インストールパスの管理

    基本的な質問で申し訳ないのですが、Pythonのインストール先が複数ありどうやって管理するべきなのでしょうか?MacOSX Yosemiteを使用していて、主なエディターはAtom

  • 解決済

    Pythonのpipでのパッケージインストール

    前提・実現したいこと Pythonを使ってBitcoinのBotを作ろうと思っていましたのでAPIを取得しようと思っていました。 発生している問題・エラーメッセージ Zaifと

  • 解決済

    pythonのrandom モジュール関連です

    前提・実現したいこと ここに質問したいことを詳細に書いてください (例)PHP(CakePHP)で●●なシステムを作っています。 ■■な機能を実装中に以下のエラーメッセージが発生し

同じタグがついた質問を見る

  • Python 3.x

    2395questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。