質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.35%

  • PHP

    15166questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Ubuntu

    847questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • PDO

    272questions

    PDO(PHP Data Objects)はPHPのデータベース抽象化レイヤーです。

PDOをインストールしようとするとエラーが出てインストールできません

解決済

回答 1

投稿 2017/11/30 10:48

  • 評価
  • クリップ 0
  • VIEW 62

Nikkoh_ban

score 2

お世話になっております。

Ubuntu17.10にPDOをインストールしようとしているのですがエラーが出てインストールできません。
gccはインストールされています。
かなり長いのでpeclでインストールしようとしたときに出てくるメッセージの最後を添付いたします。
どなたか分かる方がいらっしゃいましたらご教授いただけないでしょうか。
よろしくお願いいたします。

発生している問題・エラーメッセージ

root@hoge:/etc/php/7.0/fpm# pecl install pdo
WARNING: "pecl/PDO" is deprecated in favor of "channel://http://svn.php.net/viewvc/php/php-src/trunk/ext/pdo//ext/PDO"
downloading PDO-1.0.3.tgz ...
Starting to download PDO-1.0.3.tgz (52,613 bytes)
.............done: 52,613 bytes
12 source files, building
running: phpize
Configuring for:
PHP Api Version:         20160303
Zend Module Api No:      20160303
Zend Extension Api No:   320160303
〜中略〜
/tmp/pear/temp/PDO/pdo.c:371:20: error: too many arguments to function ‘zend_hash_get_current_data_ex’
while (SUCCESS == zend_hash_get_current_data_ex(&pdo_driver_hash, (void)&pdriver, &pos)) { ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~ In file included from /usr/include/php/20160303/Zend/zend.h:36:0, from /usr/include/php/20160303/main/php.h:36, from /tmp/pear/temp/PDO/pdo.c:28: /usr/include/php/20160303/Zend/zend_hash.h:198:30: note: declared here ZEND_API zval* ZEND_FASTCALL zend_hash_get_current_data_ex(HashTable *ht, HashPosition *pos); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Makefile:219: ターゲット 'pdo.lo' のレシピで失敗しました make: * [pdo.lo] エラー 1
ERROR: `make' failed
root@hoge:/etc/php/7.0/fpm#

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

いちばん上に「WARNING: "pecl/PDO" is deprecated」と出ているように、PHP 5.1.0以降PDOはPHPに標準添付されるようになっているため、PECLから入れるべきものではありません。

apt-getにPDO用のパッケージがありますので、そちらから入れてください。

投稿 2017/11/30 11:32

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/11/30 18:49

    解決方法を提示いただき誠にありがとうございました。
     # apt-get install php7.0-sqlite
     # apt-get install php7.0-mysql
    で無事インストールできました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.35%

関連した質問

同じタグがついた質問を見る

  • PHP

    15166questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Ubuntu

    847questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • PDO

    272questions

    PDO(PHP Data Objects)はPHPのデータベース抽象化レイヤーです。