質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.36%

  • PHP

    15165questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • composer

    102questions

    Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

composerでphpmailer インストールできない

解決済

回答 2

投稿 2017/11/27 15:08 ・編集 2017/11/29 00:07

  • 評価
  • クリップ 0
  • VIEW 74

brownwolf

score 0

前提・実現したいこと

composerでphpmailer/phpmailerをインストールしたいのですがなぜかできません。

発生している問題・エラーメッセージ

環境はVagrantでscotchbox3.0を使ってます。

公式のリファレンス参考にして、
https://github.com/PHPMailer/PHPMailer

composer.jsonの中身も真似して
composer require phpmailer/phpmailerとやって見ると、

$ composer require phpmailer/phpmailer
Using version ^6.0 for phpmailer/phpmailer
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Can only install one of: phpmailer/phpmailer[v6.0.0, dev-master].
    - Can only install one of: phpmailer/phpmailer[v6.0.1, dev-master].
    - Installation request for phpmailer/phpmailer dev-master -> satisfiable by phpmailer/phpmailer[dev-master].
    - Installation request for phpmailer/phpmailer ^6.0 -> satisfiable by phpmailer/phpmailer[v6.0.0, v6.0.1].

Installation failed, reverting ./composer.json to its original content.

このようになってしまいインストールができません。

そこでdev-masterにしないとダメなのかなと思い、
composer.jsonを下に変えて見たのですが、

    "require": {
        "php": ">=5.5.0",
        "ext-ctype": "*",
        "phpmailer/phpmailer": "dev-master"
    }

そのあと
composer update

返ってくるのは

Updating dependencies (including require-dev)
Nothing to install or update
Generating autoload files

そもそも認識されないみたいです。

いろいろ調査したのですが、これ以上解決策が見つからずどうにもならない状態です。

何か原因思い当たる方、教えて頂けないでしょうか。

補足情報(言語/FW/ツール等のバージョンなど)

言語:PHP 7.1.8
独自フレームワークです

何卒よろしくお願い致します。

 composer.json 

こちらの2パターン試しましたがダメでした。

{
    "name": "phpmailer/phpmailer",
    "type": "library",
    "description": "PHPMailer is a full-featured email creation and transfer class for PHP",
    "require": {
        "phpmailer/phpmailer": "~6.0"
    }
}
{
    "name": "phpmailer/phpmailer",
    "type": "library",
    "description": "PHPMailer is a full-featured email creation and transfer class for PHP",
    "authors": [
        {
            "name": "Marcus Bointon",
            "email": "phpmailer@synchromedia.co.uk"
        },
        {
            "name": "Jim Jagielski",
            "email": "jimjag@gmail.com"
        },
        {
            "name": "Andy Prevost",
            "email": "codeworxtech@users.sourceforge.net"
        },
        {
            "name": "Brent R. Matzelle"
        }
    ],
    "require": {
        "php": ">=5.5.0",
        "ext-ctype": "*",
        "phpmailer/phpmailer": "dev-master"
    },
    "require-dev": {
    },
    "suggest": {
    },
    "autoload": {
        "psr-4": {
            "PHPMailer\\PHPMailer\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "PHPMailer\\Test\\": "test/"
        }
    },
    "license": "LGPL-2.1"
}
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • maverixz

    2017/11/28 03:14

    composer.jsonをまるっと貼り付けてください

    キャンセル

  • brownwolf

    2017/11/29 00:08

    貼り付けました!

    キャンセル

  • num79kill

    2017/11/29 09:18

    バージョン番号は数字か記号で始めなくてはいけなかったような

    キャンセル

回答 2

check解決した方法

0

結局、composer.jsonの中身を全て削除して空にしてから、
composer require phpmailer/phpmailer
で、インストールできました。

投稿 2017/12/01 22:58

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

composer.json に 以下を記載して、 composer install で、インストールできましたが...

    "require" : {
        "phpmailer/phpmailer": "~6.0"
    }

以下の書き方は、公式にもありませんでしたが、どこを参考にされたのでしょうか?

        "phpmailer/phpmailer": "dev-master"

投稿 2017/11/27 15:49

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/11/27 16:07

    その方法でインストールしようとしましたが、同じエラーが出てきてしまいます。

    ```
    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    - Can only install one of: phpmailer/phpmailer[v6.0.0, dev-master].
    - Can only install one of: phpmailer/phpmailer[v6.0.1, dev-master].
    - Installation request for phpmailer/phpmailer dev-master -> satisfiable by phpmailer/phpmailer[dev-master].
    - Installation request for phpmailer/phpmailer ~6.0 -> satisfiable by phpmailer/phpmailer[v6.0.0, v6.0.1].
    ```

    stackoverflowでそういう書き方してる方がいたので、やってみた次第です。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.36%

関連した質問

同じタグがついた質問を見る

  • PHP

    15165questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • composer

    102questions

    Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。