質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.35%

  • Ruby

    5176questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5053questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ubuntu

    847questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • Ruby on Rails 5

    79questions

rails g migrationを行うとエラーが出ます。

解決済

回答 1

投稿 2017/11/20 00:06

  • 評価
  • クリップ 0
  • VIEW 61

kingmaster

score 1

前提・実現したいこと

ubuntu上でRuby on Railsを用いてサービス開発を行っています。
エディタはgeditを使ているのですが、rails g migrationを行うとエラーが出て先に進めなくなりました。実行したのはrails g migration add_user_id_to_postsになります。

発生している問題・エラーメッセージ

/home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-4.2.10/lib/active_support/dependencies.rb:268:in load': /home/mycomputer/デスクトップ/tweet_app/config/routes.rb:1: Invalid char \x7F' in expression (SyntaxError)
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-4.2.10/lib/active_support/dependencies.rb:268:in block in load'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-4.2.10/lib/active_support/dependencies.rb:240:in load_dependency'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-4.2.10/lib/active_support/dependencies.rb:268:in load'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application/routes_reloader.rb:40:in block in load_paths'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application/routes_reloader.rb:40:in each'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application/routes_reloader.rb:40:in load_paths'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application/routes_reloader.rb:16:in reload!'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application/routes_reloader.rb:26:in block in updater'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-4.2.10/lib/active_support/file_update_checker.rb:75:in execute'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application/routes_reloader.rb:27:in updater'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application/routes_reloader.rb:7:in execute_if_updated'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application/finisher.rb:69:in block in <module:Finisher>'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/initializable.rb:30:in instance_exec'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/initializable.rb:30:in run'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/initializable.rb:55:in block in run_initializers'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:228:in block in tsort_each'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:350:in block (2 levels) in each_strongly_connected_component'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:431:in each_strongly_connected_component_from'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:349:in block in each_strongly_connected_component'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:347:in each'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:347:in call'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:347:in each_strongly_connected_component'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:226:in tsort_each'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/tsort.rb:205:in tsort_each'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/initializable.rb:54:in run_initializers'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/railties-4.2.10/lib/rails/application.rb:352:in initialize!'
from /home/mycomputer/デスクトップ/tweet_app/config/environment.rb:5:in <top (required)>'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:102:in require'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:102:in preload'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:153:in serve'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:141:in block in run'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:135:in loop'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:135:in run'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/spring-2.0.2/lib/spring/application/boot.rb:19:in <top (required)>'
from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in require'     from /home/mycomputer/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in require'
from -e:1:in `<main>'

該当のソースコード

おそらくroutesでおかしなことが起きているのではないかと思うのですが、これより前に行った
add_image_name_to_usersやadd_password_to_usersはうまく実行することができました。
またこれらに関してはrake db:migrateもうまくいきました。

試したこと

試しにフォルダからroutesを削除して実行するとうまく実行できました。

補足情報(言語/FW/ツール等のバージョンなど)

ubuntu16.04 使用
Windows10とのデュアルブート
Ruby on rails
Ruby 2.3.1を使用

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

routes.rbに制御コード\x7Fが混入し、シンタックスエラーになっているようです。
\x7Fを削除すればうまくいくと思います。
お使いのエディタで表示されない場合、別のエディタを使って探した方が早いかもしれません。

さくらエディタであれば検索できるみたいです。
https://harvestasya.com/151

投稿 2017/11/20 13:16

編集 2017/11/20 13:22

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.35%

関連した質問

同じタグがついた質問を見る

  • Ruby

    5176questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5053questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ubuntu

    847questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • Ruby on Rails 5

    79questions