質問するログイン新規登録

Q&A

解決済

1回答

1817閲覧

リバースプロキシによる転送のやり方がわかりません;;

watasida

総合スコア6

AWS(Amazon Web Services)

Amazon Web Services (AWS)は、仮想空間を機軸とした、クラスター状のコンピュータ・ネットワーク・データベース・ストーレッジ・サポートツールをAWSというインフラから提供する商用サービスです。

1グッド

0クリップ

投稿2023/03/17 19:24

1

0

実現したいこと

AWSのパブリックサブネットに設置したEC2インスタンス(webサーバ)へのHTTPリクエストを、プライベートサブネットに設置したEC2インスタンス(APサーバ)にリバースプロキシで転送したい。
web、AP、DBサーバの3層構造が一般的であり、セキュリティ的にAP,、 DBはプライベートサブネットに設置すると良いらしい(自分調べ)とのことで、AWSの勉強のためにこのような手法を試してます(実務で扱っているわけではありません)。
バキバキの初心者です。用語の使い方等が間違っていたら教えてください。

前提

色々試してみた結果ごちゃごちゃしてしまい、必要な情報が書けていないかもしれません。
不足している情報があれば言ってください。

以下のような設計を考えています。
イメージ説明

今のところ、以下の通信はうまくいっていると思います。

  • ホストマシンからwebサーバへのhttp接続(ブラウザからパブリックIPでnginxのページが表示される)
  • ホストマシンからwebサーバへのssh接続
  • ホストマシンからwebサーバを踏み台にしたAPサーバへのssh接続
  • APサーバからDBサーバへのTCP3306接続
  • APサーバからエンドポイントを介したS3への接続

ホストマシンからhttpでwebサーバにアクセスした際に、リバースプロキシでAPサーバの3000番ポートに転送されるように、webサーバのnginxの設定ファイル、APサーバのapacheの設定ファイルを書き換えてみたのですが、接続できません。

  • nginxの設定ファイル
    こちらを参考に、/etc/nginx/conf.d/proxy.confを作成し、以下のように書き込みました。
    rootに書いてあるのはAPサーバのlaravelプロジェクトのドキュメントルートです(これをapacheの設定ファイルにも書き込んでいます)
server { listen 80; server_name .*; root /var/www/laravel-project/AWS-EC2-laravel/public; location / { try_files $uri @app; } location @app { proxy_set_header Host $http_host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-Host $host; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; proxy_pass http://APサーバのプライベートIP:3000; } }
  • apacheの設定ファイル
    こちらや、こちらを参考にして、/etc/httpd/conf/httpd.confを以下のように書き換えました。
# DocumentRoot: The directory out of which you will serve your # documents. By default, all requests are taken from this directory, but # symbolic links and aliases may be used to point to other locations. # DocumentRoot "/var/www/laravel-project/AWS-EC2-laravel/public" # 書き換え # # Relax access to content within /var/www. # <Directory "/var/www/laravel-project/AWS-EC2-laravel/public"> # 書き換え AllowOverride All # NoneからAllに書き換え # Allow open access: Require all granted </Directory>

発生している問題・エラーメッセージ

ブラウザから、http://webサーバのパブリックIPにアクセスすると、502 Bad Gatewayというエラー(nginxのエラーページ)が表示されます。

試したこと

webサーバからの3000番ポートへのリクエストを受けつけるため/etc/httpd/conf/httpd.confを

Listen webサーバのプライベートIP:3000 # 80から書き換え

と書き換え、apacheを再起動すると、

(99)Cannot assign requested address: AH00072: make_sock: could not bind to address webサーバのプライベートIP

というエラーになりました。

補足情報

APサーバにはapacheに加えてphp-fpmというPHP用のアプリケーションサーバ(?)も入っています。何の目的で入れたのかもあまり理解していないのですが、これの設定ファイルを書き換える必要もあるのでしょうか?

gusachan3が✨を押しています

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

guest

回答1件

0

自己解決

以下のように設定すると、ブラウザからwebサーバのIPにアクセスして、laravelの画面が表示されました。
APサーバの/etc/httpd/conf/httpd.confを

Listen 3000 # 80から書き換え

Webサーバの/etc/nginx/nginx.confのserverの中に以下のように追記

location / { proxy_pass http://APサーバのIP:3000/; }

投稿2023/03/23 15:12

watasida

総合スコア6

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.25%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問