質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

コマンドプロンプト

コマンドプロンプト(cmd.exe)はMicrosoftによって提供されているコマンドラインインタプリタです。OS/2・Windows CE・Windows NTで使用可能です。

XAMPP

XAMPP(ザンプ)は、ウェブアプリケーションの実行に必要なフリーソフトウェアをパッケージングしたApacheディストリビューションです。 XAMPPひとつインストールするだけで、Apache、MySQL、PHP、Perlなどのソフトウェアと、 phpMyAdminなどの管理ツール、SQLiteなどのソフトウェアやライブラリモジュールなどを利用することが可能です。

Q&A

1回答

1234閲覧

composer updateを実行したいがエラーが出る。

TINA

総合スコア0

Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

コマンドプロンプト

コマンドプロンプト(cmd.exe)はMicrosoftによって提供されているコマンドラインインタプリタです。OS/2・Windows CE・Windows NTで使用可能です。

XAMPP

XAMPP(ザンプ)は、ウェブアプリケーションの実行に必要なフリーソフトウェアをパッケージングしたApacheディストリビューションです。 XAMPPひとつインストールするだけで、Apache、MySQL、PHP、Perlなどのソフトウェアと、 phpMyAdminなどの管理ツール、SQLiteなどのソフトウェアやライブラリモジュールなどを利用することが可能です。

0グッド

0クリップ

投稿2023/02/07 16:28

実現したいこと

  • コマンドプロンプトでcomposer updateを実行させたい
  • XAMPPのPHPのバージョンを切り替えたい

前提

プログラミング初心者です。

XAMPPを使って開発環境を構築しています。
composer updateをコマンドプロントで実行させたいのですが、写真のようなエラーが出ます。
PHPのバージョンを切り替えようと思うのですが、写真には
require php ^7.1....
require php ^7.0....
require php ^5.6|^7.0....

というように複数のPHPのバージョンが提示されるのですが、どのPHPのバージョンに切り替えればよいのでしょうか?

ちなみに現在のXAMPPのphpのバージョンは8.2.0です。

よろしくお願いします。

イメージ説明

発生している問題・エラーメッセージ

XAMPPのPHPのバージョンが対応していない?

Your requirements could not be resolved to an installable set of packages. Problem 1 - Root composer.json requires doctrine/dbal 2.6.* -> satisfiable by doctrine/dbal[v2.6.0, v2.6.1, v2.6.2, v2.6.3]. - doctrine/dbal[v2.6.0, ..., v2.6.3] require php ^7.1 -> your php version (8.2.0; overridden via config.platform, same as actual) does not satisfy that requirement. Problem 2 - Root composer.json requires webpatser/laravel-uuid ^3.0 -> satisfiable by webpatser/laravel-uuid[3.0, 3.0.1, 3.0.2]. - webpatser/laravel-uuid[3.0, ..., 3.0.2] require php ^7.0 -> your php version (8.2.0; overridden via config.platform, same as actual) does not satisfy that requirement. Problem 3 - phpoffice/phpspreadsheet[1.2.0, ..., 1.8.2] require php ^5.6|^7.0 -> your php version (8.2.0; overridden via config.platform, same as actual) does not satisfy that requirement. - phpoffice/phpspreadsheet[1.9.0, ..., 1.12.0] require php ^7.1 -> your php version (8.2.0; overridden via config.platform, same as actual) does not satisfy that requirement. - phpoffice/phpspreadsheet[1.13.0, ..., 1.14.1] require php ^7.2 -> your php version (8.2.0; overridden via config.platform, same as actual) does not satisfy that requirement. - phpoffice/phpspreadsheet[1.15.0, ..., 1.27.0] require ext-gd * -> it is missing from your system. Install or enable PHP's gd extension. - Root composer.json requires phpoffice/phpspreadsheet ^1.2 -> satisfiable by phpoffice/phpspreadsheet[1.2.0, ..., 1.27.0]. To enable extensions, verify that they are enabled in your .ini files: - C:\xampp\php\php.ini You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode. Alternatively, you can run Composer with `--ignore-platform-req=ext-gd` to temporarily ignore these required extensions.

該当のソースコード

PHP Laravel

試したこと

ここに問題に対して試したことを記載してください。

補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

m.ts10806

2023/02/07 21:49

jsonを提示してください
TINA

2023/02/08 11:52

一部ですがPHPが記載されてる部分はこのようになってました。 "require": { "php": ">=7.0.0", "fideloper/proxy": "~3.3", "laravel/framework": "5.5.*", "laravel/tinker": "~1.0", "laravelcollective/html": "^5.5", "phpoffice/phpspreadsheet": "^1.2", "reliese/laravel": "^0.0.13", "doctrine/dbal": "2.6.*" }, "config": { "preferred-install": "dist", "sort-packages": true, "optimize-autoloader": true, "platform": { "php": "8.2.0" } },
guest

回答1

0

require ext-gd * -> it is missing from your system. Install or enable PHP's gd extension.

これが原因です

投稿2023/02/08 01:51

phper.k

総合スコア3923

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

TINA

2023/02/08 17:36

ご回答ありがとうございます。 PHP-gd拡張モジュールを有効化したらその問題は解決することができました! しかし、上記の「PHPのバージョンがあっておらず....」のようなエラーは消えず、結局composer updateを実行することはできませんでした。 現在使用しているPHPのバージョン(8.2.0)以外ををダウンロードして再度実行しようと思うのですが、上記のようなエラーが出た場合はどのバージョンをダウンロードしたらよいですか?
phper.k

2023/02/09 02:19

「「PHPのバージョンがあっておらず....」のようなエラー」 ↑この情報だけでわかるわけないでしょ。 こちらをよくお読みください。 https://teratail.com/help/question-tips
TINA

2023/02/09 02:31

上のコマンドプロンプトのスクショに複数回書かれている your php version (8.2.0; overridden via config.platform, same as actual) does not satisfy that requirement. というエラーのことを示していました。 分かりにくくて申し訳ございませんでした。
phper.k

2023/02/09 02:41 編集

こちらをよくお読みください。 https://teratail.com/help/question-tips ・エラーはすべて載せる。 ・そのエラーは何をした時のものは明示する(具体的にどんなコマンドを叩いたのか) 提示した部分に書いているのは「あなたのPHPは8.2で対応していません」という情報しかない。 どのモジュールが対応していないのかは判断つかない。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問