質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Java

Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

Eclipse

Eclipseは、IBM社で開発された統合開発環境のひとつです。2001年11月にオープンソース化されました。 たくさんのプラグインがあり自由に機能を追加をすることができるため、開発ツールにおける共通プラットフォームとして位置づけられています。 Eclipse自体は、Javaで実装されています。

Tomcat

TomcatはApache Software Foundation (ASF)で開発されたオープンソースのWebコンテナです。

Q&A

解決済

1回答

224閲覧

EclipseにTomcat11を追加したい

inu22

総合スコア2

Java

Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

Eclipse

Eclipseは、IBM社で開発された統合開発環境のひとつです。2001年11月にオープンソース化されました。 たくさんのプラグインがあり自由に機能を追加をすることができるため、開発ツールにおける共通プラットフォームとして位置づけられています。 Eclipse自体は、Javaで実装されています。

Tomcat

TomcatはApache Software Foundation (ASF)で開発されたオープンソースのWebコンテナです。

0グッド

0クリップ

投稿2024/05/13 07:49

編集2024/05/13 10:00

実現したいこと

PleiadesからEclipse 2023-12 (4.30.0)をダウンロードしたのですが、
Tomcat10までしかないところにTomcat11を追加したいです。

別の質問内で必要そうだったので試したいのですが、詰まったので別の質問として作成しました。
https://teratail.com/questions/s6i8wp4adwqryg

発生している問題・分からないこと

イメージ説明
ここにTomcat11を追加したいのですが、ランタイム環境のタイプを選択のところにv11がなくここからどうして良いのか分からず詰まっています。

追記:
「追加」ではなく「検索」を試したところ、
「新規サーバー・ランタイム環境が見つかりませんでした。」のエラーになりました。
検索したパスは以下の通りです。
/Applications/Eclipse_2023-12.app/Contents/tomcat/11/
なお、他のバージョン(10など)のフォルダだとこのエラーは出ませんでした。
イメージ説明

該当のソースコード

特になし

試したこと・調べたこと

  • teratailやGoogle等で検索した
  • ソースコードを自分なりに変更した
  • 知人に聞いた
  • その他
上記の詳細・結果

https://qiita.com/SKY-HaYaTo/items/745e2eee522d321342d2
こちらを参考にし、

https://archive.apache.org/dist/tomcat/tomcat-11/v11.0.0-M1/bin/
上記からapache-tomcat-11.0.0-M1.zipをダウンロードし、展開してフォルダ名を11にした後、
/Applications/Eclipse_2023-12.app/Contents/tomcat/に配置してみたのですが、上述のところで詰まっています。

補足

MacOS Monterey 12.7.4
Eclipse 2023-12 (4.30.0)

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

inu22

2024/05/13 10:01

ご回答ありがとうございます。 「追加」ではなく「検索」を試したところ、 「新規サーバー・ランタイム環境が見つかりませんでした。」のエラーになりました。 検索したパスは以下の通りです。 /Applications/Eclipse_2023-12.app/Contents/tomcat/11/ なお、他のバージョン(10など)のフォルダだとこのエラーは出ませんでした。 質問に同じ内容とエラー画面追加しています。
inu22

2024/05/13 23:08

そもそも対応していなかったのですね。 対応するまで待とうと思います。ありがとうございました。 ベストアンサーに選びたいので同じ内容を回答欄に投稿いただけますでしょうか。
guest

回答1

0

ベストアンサー

Bug 581277 - Add Tomcat 11.0.x to WTP Server Tools
https://bugs.eclipse.org/bugs/show_bug.cgi?id=581277

バグと言うか要望ですけども。
成ってないということは正式かせめてベータまで待つつもりですかね。
内部のファイルを弄って 10.1 等に見せかければ使えるだろうということですが…。

投稿2024/05/14 04:07

jimbe

総合スコア12874

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

inu22

2024/05/14 04:13 編集

ご回答ありがとうございました。 リンク先の方法を使って内部のファイルを弄って10.1に見せかけ、サーバーを追加するところまではできました。 ただし作成してデプロイできるWebアプリのバージョンは、 Eclipseでサポートされているバージョンに制限されるとのことで 今回は目的に合わなかったので対応するまで待つことにします。
jimbe

2024/05/14 05:09

11 としての機能は使えなくても tomcat11 が動作するかは試せるといったところでしょうか。 それはそれで意味のある情報だと思います。 有難う御座いました。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問