質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.42%
Gatsby

Gatsbyとは、Reactベースの静的サイトジェネレータ。最新のフロントエンド技術を活かし、機能豊富なWebサイトやアプリケーションを作ることが可能です。GraphQLを用いてあらゆるソースからサイトのデータを取得。指定した設定に基づいて静的サイトを構築することができます。

Q&A

1回答

842閲覧

gatsbyの環境構築

kenjise

総合スコア0

Gatsby

Gatsbyとは、Reactベースの静的サイトジェネレータ。最新のフロントエンド技術を活かし、機能豊富なWebサイトやアプリケーションを作ることが可能です。GraphQLを用いてあらゆるソースからサイトのデータを取得。指定した設定に基づいて静的サイトを構築することができます。

0グッド

0クリップ

投稿2023/03/19 16:47

実現したいこと

% gatsby --help  を実行して正常に実行できるようにしたい。

前提

発生している問題・エラーメッセージ

エラーメッセージ

% gatsby --help
zsh: command not found: gatsby
~ % npm config delete prefix
~ % npm config set prefix /usr/local
~ % npm i -g gatsby-cli
/usr/local/bin/gatsby -> /usr/local/lib/node_modules/gatsby-cli/cli.js

gatsby-cli@5.7.0 postinstall /usr/local/lib/node_modules/gatsby-cli
node scripts/postinstall.js

npm WARN notsup Unsupported engine for gatsby-cli@5.7.0: wanted: {"node":">=18.0.0"} (current: {"node":"12.14.0","npm":"6.13.4"})
npm WARN notsup Not compatible with your version of node/npm: gatsby-cli@5.7.0
npm WARN notsup Unsupported engine for fs-extra@11.1.0: wanted: {"node":">=14.14"} (current: {"node":"12.14.0","npm":"6.13.4"})
npm WARN notsup Not compatible with your version of node/npm: fs-extra@11.1.0
npm WARN notsup Unsupported engine for gatsby-core-utils@4.7.0: wanted: {"node":">=18.0.0"} (current: {"node":"12.14.0","npm":"6.13.4"})
npm WARN notsup Not compatible with your version of node/npm: gatsby-core-utils@4.7.0
npm WARN notsup Unsupported engine for gatsby-telemetry@4.7.0: wanted: {"node":">=18.0.0"} (current: {"node":"12.14.0","npm":"6.13.4"})
npm WARN notsup Not compatible with your version of node/npm: gatsby-telemetry@4.7.0
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @lmdb/lmdb-darwin-arm64@2.5.3 (node_modules/gatsby-cli/node_modules/lmdb/node_modules/@lmdb/lmdb-darwin-arm64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @lmdb/lmdb-darwin-arm64@2.5.3: wanted {"os":"darwin","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @lmdb/lmdb-linux-x64@2.5.3 (node_modules/gatsby-cli/node_modules/lmdb/node_modules/@lmdb/lmdb-linux-x64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @lmdb/lmdb-linux-x64@2.5.3: wanted {"os":"linux","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @lmdb/lmdb-linux-arm64@2.5.3 (node_modules/gatsby-cli/node_modules/lmdb/node_modules/@lmdb/lmdb-linux-arm64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @lmdb/lmdb-linux-arm64@2.5.3: wanted {"os":"linux","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @lmdb/lmdb-linux-arm@2.5.3 (node_modules/gatsby-cli/node_modules/lmdb/node_modules/@lmdb/lmdb-linux-arm):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @lmdb/lmdb-linux-arm@2.5.3: wanted {"os":"linux","arch":"arm"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @lmdb/lmdb-win32-x64@2.5.3 (node_modules/gatsby-cli/node_modules/lmdb/node_modules/@lmdb/lmdb-win32-x64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @lmdb/lmdb-win32-x64@2.5.3: wanted {"os":"win32","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @msgpackr-extract/msgpackr-extract-win32-x64@3.0.2 (node_modules/gatsby-cli/node_modules/msgpackr-extract/node_modules/@msgpackr-extract/msgpackr-extract-win32-x64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @msgpackr-extract/msgpackr-extract-win32-x64@3.0.2: wanted {"os":"win32","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @msgpackr-extract/msgpackr-extract-linux-x64@3.0.2 (node_modules/gatsby-cli/node_modules/msgpackr-extract/node_modules/@msgpackr-extract/msgpackr-extract-linux-x64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @msgpackr-extract/msgpackr-extract-linux-x64@3.0.2: wanted {"os":"linux","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @msgpackr-extract/msgpackr-extract-linux-arm64@3.0.2 (node_modules/gatsby-cli/node_modules/msgpackr-extract/node_modules/@msgpackr-extract/msgpackr-extract-linux-arm64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @msgpackr-extract/msgpackr-extract-linux-arm64@3.0.2: wanted {"os":"linux","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @msgpackr-extract/msgpackr-extract-darwin-arm64@3.0.2 (node_modules/gatsby-cli/node_modules/msgpackr-extract/node_modules/@msgpackr-extract/msgpackr-extract-darwin-arm64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @msgpackr-extract/msgpackr-extract-darwin-arm64@3.0.2: wanted {"os":"darwin","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @msgpackr-extract/msgpackr-extract-linux-arm@3.0.2 (node_modules/gatsby-cli/node_modules/msgpackr-extract/node_modules/@msgpackr-extract/msgpackr-extract-linux-arm):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @msgpackr-extract/msgpackr-extract-linux-arm@3.0.2: wanted {"os":"linux","arch":"arm"} (current: {"os":"darwin","arch":"x64"})

updated 1 package in 39.116s
~ % gatsby --help
internal/modules/cjs/loader.js:800
throw err;
^

Error: Cannot find module 'gatsby-core-utils/is-truthy'
Require stack:

  • /usr/local/lib/node_modules/gatsby-cli/lib/reporter/reporter.js
  • /usr/local/lib/node_modules/gatsby-cli/lib/reporter/catch-exit-signals.js
  • /usr/local/lib/node_modules/gatsby-cli/lib/reporter/index.js
  • /usr/local/lib/node_modules/gatsby-cli/lib/create-cli.js
  • /usr/local/lib/node_modules/gatsby-cli/lib/index.js
  • /usr/local/lib/node_modules/gatsby-cli/cli.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:797:15)
    at Function.Module._load (internal/modules/cjs/loader.js:690:27)
    at Module.require (internal/modules/cjs/loader.js:852:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at Object.<anonymous> (/usr/local/lib/node_modules/gatsby-cli/lib/reporter/reporter.js:19:17)
    at Module._compile (internal/modules/cjs/loader.js:959:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:995:10)
    at Module.load (internal/modules/cjs/loader.js:815:32)
    at Function.Module._load (internal/modules/cjs/loader.js:727:14)
    at Module.require (internal/modules/cjs/loader.js:852:19) {
    code: 'MODULE_NOT_FOUND',
    requireStack: [
    '/usr/local/lib/node_modules/gatsby-cli/lib/reporter/reporter.js',
    '/usr/local/lib/node_modules/gatsby-cli/lib/reporter/catch-exit-signals.js',
    '/usr/local/lib/node_modules/gatsby-cli/lib/reporter/index.js',
    '/usr/local/lib/node_modules/gatsby-cli/lib/create-cli.js',
    '/usr/local/lib/node_modules/gatsby-cli/lib/index.js',
    '/usr/local/lib/node_modules/gatsby-cli/cli.js'
    ]

}

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

nodejsのバージョンを上げると治ると思います

次のコマンドを実行して、グローバルにインストールされた Gatsby CLI をアンインストールします。

npm uninstall -g gatsby-cli

その後、Node.js のバージョンを 18.0.0 以上にアップグレードします。最新の LTS バージョンにアップグレードすることをお勧めします。 (gatsby-cli@5.7.0がnodejs18以上を要求しているため)

Node.jsの公式サイトから、最新版のNode.jsをダウンロードしてインストールします。インストーラーをダブルクリックして開き、指示に従ってインストールします。

Node.js のバージョンをアップグレードしたら、再び Gatsby CLI をインストールしてみてください。

npm install -g gatsby-cli
これで gatsby --help を実行することができるか試してください。

投稿2023/03/19 17:33

natsume2233

総合スコア225

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

kenjise

2023/03/28 23:39

ありがとうございます。 すいません、nodeのバージョンアップができません。 % nodebrew install-binary v18.15.0 Fetching: https://nodejs.org/dist/v18.15.0/node-v18.15.0-darwin-x64.tar.gz ######################################################################################### 100.0% Installed successfully % nodebrew use v18.15.0 use v18.15.0 % node --version v12.14.0
kenjise

2023/03/29 00:17

nodeのアップデートはできましたがgatbyの方はできません。 % node -v v19.8.1 % npm install -g gatsby-cli npm notice npm notice New minor version of npm available! 9.5.1 -> 9.6.2 npm notice Changelog: https://github.com/npm/cli/releases/tag/v9.6.2 npm notice Run npm install -g npm@9.6.2 to update! npm notice npm ERR! code ENOENT npm ERR! syscall spawn sh npm ERR! path /usr/local/lib/node_modules/gatsby-cli/node_modules/lmdb npm ERR! errno -2 npm ERR! enoent spawn sh ENOENT npm ERR! enoent This is related to npm not being able to find a file. npm ERR! enoent npm ERR! A complete log of this run can be found in: npm ERR! /Users/kenji/.npm/_logs/2023-03-29T00_10_26_916Z-debug-0.log % npm uninstall -g gatsby-cli up to date in 76ms % npm uninstall -g gatsby-cli up to date in 71ms % node -v v19.8.1 % npm install -g gatsby-cli npm ERR! code ENOENT npm ERR! syscall spawn sh npm ERR! path /usr/local/lib/node_modules/gatsby-cli/node_modules/lmdb npm ERR! errno -2 npm ERR! enoent spawn sh ENOENT npm ERR! enoent This is related to npm not being able to find a file. npm ERR! enoent npm ERR! A complete log of this run can be found in: npm ERR! /Users/kenji/.npm/_logs/2023-03-29T00_11_54_265Z-debug-0.log
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.42%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問