質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.53%
terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Q&A

解決済

1回答

455閲覧

Macのターミナルアプリからcocoapodsをダウンロードしたい

Kimura

総合スコア7

terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

0グッド

0クリップ

投稿2023/11/28 10:09

実現したいこと

  • cocoapodsがエラーが出ててダウンロード出来ないので解決してダウンロードしたい。

前提

MACのターミナルアプリでcocoapodsをダウンロードしようとしています。
インストールに必要なコマンド?のsudo gem install cocoapodsを入力したところ以下のようなエラーが発生しています。

発生している問題・エラーメッセージ

Error installing cocoapods: The last version of drb (>= 0) to support your Ruby & RubyGems was 2.0.5. Try installing it with `gem install drb -v 2.0.5` and then running the current command again drb requires Ruby version >= 2.7.0. The current ruby version is 2.6.10.210.``` ### 試したこと Google検索で出てきたRubyのアップデートを試してみましたがこれも出来ませんでした。 ### 補足情報(FW/ツールのバージョンなど) Rubyのバージョンは2.6.10.2です。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

hoshi-takanori

2023/11/28 10:21

個人的には、sudo は使わずに、Homebrew で入れるのがお勧めです。
guest

回答1

0

ベストアンサー

エラーメッセージに書かれている通りのコマンドを sudo 付きで

sudo gem install drb -v 2.0.5

でインストールした後、再度cocoapodsのインストールを実施すればいいです。

おそらく、この後 activesupport についても同様のエラーメッセージが出ると思いますので、同様の対処をして、もう一度cocoapodsのインストールを実施すれば成功するはずです。

CocoaPodsのインストール方法について、公式ドキュメントでは

https://guides.cocoapods.org/using/getting-started.html

CocoaPods is built with Ruby and it will be installable with the default Ruby available on macOS. You can use a Ruby Version manager, however we recommend that you use the standard Ruby available on macOS unless you know what you're doing. Using the default Ruby install will require you to use sudo when installing gems. (This is only an issue for the duration of the gem installation, though.)

と説明されている通り、masOSに最初から入っているデフォルトのRubyを使用してインストールすることが推奨されています。

ただ、このmacOSにプリインストールされているRubyのバージョンはv2.6.10とかなり古いRubyで、既にRubyの開発元ではサポートが打ち切られているバージョンなので、CocoaPodsが利用しているRubyのライブラリも古いRubyをサポートしなくなったものが出てきており、今回のように少し古いバージョンのライブラリをバージョン指定でインストールする対応が必要になってきているようです。

また、AppleはmacOSにRubyをプリインストールすることにあまり積極的ではないようで、そろそろプリインストールも打ち切られるのではないかと噂されています。もしそうなったら、公式ドキュメントのインストール方法の説明も更新されるだろうと思います。

(参考)
https://github.com/CocoaPods/CocoaPods/issues/12122

投稿2023/11/30 00:59

編集2023/11/30 01:00
TakeOne

総合スコア6299

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

Kimura

2023/12/01 07:26

無事DL終えられました。ありがとうございます
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.53%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問