回答編集履歴

1 質問のバージョンを勘違いしていたので追記

koronatail

koronatail score 433

2019/01/21 10:49  投稿

Spring BootリファレンスのSystem Requirementsで確認できます。
最新バージョンは以下のURL
[https://docs.spring.io/spring-boot/docs/current/reference/html/getting-started-system-requirements.html](https://docs.spring.io/spring-boot/docs/current/reference/html/getting-started-system-requirements.html)
他のバージョンを探したいときは下からx.x.x.RELEASE/reference/html/をたどっていけば見つかりそうです。
[https://docs.spring.io/spring-boot/docs/](https://docs.spring.io/spring-boot/docs/)
さらっと見た限りだと1.5以前であれば動きそうですね
さらっと見た限りだと1.5以前であれば動きそうですね
**追記**
・・・と思ったのですが質問者様のpom.xmlよく見たらSpring Boot1.5.8とTomcat7.0.76の組み合わせでしたね・・・。
System Requirementsを見るにサポートしているように見えるのでバージョン以外の原因でしょうか・・・

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る