回答編集履歴

2 dummy

argius

argius score 9504

2015/08/30 03:02  投稿

`Main3.java`が含まれている(Eclipseの?)プロジェクトのJavaのバージョンがJava6になっているようです。
`Main3.java`が含まれているEclipseのプロジェクトのJavaのバージョンがJava6になっているようです。
`AutoClosable`や`System.lineSeparator()`は、Java7から使えるようになったAPIですので、Java7以降を使うように設定してみてください。
1 dummy

argius

argius score 9504

2015/08/30 02:58  投稿

`Main3.java`が含まれている(Eclipseの?)プロジェクトのJavaのバージョンがJava6になっているようです。
`AutoClosable`や`System.lineSeparator()`はJava7から使えるようになったAPIですので、Java7以降を使うように設定してみてください。
`AutoClosable`や`System.lineSeparator()`は、Java7から使えるようになったAPIですので、Java7以降を使うように設定してみてください。

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る