質問編集履歴

2 追記

kozica

kozica score 58

2018/10/04 18:46  投稿

bundle installでエラーがでる
bundle installで下記のようなエラーがでてきます
bundle updateしろというので
bundle updateしたら,bundle update activerecordしろと言われ
bundle update activerecordしたらbundle updateしろと振り出しに戻ります
これはどうすればよいのでしょうか?
 
どなたも解決ができなようですが、わかる方いませんでしょうか?  
```
$ bundle install
Your Gemfile lists the gem settingslogic (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Fetching gem metadata from https://rubygems.org/.......
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "rspec-core":
 In snapshot (Gemfile.lock):
   rspec-core (= 3.8.0)
 In Gemfile:
   guard-rspec was resolved to 4.7.3, which depends on
     rspec (< 4.0, >= 2.99.0) was resolved to 3.8.0, which depends on
       rspec-core (~> 3.8.0)
   rspec-rails (~> 3.7.2) was resolved to 3.7.2, which depends on
     rspec-core (~> 3.7.0)
Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
$ bundle update
Your Gemfile lists the gem settingslogic (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Fetching gem metadata from https://rubygems.org/.......
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies................
Using rake 12.3.1
Using concurrent-ruby 1.0.5
Using i18n 0.9.5
Using multi_json 1.13.1
Using activesupport 3.2.14
Using builder 3.0.4
Using activemodel 3.2.14
Using erubis 2.7.0
Using journey 1.0.4
Using rack 1.4.7
Using rack-cache 1.8.0
Using rack-test 0.6.3
Using hike 1.2.3
Using tilt 1.4.1
Using sprockets 2.2.3
Using actionpack 3.2.14
Using mime-types 1.25.1
Using polyglot 0.3.5
Using treetop 1.4.15
Using mail 2.5.5
Using actionmailer 3.2.14
Fetching activerecord 3.2.14
Downloading activerecord-3.2.14 revealed dependencies not in the API or the lockfile
(activesupport (= 3.2.14), activemodel (= 3.2.14), arel (~> 3.0.2), tzinfo (~> 0.3.29)).
Either installing with `--full-index` or running `bundle update activerecord` should fix
the problem.
In Gemfile:
 acts_as_list was resolved to 0.9.16, which depends on
   activerecord
$ bundle update activerecord
Your Gemfile lists the gem settingslogic (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Fetching gem metadata from https://rubygems.org/.......
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "rspec-core":
 In snapshot (Gemfile.lock):
   rspec-core (= 3.8.0)
 In Gemfile:
   guard-rspec was resolved to 4.7.3, which depends on
     rspec (< 4.0, >= 2.99.0) was resolved to 3.8.0, which depends on
       rspec-core (~> 3.8.0)
   rspec-rails (~> 3.7.2) was resolved to 3.7.2, which depends on
     rspec-core (~> 3.7.0)
Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
```
  • Ruby

    13450 questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 5

    5106 questions

    Ruby on Rails 5は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

1 追記

kozica

kozica score 58

2018/10/04 17:56  投稿

bundle installでエラーがでる
bundle installで下記のようなエラーがでてきます
 
bundle updateしろというので  
bundle updateしたら,bundle update activerecordしろと言われ  
bundle update activerecordしたらbundle updateしろと振り出しに戻ります  
 
 
これはどうすればよいのでしょうか?
```
$ bundle install
Your Gemfile lists the gem settingslogic (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Fetching gem metadata from https://rubygems.org/.......
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "rspec-core":
 In snapshot (Gemfile.lock):
   rspec-core (= 3.8.0)
 In Gemfile:
   guard-rspec was resolved to 4.7.3, which depends on
     rspec (< 4.0, >= 2.99.0) was resolved to 3.8.0, which depends on
       rspec-core (~> 3.8.0)
   rspec-rails (~> 3.7.2) was resolved to 3.7.2, which depends on
     rspec-core (~> 3.7.0)
Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
 
$ bundle update  
Your Gemfile lists the gem settingslogic (>= 0) more than once.  
You should probably keep only one of them.  
While it's not a problem now, it could cause errors if you change the version of one of them later.  
Fetching gem metadata from https://rubygems.org/.......  
Fetching gem metadata from https://rubygems.org/.  
Resolving dependencies................  
Using rake 12.3.1  
Using concurrent-ruby 1.0.5  
Using i18n 0.9.5  
Using multi_json 1.13.1  
Using activesupport 3.2.14  
Using builder 3.0.4  
Using activemodel 3.2.14  
Using erubis 2.7.0  
Using journey 1.0.4  
Using rack 1.4.7  
Using rack-cache 1.8.0  
Using rack-test 0.6.3  
Using hike 1.2.3  
Using tilt 1.4.1  
Using sprockets 2.2.3  
Using actionpack 3.2.14  
Using mime-types 1.25.1  
Using polyglot 0.3.5  
Using treetop 1.4.15  
Using mail 2.5.5  
Using actionmailer 3.2.14  
Fetching activerecord 3.2.14  
Downloading activerecord-3.2.14 revealed dependencies not in the API or the lockfile  
(activesupport (= 3.2.14), activemodel (= 3.2.14), arel (~> 3.0.2), tzinfo (~> 0.3.29)).  
Either installing with `--full-index` or running `bundle update activerecord` should fix  
the problem.  
 
In Gemfile:  
 acts_as_list was resolved to 0.9.16, which depends on  
   activerecord  
 
$ bundle update activerecord  
Your Gemfile lists the gem settingslogic (>= 0) more than once.  
You should probably keep only one of them.  
While it's not a problem now, it could cause errors if you change the version of one of them later.  
Fetching gem metadata from https://rubygems.org/.......  
Fetching gem metadata from https://rubygems.org/.  
Resolving dependencies...  
Bundler could not find compatible versions for gem "rspec-core":  
 In snapshot (Gemfile.lock):  
   rspec-core (= 3.8.0)  
 
 In Gemfile:  
   guard-rspec was resolved to 4.7.3, which depends on  
     rspec (< 4.0, >= 2.99.0) was resolved to 3.8.0, which depends on  
       rspec-core (~> 3.8.0)  
 
   rspec-rails (~> 3.7.2) was resolved to 3.7.2, which depends on  
     rspec-core (~> 3.7.0)  
 
Running `bundle update` will rebuild your snapshot from scratch, using only  
the gems in your Gemfile, which may resolve the conflict.  
 
```
  • Ruby

    13450 questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 5

    5106 questions

    Ruby on Rails 5は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る