質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Ruby

    9391questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 5

    3150questions

bundle installでエラーがでる

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 524

kozica

score 43

bundle installで下記のようなエラーがでてきます

bundle updateしろというので
bundle updateしたら,bundle update activerecordしろと言われ
bundle update activerecordしたらbundle updateしろと振り出しに戻ります

これはどうすればよいのでしょうか?

どなたも解決ができなようですが、わかる方いませんでしょうか?

$ bundle install
Your Gemfile lists the gem settingslogic (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Fetching gem metadata from https://rubygems.org/.......
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "rspec-core":
  In snapshot (Gemfile.lock):
    rspec-core (= 3.8.0)

  In Gemfile:
    guard-rspec was resolved to 4.7.3, which depends on
      rspec (< 4.0, >= 2.99.0) was resolved to 3.8.0, which depends on
        rspec-core (~> 3.8.0)

    rspec-rails (~> 3.7.2) was resolved to 3.7.2, which depends on
      rspec-core (~> 3.7.0)

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

$ bundle update
Your Gemfile lists the gem settingslogic (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Fetching gem metadata from https://rubygems.org/.......
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies................
Using rake 12.3.1
Using concurrent-ruby 1.0.5
Using i18n 0.9.5
Using multi_json 1.13.1
Using activesupport 3.2.14
Using builder 3.0.4
Using activemodel 3.2.14
Using erubis 2.7.0
Using journey 1.0.4
Using rack 1.4.7
Using rack-cache 1.8.0
Using rack-test 0.6.3
Using hike 1.2.3
Using tilt 1.4.1
Using sprockets 2.2.3
Using actionpack 3.2.14
Using mime-types 1.25.1
Using polyglot 0.3.5
Using treetop 1.4.15
Using mail 2.5.5
Using actionmailer 3.2.14
Fetching activerecord 3.2.14
Downloading activerecord-3.2.14 revealed dependencies not in the API or the lockfile
(activesupport (= 3.2.14), activemodel (= 3.2.14), arel (~> 3.0.2), tzinfo (~> 0.3.29)).
Either installing with `--full-index` or running `bundle update activerecord` should fix
the problem.

In Gemfile:
  acts_as_list was resolved to 0.9.16, which depends on
    activerecord

$ bundle update activerecord
Your Gemfile lists the gem settingslogic (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Fetching gem metadata from https://rubygems.org/.......
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "rspec-core":
  In snapshot (Gemfile.lock):
    rspec-core (= 3.8.0)

  In Gemfile:
    guard-rspec was resolved to 4.7.3, which depends on
      rspec (< 4.0, >= 2.99.0) was resolved to 3.8.0, which depends on
        rspec-core (~> 3.8.0)

    rspec-rails (~> 3.7.2) was resolved to 3.7.2, which depends on
      rspec-core (~> 3.7.0)

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • buta_botti

    2018/10/04 17:55

    多少は自分で調べてから試したことを添えて質問したほうがいいと思います。丸投げが多い印象を受けます。

    キャンセル

  • kozica

    2018/10/04 17:56

    半日調べてます、、、

    キャンセル

  • buta_botti

    2018/10/04 17:57

    ではなおさら試したことを添えて質問したほうがいいと思いますよ。

    キャンセル

  • kozica

    2018/10/04 17:59

    ご指摘ありがとうございます。試したことは記載しておりますのでご確認頂けると幸いです

    キャンセル

回答 2

+1

guard-rspecrspecに依存していて、そのrspecver3.8.xのrspec-coreに依存しています。
rspec-railsver3.7.xのrspec-coreに依存しています。
このあたりからバージョン違いのrspec-coreをインストールしようとしているので
どっちかに合わせなさいというエラーが発生しているようです。

なので、rspec-coreに依存しているrspecrspec-railsをupdateすれば良さそうです。

bundle update rspec-rails rspec

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/05 14:28

    回答ありがとうございます。
    依存関係を色々試したところ、bundlerのバージョンの問題でした。
    bundlerのバージョンを下げることで解決できました。
    回答して頂きありがとうございました!

    キャンセル

check解決した方法

0

bundlerのバージョンを下げて解決

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Ruby

    9391questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 5

    3150questions