質問編集履歴

8

タイトル修正

2018/01/25 06:33

投稿

syo2369
syo2369

score25

test CHANGED
@@ -1 +1 @@
1
- SpringMVCプロジェクトの起動で失敗する。
1
+ SpringMVCプロジェクトのデプロイで失敗する。
test CHANGED
File without changes

7

初心者アイコンの追加

2018/01/25 06:33

投稿

syo2369
syo2369

score25

test CHANGED
File without changes
test CHANGED
File without changes

6

試したことを修正

2018/01/25 06:13

投稿

syo2369
syo2369

score25

test CHANGED
File without changes
test CHANGED
@@ -86,15 +86,13 @@
86
86
 
87
87
  「概要」→「プロパティ」
88
88
 
89
- ・- java-version: 1.6 → 1.8                     (1.8へ修正済み)
89
+ ・- java-version: 1.6 → 1.8へ修正
90
90
 
91
- ・- org.springframework-version: 3.1.1.RELEASE → 4.3.7.RELEASE (3.9.2.RELEASEへ修正済み)
91
+ ・- org.springframework-version: 3.1.1.RELEASE → 3.1.1.RELEASEのまま
92
92
 
93
- ・- org.aspectj-version: 1.6.10 → 1.8.10      (1.6.10のまま
93
+ ・- org.aspectj-version: 1.6.10 → 1.6.10のまま
94
94
 
95
- ・- org.slf4j-version: 1.6.6 → 1.7.24        (1.6.6のまま
95
+ ・- org.slf4j-version: 1.6.6 → 1.6.6のまま
96
-
97
- ※org.aspectj-versionとorg.slf4j-versionはそれぞれ検索かけてバージョンの確認をしました。
98
96
 
99
97
 
100
98
 

5

試したことの修正

2018/01/25 04:20

投稿

syo2369
syo2369

score25

test CHANGED
File without changes
test CHANGED
@@ -90,9 +90,11 @@
90
90
 
91
91
  ・- org.springframework-version: 3.1.1.RELEASE → 4.3.7.RELEASE (3.9.2.RELEASEへ修正済み)
92
92
 
93
- ・- org.aspectj-version: 1.6.10 → 1.8.10      (何を参考修正すればよいかわからず
93
+ ・- org.aspectj-version: 1.6.10 → 1.8.10      (1.6.10のまま
94
94
 
95
- ・- org.slf4j-version: 1.6.6 → 1.7.24        (何を参考修正すればよいかわからず
95
+ ・- org.slf4j-version: 1.6.6 → 1.7.24        (1.6.6のまま
96
+
97
+ ※org.aspectj-versionとorg.slf4j-versionはそれぞれ検索かけてバージョンの確認をしました。
96
98
 
97
99
 
98
100
 

4

動的プロジェクト⇒動的Webプロジェクトへ変更

2018/01/25 03:49

投稿

syo2369
syo2369

score25

test CHANGED
File without changes
test CHANGED
@@ -76,7 +76,7 @@
76
76
 
77
77
  ・JavaScript 1.0にチェック
78
78
 
79
- (動的プロジェクトでデプロイに成功している設定に合わせました)
79
+ (動的Webプロジェクトでデプロイに成功している設定に合わせました)
80
80
 
81
81
 
82
82
 

3

現在試していることの追記

2018/01/25 03:45

投稿

syo2369
syo2369

score25

test CHANGED
File without changes
test CHANGED
@@ -80,6 +80,22 @@
80
80
 
81
81
 
82
82
 
83
+ ④以下のサイトを参考にpom.xmlを開いて、依存関係のバージョンを変更しています。
84
+
85
+ ⇒https://qiita.com/Munets/items/386ce6c7cd49fb4b5a0e
86
+
87
+ 「概要」→「プロパティ」
88
+
89
+ ・- java-version: 1.6 → 1.8                     (1.8へ修正済み)
90
+
91
+ ・- org.springframework-version: 3.1.1.RELEASE → 4.3.7.RELEASE (3.9.2.RELEASEへ修正済み)
92
+
93
+ ・- org.aspectj-version: 1.6.10 → 1.8.10      (何を参考修正すればよいかわからず)
94
+
95
+ ・- org.slf4j-version: 1.6.6 → 1.7.24        (何を参考修正すればよいかわからず)
96
+
97
+
98
+
83
99
  ### 補足情報(FW/ツールのバージョンなど)
84
100
 
85
101
  Pleiades Eclipse 4.6 neon
@@ -88,6 +104,8 @@
88
104
 
89
105
  payara-4.1.2.174
90
106
 
107
+ Spring Tool Suite(STS) for Eclipse 3.9.2 RELEASE
108
+
91
109
 
92
110
 
93
111
  問題タブにプロジェクトに関するエラー、警告は出ていません。

2

該当ソースコードの削除

2018/01/25 03:30

投稿

syo2369
syo2369

score25

test CHANGED
File without changes
test CHANGED
@@ -38,15 +38,7 @@
38
38
 
39
39
 
40
40
 
41
- ### 該当のソースコード
42
41
 
43
-
44
-
45
- ```ここに言語名を入力
46
-
47
- ソースコード
48
-
49
- ```
50
42
 
51
43
 
52
44
 

1

試したことの追記

2018/01/25 02:52

投稿

syo2369
syo2369

score25

test CHANGED
File without changes
test CHANGED
@@ -52,21 +52,31 @@
52
52
 
53
53
  ### 試したこと
54
54
 
55
- 以下のサイトにある作業。
56
55
 
57
- https://argrath.ub32.org/annex/2016/04/14-02.html
58
56
 
59
- ・サーバータブのローカル・ の GlassFish 4」とか出る行を右クリック
57
+ は実行環境 CDC-1.0/Foundation-1.0 を指定しています。この環境と厳密に互換性のあるワークスペースにインストールされた JRE がありません。」と警告がでいた。
60
58
 
61
- ・「プロパティー」選択
59
+ 以下のサイトの対応実施。
62
60
 
63
- ・プロパティー画面の「GlassFish」を選択
64
-
65
- ・「Use JAR archives for deployment」のチェックを入れる
61
+ ⇒https://detail.chiebukuro.yahoo.co.jp/qa/question_detail/q14126977909
66
62
 
67
63
 
68
64
 
65
+ ②以下のサイトにある作業。
66
+
67
+ ⇒https://argrath.ub32.org/annex/2016/04/14-02.html
68
+
69
+  ・サーバータブの「ローカル・ホスト の GlassFish 4」とか出てる行を右クリック
70
+
71
+  ・「プロパティー」を選択
72
+
73
+  ・プロパティー画面の「GlassFish」を選択
74
+
75
+  ・「Use JAR archives for deployment」のチェックを入れる
76
+
77
+
78
+
69
- プロジェクト・フォセットの設定
79
+ プロジェクト・フォセットの設定
70
80
 
71
81
  ・GlassFish Web Extensions 4.0にチェック
72
82